XamarainShellPackage did not load correctly in VS 2015

Jean-DanielGasserJean-DanielGasser CHMember ✭✭
edited May 2015 in Visual Studio

Hello,
I try to use Xamarin with VS 2015, but even after several uninstall/install/repair of Xamaribn and Visual Studio, when I launch VS 2015 the following message appears: "The 'XamarinShellPackage' did not load correctly". (See 'ActivityLog.xml' attached.)

That is the first error message, second message appears when I want to create a new solution based on Xamarin, it cannot create the iOS and Android projects and display the following message : "A problem was encountered creating the sub project 'xxx.iOS'. Required service 'EnvDTE.DTE' not found.

Can you please help resolve that problem ?

Thank you in advance

J-D Gasser

Best Answer

«1

Answers

  • JonathanHarrisonJonathanHarrison GBUniversity

    I am seeing the same with Visual Studio 2015 RC. It was previously working under Visual Studio 2015 CTP 6.

  • Jean-DanielGasserJean-DanielGasser CHMember ✭✭
    edited May 2015

    Hello Jonathan,
    You're right, I now use VS 2015 RC and I know that it worked before with CTP 6. But unfortunately, I cannot confirm the error came since installation of RC.
    I'm actually installing VS 2013 to continue my tests. I hope it will work with VS 2013.

    But as I am a programmer, the best for me is to understand the root of the problem ;) .

  • JonathanHarrisonJonathanHarrison GBUniversity

    I have just done the same with VS 2013 and seeing the same issue as with VS 15.

  • GrandyNguyenGrandyNguyen USMember

    Same issue. Same error on VS 2013 and VS 2015 RC

  • Jean-DanielGasserJean-DanielGasser CHMember ✭✭

    Hello,
    I just finished the installation of VS 2013 and ... you're both right. I have the same issue with VS 2013 and VS 2015.

    Can anybody help me ?

  • Jean-DanielGasserJean-DanielGasser CHMember ✭✭

    In order to analyze this behavior, I ran "devenv /setup /log %temp%\devenv.log

    Please find the log attached.

    I hope this will help somebody to diagnose root of the problem.

  • Jean-DanielGasserJean-DanielGasser CHMember ✭✭

    After reinstalling the whole computer (Surface Pro 3) from scratch with Windows 8.1, I then installed VS 2015 and at least Xamrin, the error persists !

    I will contact Xamarin support directly and keep you inform if they find a solution.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    HI,

    Can you all try the steps in this trouble shooting guide?
    https://kb.xamarin.com/customer/portal/articles/1643349-missing-visual-studio-extensions-after-installation

    Thanks!

  • FernandoRibeiroFernandoRibeiro BRMember, Developer Group Leader

    Hello friends.
    I have the same problem of Gasser. I can not create a template for Android and iOS. I installed Xamarin, already noticed, I changed already installing support for visual studio 2015 preview. Following is the photo of the error. Is it because of the preview version of Visual Studio?

    Can anyone help me?

  • Jean-DanielGasserJean-DanielGasser CHMember ✭✭

    Hello Jon, hello Fernando,
    Thank you for your assistance, I'm actually in contact with Patrick at Xamarin's support.

    Fernando's problem semms to be exactly the same as mine.

    I will keep you inform as soon as we find the solution.

    Greetings

    J-D Gasser

  • NathanGuerinNathanGuerin USMember
    edited May 2015

    @VGA I ran this, only choosing to install the VS Extension instead of the whole package. Would it be possible to push a fix to the steady channel for the VS Extension or just distribute the VS Extension instead of the whole package? I'd prefer to stay on the stable channel instead of the alpha channel for the rest of the project.

    So, also, the it did fix the error that was reported at the top, but VS fails (for me) on Project Creation with "Cannot find Mono Android reference assembly, looked here: [path to file]".

    Later Edit (5/15)
    Switched channel to Beta. A new version of Xamarin was downloaded that included an update to the VS plugin. Fixes the problems above.

  • Jean-DanielGasserJean-DanielGasser CHMember ✭✭

    Hello,
    After a lot of work with the support, the installer above did fix the error:
    http://download.xamarin.com/XamarinforVisualStudio/Windows/Xamarin.VisualStudio_3.11.446.msi

    I did not try with the one purposed by VGA, but I'm quite sure it will also solve the problem.

    Thank you everybody for the support, I will accept VGA's answer as solution.

    Greetings

    J-D Gasser

  • KumarGautamKumarGautam USMember

    Hello Gasser,

    Thanks for you above solution, It works perfect for me. I was struggling very hard for this issue.

    Thanks
    Kumar Gautam

  • MaksymShykovMaksymShykov USMember

    Hi,

    Thanks for fix. Issue has gone

  • zebra-brzebra-br USUniversity ✭✭

    Was working OK using VS2015 RC on Windows 10 Pro Insider Preview Build 10074.
    On shutting down 2 days ago Windows automatically started an update to Build 10130.
    That trashed Visual Studio, so did complete uninstall of Xamarin & Visual Studio & reinstall of both.
    No joy so kept searching and found this topic. Tried the new msi above, but still doesn't work
    So current Xamarin with VS2015 RC on Windows 10 Pro Insider Preview Build 10130 doesn't work.

  • zebra-brzebra-br USUniversity ✭✭

    Update: After applying the above msi still got the Xamarin Shell Load error, but after a system reboot that error did not display on startup of VS2015. However, on attempting to create an Android project, got some error dialogs about XamarinAndroidPackage not loading correctly .

  • VictorGarciaAprea.9996VictorGarciaAprea.9996 USXamarin Team Xamurai

    Hi zebra,

    Which version of XamarinVS are you running? (Help->About in VS)

    Can you please install this build (don't pay attention to the version in the URL, it's actually a newer one):
    http://xvs.xamarin.com/Xamarin.VisualStudio_3.11.524.msi

    And let me know if that fixes your load package issues?

    thanks

  • BenoitJadinonBenoitJadinon BEMember ✭✭

    works for me with http://xvs.xamarin.com/Xamarin.VisualStudio_3.11.524.msi , auto updated with 3.11.590
    thanks

  • RBrianLindahlRBrianLindahl USMember ✭✭

    had the same problem on a fresh 2015 install. updated to beta channel, works fine.

  • Xamarin-IanXamarin-Ian USMember, Xamarin Team Xamurai

    Hello everyone,
    We are working on our support for Visual Studio 2015 and currently Visual Studio 2015 is at the RC (Release Candidate) stage from Microsoft. At this time we are aware of several issues with running Xamarin with Visual Studio 2015 RC and we are recommending that folks stay with Visual Studio 2013.

    Visual Studio 2015 RTM is slated for July 20, 2015 and we are working to ensure we will have new builds of Xamarin that will work with 2015 RTM. http://blogs.msdn.com/b/somasegar/archive/2015/06/29/save-the-date-visual-studio-2015-rtm-on-july-20th.aspx

    If you are in the Microsoft Visual Studio TAP program please reach out to me and send me a message, so we can discuss if we can provide you with private builds of Xamarin Visual Studio that will work with Microsoft's private builds that are newer than the Visual Studio 2015 RC.

  • VictorGarciaAprea.9996VictorGarciaAprea.9996 USXamarin Team Xamurai

    One clarification: for anyone running VS 2015 post-RC builds (not public builds), you are already getting the latest and greatest Xamarin bits you can have for that specific VS 2015 build.

    thanks

  • LeonardoGarciaLeonardoGarcia USMember

    Runnin VS as an administrator fixed it for me.

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    @VictorGarciaAprea.9996 and @Xamarin-Ian I see this thread is more than a year old. Then why the hell I am getting it now. Probably me only.

    I just updated the Xamarin.Forms NuGet packages in my solution after updating the XamarinVS to ver. 4.2.0.680. When closed VS2015 to restart it, I got this error while saving the solution changes. Then on the .Droid project is showing as 'incompatible'. I tried repairing Xamarin install and VS2015 but of no help. Then I tried running a month old version my solution but the same result.

    Here is the error in the file "C:\Users\\AppData\Roaming\Microsoft\VisualStudio\14.0\ActivityLog.xml". I have attached the file also. Please remove the .txt before opening it.


    727

    Error

    VisualStudio
    LegacySitePackage failed for package [XamarinAndroidPackage]Source: 'Xamarin.AndroidTools' Description: Method not found: 'Void Mono.AndroidTools.AnalyticsService.ReportContextProperty(System.String[], System.String[])'. System.MissingMethodException: Method not found: 'Void Mono.AndroidTools.AnalyticsService.ReportContextProperty(System.String[], System.String[])'. at Xamarin.AndroidTools.MonoDroidSdk.Refresh(String runtimePath, String binPath, String bclPath) at Xamarin.AndroidTools.MonoDroidSdk.GetSdk() at Xamarin.AndroidTools.AndroidSdk.<>c.<GetInstalledPlatformVersions>b__66_1(AndroidVersion version) at System.Linq.Enumerable.<>c__DisplayClass6_01.&lt;CombinePredicates&gt;b__0(TSource x)&#x000D;&#x000A; at System.Linq.Enumerable.WhereArrayIterator1.MoveNext() at System.Linq.Enumerable.Any[TSource](IEnumerable`1 source) at Xamarin.VisualStudio.Android.Services.AndroidToolsSdk.CheckInstalledPlatformVersions() in C:\data\lanes\3513\c4382f51\source\xamarinvs\src\Core\VisualStudio.Android\Services\AndroidToolsSdk.cs:line 374 at Xamarin.VisualStudio.Android.Services.AndroidToolsSdk.CheckAndroidSdkSettings() in C:\data\lanes\3513\c4382f51\source\xamarinvs\src\Core\VisualStudio.Android\Services\AndroidToolsSdk.cs:line 367 at Xamarin.VisualStudio.Android.Services.AndroidToolsSdk.Start() in C:\data\lanes\3513\c4382f51\source\xamarinvs\src\Core\VisualStudio.Android\Services\AndroidToolsSdk.cs:line 311 at Xamarin.VisualStudio.Android.XamarinAndroidPackage.Initialize() in C:\data\lanes\3513\c4382f51\source\xamarinvs\src\Core\VisualStudio.Android\XamarinAndroidPackage.cs:line 134 at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)
    {296E6A4E-2BD5-44B7-A96D-8EE3D9CDA2F6}

    80131513

    <errorinfo></errorinfo>
    

  • @ShantimohanElchuri I Have the exact same problem, this update broke everything

  • DarkSummonDarkSummon USMember ✭✭

    @VictorGarciaAprea.9996 said:
    Hi guys,

    Can you please give this MSI a try and let us know?

    http://xvs.xamarin.com/Xamarin.VisualStudio_3.11.524.msi

    We are seeing a few boxes having the XamarinShellPackage load failure in VS 2015 RC and so far the above MSI fixes it.

    thanks,
    -VGA.

    Thanks! Tried everything and nothing worked - this did :) :)

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    @DarkSummon This is an old thread and the msi referred in is ver 3.11.524. Currently the Xamarin is in ver 4.2.695. So you may be loosing lot of bug fixes.

    I have come to know of a known bug in VS as given in bugzilla.

    For me I have to delete all the ComponentModelCache files at the directory C:\Users\\AppData\Local\Microsoft\VisualStudio\14.0\ComponentModelCache resolved the issue. But I will have to do this every time either before starting or after closing VS. That's the only hitch till the bug is resolved.

  • DarkSummonDarkSummon USMember ✭✭

    @ShantimohanElchuri Nope, that didn't work for me either - it was the first thing I tried. As said, the only thing that resolved this annoying issue, was installing that fix/release. I've had no problems with anything Xamarin related since :smile:

  • scotch83scotch83 BEMember

    Hello, please where is it possible to find the installers for previous versions of Xamarin?
    Here you are posting one of these, but to find back others is quite difficult, if not impossible.
    Best regards

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    @scotch83 said:
    Hello, please where is it possible to find the installers for previous versions of Xamarin?
    Here you are posting one of these, but to find back others is quite difficult, if not impossible.
    Best regards

    Yep, it is really not possible to find the older versions of Xamarin VS on our own. Some Xamarin guy have to post the link.

  • GregKowieskiGregKowieski USUniversity ✭✭

    This is my conclusion. it doesn't have any specifics about what to do, but more of a suggestion of what is happening. The specifics of my situation was a complete un-install of VS2015 and Xamarin including the Android SDK, (although I don't think the android-sdk had anything at all to do with it).

    First and foremost, the issue really looks like it all started due to a push from MS to upgrade the Xamarin from version 3, (a Xamarin release), to 4, (the MS Xamarin release). This really buggered up the whole dev environment. Most likely because the MS Xamarin toolkit was expecting dlls and extension from MS and not from pre MS acquisition, (which I had kept mine at pre-acq due to all the troubles I had when the first 4.x was released).

    Standard un-install of VS2015 and Xamarin did not do the trick as the Xamarin tools didn’t completely un-install. Particular, the VS2015 apparently keeps a crap-ton of appdata that just doesn’t go away. So, the Total uninstall of VS2015 appears to have been the secret to success. Although, you just can’t have it easy…., the Xamarin un-install didn’t remove the Xamarin Bonjour service from the services.

    So, every attempt to re-install VS2015 xamarin component would fail giving me the error about not having access to install some service. I traced it down to the bonjour service. Using the Xamarin 4x installer, I couldn’t get the service to install there either with the same error as VS2015 was throwing. Luckily, I had a bojour directory, (probably from Xamarin early days), that had the executables for bonjour. I manually removed the old bonjour services, (I had two. Bonjour and Xamarin Bonjour). Using mDNSResponder.exe I was able to install a new Bonjour service. I then ran the Xamarin installer to see if it would let me install the Xamarin bonjour service. It did! So I un-installed the Xamarin bonjour service and attempted to install the VS2015 xamarin component again. This time it worked.

    The only left overs were the JDK compatibility with the new ms Xamarin dlls. I had to update JDK to 1.8 per http://stackoverflow.com/questions/36457947/java-lang-unsupportedclassversion-error-in-xamarin-studio. Funny thing is though. The x86 version didn’t work. But the 64 bit version did.

    I was able to finally able to compile and deploy one of my critical projects.

  • njayawanjayawa USMember ✭✭

    I get this same error in Visual Studio 2017 RC, when trying to create a cross platform App. Any suggestions?

  • AresLazarusAresLazarus USMember ✭✭

    @ShantimohanElchuri said:
    @DarkSummon This is an old thread and the msi referred in is ver 3.11.524. Currently the Xamarin is in ver 4.2.695. So you may be loosing lot of bug fixes.

    I have come to know of a known bug in VS as given in bugzilla.

    For me I have to delete all the ComponentModelCache files at the directory C:\Users\\AppData\Local\Microsoft\VisualStudio\14.0\ComponentModelCache resolved the issue. But I will have to do this every time either before starting or after closing VS. That's the only hitch till the bug is resolved.

    This worked for me on VS2015 for Xamarin 4.2.1.64, many thanks.

  • ShantimohanElchuriShantimohanElchuri USMember ✭✭✭✭✭

    @AresTerzopoulos Good that I was helpful.

    But unfortunately @mohitkheterpal has closed the Bug #44300 in Bugzilla as Verified Fixed based on the Comment #36 which stated that it was 'Fixed in version 4.2.0.743 (cycle8)'. But unfortunately it is found to be not fixed even in XVS 4.2.1.64.

    Any explanation???

  • KevMooreKevMoore GBMember

    Hi Guys. Any progress on this? Taking the benefit of the doubt, I did a complete re-install of VS2015 update 3. This didn't work, and I installed the recommended MSI from above (3.1x) and this works, however as my MacBuild has been upgraded to the latest Xamarin, the build host does not work. I have installed the latest BETA MSI, and now get the old "XamarinShellPackage" package did not load correctly. I then re-tried clearing down the ComponentModelCache and restarted, but the error still persists.

    I really don't want to have to downgrade my Mac Xamarin build.

    Is there anyone from Xamarin who can shed any light?

  • AlanClarkAlanClark USForum Administrator, Xamarin Team Xamurai

    @KevMoore Could you please try the the following to thoroughly uninstall and reinstall Xamarin?

    To remove Xamarin completely:
    https://developer.xamarin.com/guides/cross-platform/getting_started/visual_studio_with_xamarin/troubleshooting/uninstall-xamarinvs/

    I'll DM you a link for the latest Stable release to reinstall after a reboot!

  • KevMooreKevMoore GBMember

    Thanks Alan. Trying now. Will keep you posted....

  • KevMooreKevMoore GBMember

    Hi Alan.

    Right, followed the instructions to the letter. Unfortunately, I am still getting the same error :( Shall I DM the activity log from VS?

    Really, very frustrating :(

    cheers

    Kev

  • GautamJainGautamJain INMember ✭✭✭
    edited February 2017

    Uninstalled Xamarin
    Uninstalled VS 2015
    Deleted registry key HKEY_CURRENT_USER\SOFTWARE\Microsoft\VisualStudio\14.0 and also HKEY_LOCAL_MACHINE
    Deleted folder under Appdata\Local\Microsoft\VisualStudio\14.0
    Downloaded and installed VS+Xamarin from Xamarin website

    It worked!

  • AlexStrongAlexStrong GBMember ✭✭

    I installed the latest Xamarin Update that appeared today, cant even remember what it was since it is not written anywhere but now I am facing this issue and can't get anywhere with it. Tried everything! I cant believe I am going to have to completely uninstall VS to sort out what this updated has caused!! So annoyed right now.

«1
Sign In or Register to comment.