iPhoneSimulator build results in "No valid iOS code signing keys found in keychain."

JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

Previous versions of Xamarin.iOS (8.9.x and earlier) incorrectly assumed that if the Entitlements.plist file in your project had no keys set, then the app did not need to be signed for use with the iOS Simulator.

This, however, was wrong. The problem is that Entitlements also need to be merged from the selected Provisioning Profile, so simply checking the contents of the Entitlements.plist file was not enough.

Starting with Xamarin.iOS 8.10, if the Entitlements.plist file is set at all for the iPhoneSimulator build configuration, then codesigning is required and thus an iOS code signing certificate is required to be installed in your keychain.

If you do not need your iOS Simulator builds to codesign (because you do not need to test any Entitlement features), then you can go into the iOS Bundle Signing options panel within your Project Options and remove the "Entitlements.plist" value from the Custom Entitlements textbox.

«1

Posts

  • derFranzderFranz DEMember

    problem solved, thx :)

  • AgataAgata USMember ✭✭

    Worked for me, thanks!

  • JohnAlbano.6183JohnAlbano.6183 USMember
    edited May 2015

    I am having this problem with our AppStore build. It was working fine a couple weeks ago -- submitted to apple -- and it got approved over the weekend -- now working on an update. I can't remove the entitlements.plist as suggested here because this is our app store build. Any thoughts? We're using the Xamarin Studio, not VS.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @JohnAlbano.6183, the App Store build is built for iPhone device, whereas this thread is only about the iPhone simulator deployment scenario. The error message in your case therefore mostly likely means that you do not in fact have a valid App Store signing key in your Mac's keychain. See for example http://forums.xamarin.com/discussion/comment/63318/#Comment_63318 for some additional troubleshooting steps for that (different) issue. One possible cause is that your App Store signing certificates might have expired.

  • MichaelLeung.3031MichaelLeung.3031 AUMember ✭✭

    After I did these changes, all ipad options are gone

  • MichaelLeung.3031MichaelLeung.3031 AUMember ✭✭

    It used to be, I can fire the ipad simulator from visual studio

  • MichaelKnappMichaelKnapp USMember
    edited June 2015

    The proposed solution does not work for me in Ad Hoc and AppStore builds. Is there any update?

    Nm - looks my distribution cert actually expired - this post was super helpful in resolving the problem: http://forums.xamarin.com/discussion/comment/63318/#Comment_63318

  • RaulArevaloLunaRaulArevaloLuna MXMember

    Hello World... In my cross platform solution created in Visual Studio 2013 I have the Build error: No valid iOS code signing keys found in keychain.

    How can I find the .csproj file to edit?
    Where can I see the file to opend?

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    It used to be, I can fire the ipad simulator from visual studio

    MichaelLeung.3031, the closest related issue I've run into myself is Bug 30646. To double-check if you might be hitting that issue, you can look under "Project properties -> iOS Application -> Devices". If that field is set to "iPhone/iPod", then the iPad simulators will not appear in the device selection drop-down menu. You will need to change the value to "iPad" or "Universal" to see iPad simulators in the drop-down menu.

    If the issue you're seeing is different from Bug 30646, then the most direct way forward would be if you get a chance to file a new bug for the specific problem you are seeing (ideally including a test case and a list of steps to reproduce). (If that link redirects to the top-level kb.xamarin.com/ page the first time you click it, try clicking it once more.) Thanks!

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    RaulArevaloLuna, the first hit on Google for "how to edit .csproj file" is a suitable answer from StackOverflow:

    http://stackoverflow.com/questions/5129090/how-to-edit-csproj-file/5129214#5129214.

  • FerAntiveroFerAntivero USMember

    @jstedfast and @JohnMiller it works like a charm in VS2015RC!

  • MaurilioFilhoMaurilioFilho BRMember

    The version that came out yesterday on the site https://releases.xamarin.com/alpha-release-cycle-5-service-release-2/
    Already comes with this corrected functionality, is so Xamarin change the update channel for the Alpha version and wait for the installation, and this well to stable version !! The production version due out until the middle of this month !!

  • jonathanyatesjonathanyates GBMember ✭✭✭

    I am getting the same error. 'No valid iOS code signing keys found in keychain'. I have removed the Entitlements.plist out of the csproj by editing it. But I still get this error when trying to deploy to my iPhone. This is on a new MacBook btw. I followed the XCode provisioning again to the letter and all that looks good, but still the same error. This is running on either W8 or W10 with VS2015. I currently can not test my app on my iphone due to this error. Can anyone help me please?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    @jonathanyates

    You MUST codesign for iPhone deployment. Removing the Entitlements.plist only "fixes" this for iPhoneSimulator.

    You'll need to go to https://developer.apple.com and create a development certificate to use for deploying to your iOS device for testing.

  • jonathanyatesjonathanyates GBMember ✭✭✭

    Yes I've done all that. I followed this to the letter:

    http://developer.xamarin.com/guides/ios/getting_started/installation/device_provisioning/

    I have my iPhone set up against my provisioning profile which is shown in XCode. I've tried with both wildcard and specific AppID's. Still doesn't work.

    Is there some other magic I need to do?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Those are provisioning profiles, not codesigning certificates. You need both. The error is about a missing codesigning certificate.

    If you created a certificate, you need to make sure to import it into your keychain.

  • jonathanyatesjonathanyates GBMember ✭✭✭

    Where is the documentation for this it is not described in the provisioning link above?

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    As a little test, you can also try deploying a new blank Xcode iOS project to the device from Xcode to make sure everything is working smoothly from that side.

  • jonathanyatesjonathanyates GBMember ✭✭✭

    Yes I have followed all of that. See attached screenshot for what I have showing in XCode Account.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    You do not have an "iOS Development" certificate. That's the problem. You only have one for Mac.

  • jonathanyatesjonathanyates GBMember ✭✭✭

    Really? I think I do. This is what is showing in the Dev Center. See attached.

  • jonathanyatesjonathanyates GBMember ✭✭✭

    Why does XCode not show this?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Those are provisioning profiles (the website UI is really confusing). The Xcode screenshot shows pretty clearly that you do not have an iOS Development certificate - or, if you do, it's not installed on your machine.

    If you had an iOS development certificate in your keychain, it would show up in Xcode as "iOS Development", but you do not have that. You have "Mac Development" instead, which is not the same thing.

  • jonathanyatesjonathanyates GBMember ✭✭✭

    But on the dev centre it shows the iOS certs. XCode should pull this down when I do view details and refresh right, as described in the docs. What else can I do?

  • jonathanyatesjonathanyates GBMember ✭✭✭

    Remember this is a new mac. It was working on my old one.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Your Developer Center screenshot showed that you have iOS Development provisioning profiles. It did not show that you have iOS Development certificates.

    I know that on the left-hand side, it looked like you had selected development certificates, but what you were actually looking at were provisioning profiles. Look at the top of the right-hand side of the screen in your screenshot and you'll see that it says "iOS Provisioning Profiles (Development)".

    You need to create a new iOS Development certificate more-or-less the same way you created the "Mac Development" certificate on Apple's Developer Portal website.

  • jonathanyatesjonathanyates GBMember ✭✭✭

    I clicked the + in the accounts under the signing identities and it told me I have an iOS but on another machine and gave the the option to Revoke and Request. I clicked this and the iOS Development cert magically appeared in the list. And now solution builds without the error and I can deploy to my iPhone :)

    Thanks for your help.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Grats :-)

  • AntonDashivskyiAntonDashivskyi UAMember ✭✭

    Hi Xcode give possibility run application on device without certificate.
    can I do something like this in XS ?

  • KMullinsKMullins USMember, Xamarin Team Xamurai

    Hi @AntonDashivskyi,

    What you are looking for is our Free Provisioning document. It should help you do what you want.

    Kevin

  • AntonDashivskyiAntonDashivskyi UAMember ✭✭

    Don't work. I can run single application from Xcode, but still can't run from XS

  • VVOVVO USMember
    edited April 2016

    ... and 1 year after this thread was started, I'm still experiencing the "No installed provisioning profiles match the installed iOS code signing keys" error. At this point, I should probably just give up and create a Hitler Rant video on YouTube, since I've tried every workaround mentioned in this and other threads, and nothing worked :(

    I figure, if deploying from Xcode onto device works, but Xamarin fails with this stupid error - it's Xamarin's fault. Is it not??

  • DrCJonesDrCJones USMember

    I believe a more proper & simple solution (especially because things have changed so much) is to change the platform build configuration from iPhone to iPhoneSimulator.
    See here:
    http://stackoverflow.com/questions/32647815/no-valid-ios-code-signing-keys-found-in-keychain

  • JassimRahmaJassimRahma USMember ✭✭✭✭

    I have the same error when I try to archive but not when I build the app

    Kindly help..

    I am using Visual Studio for Mac

  • RobertAuerRobertAuer USMember ✭✭

    I'm also getting
    "No valid iOS code signing keys found in keychain. You need to request a codesigning certificate from developer.apple.com. BLE.Client.iOS" (and for what it is worth I can't get the android one to run as well)

    I tried to build the "empty" Xcode app to put on my iOS device, but I could not get that to work either. There are a number of posts on this forum and on stackoverflow, but they all seem to be out of date. None of them work.

    Please advise.

  • JohnHJohnH GBMember ✭✭✭✭✭

    @RobertAuer have you created the certificates and provisioning profiles that contain the device id for your iOS device?

  • RobertAuerRobertAuer USMember ✭✭

    @JohnHair Thank you for your response. I have created the certificate from developer.apple.com I'm not sure what you mean by device id. Are you aware of someplace that has a step by step document to explains this? Everything seems (to me) to be rather scattered.

Sign In or Register to comment.