Can't Archive or publish to appstore after going to 5.9

NicWiseNicWise NZMember, Insider, Beta mod

This is a project which has worked fine before.

If I archive, I see it in the list, I can generate an IPA, but the App Uploader will not accept it - "No Info.plist"

If I look in xcode (where I normally upload from, and would prefer to continue to upload from), it shows as a Mac archive. Can't upload, as it's the wrong time.

Is archive/publishing working for anyone? What did I miss?

Posts

  • CraigDunnCraigDunn USXamarin Team Xamurai

    Hey Nic,

    Anything special about the project (does it have an Extension or something, is it Watch Kit)? I can successfully Archive this in Xamarin Studio and view/validate/Submit it from within Xcode. That was just a quick smoke test I did ~ will test more in XS later.

    Which Xcode are you using (6.2, 6.3, 6.4 beta)? FYI I'm on 6.3.1.

  • NicWiseNicWise NZMember, Insider, Beta mod

    Ah yes. It has a Today Extension.

    Just installing 6.3.1 - I'm on 6.3 at the moment. Thanks @CraigDunn

    WatchKit starts once this one is uploaded and out. And my watch shows up

  • MichaelBluesteinMichaelBluestein USInsider, University, Developer Group Leader ✭✭✭

    After I created the archive in Xamarin Studio, I switched to Xcode and it's listed under Other Apps rather than iOS Apps. It shows the type as iOS App Archive and validates OK though

  • NicWiseNicWise NZMember, Insider, Beta mod

    I have a clue (still waiting for 6.3.1 to install): I have a console app in the project, too. That might be why it's showing up as a Mac app. Going to remove that and see what happens. It's just a database generator, so no need for it in the project really

  • CraigDunnCraigDunn USXamarin Team Xamurai

    Interestingly, I tried a Today Extension project too and I see the same as Mike ~ it's under "Other apps", but the Type is still iOS.

    image

    The watch kit apps are "Other Apps" too, so I wonder if that's because they all have Extensions?

    Let us know how it goes with 6.3.1...

  • NicWiseNicWise NZMember, Insider, Beta mod

    Mine says Mac app :( Even after removing the console app from the project.

  • NicWiseNicWise NZMember, Insider, Beta mod

    Right then. I've tried changing the Info.plist in the xcarchive - it changes other details, but not the type. Not sure what it DOES to detect it's a Mac app vrs an iOS app...

  • NicWiseNicWise NZMember, Insider, Beta mod

    GAH! So I:

    • Rebooted
    • Clean
    • Rebuild
    • Delete all the old archives

    And now it works. WTH. But I'll take it.

Sign In or Register to comment.