First foray into Xamarin - issues

JCFordJCFord USMember

I'm evaluating Xamarin for my team's first mobile app. I've installed all the requirements and I believe I have everything set up correctly.

I created a new solution using the template "Mobile Apps -> Blank App (Xamarin.Forms Shared)".

I was unable to get this basic "hello, world" app to run at all using any of the Android Virtual Devices I tried. I eventually downloaded Genymotion and it worked with that.

When I tried to run the app on an iPhoneSimulator I saw an error about provisioning profiles. A search on this forum led me to removing the entitlements node from the csproject file. Thereafter, it would run and launch the iPhone Simulator on the build host, but it will now only show a black screen on the simulator for a few seconds and then the simulator's home screen reappears. It never shows the "hello, world" text. This is the same no matter which iOS device I simulate.

Is this another known issue with a workaround? My searches didn't turn up anything.

Any help would be appreciated.

Posts

  • JCFordJCFord USMember

    Update: I ran the project successfully on a physical iPhone but it still crashes to the home screen on the simulator.

  • JCFordJCFord USMember

    Update: I reset the content on the iPhone Simulator and tried again and it ran.

    It's beginning to look like mobile development is going to be a test of patience.

  • DavidCarawayDavidCaraway USBeta ✭✭

    Also keep in mind that should Xamarin Forms prove too problematic you can still build the UI layer like all of us did prior to Forms. In fact, I still do not use Forms for my UI. I save a lot of time developing for multiple platforms even without Forms.

  • JCFordJCFord USMember

    Thanks. Yes, I did explore that a bit before looking into Forms. It had its own set of idiosyncrasies and gotchas, but since it's more mature than Forms I was able to find answers to most of them on the net.

Sign In or Register to comment.