Breakpoints not hitting in portable class library for iOS app

I can set breakpoints in Visual Studio 2013 for an iOS app and the breakpoints work correctly using Xamarin iOS Build Host and iphone simulator. However, if I set breakpoints in the portable class library that contains my Xamarin.Forms logic they never trigger (class library is in same solution). If I put Debugger.Break() in my code it breaks, but it doesn't break on the line of code in the library; instead it breaks on UIApplication.Main (args, null, "AppDelegate") in the iOS app.

FWIW, I tried this before and after updating to latest version of all Xamarin bits, but got the same result.

Here are all the version numbers on Windows:
Microsoft Visual Studio Premium 2013
Version 12.0.30723.00 Update 3

Microsoft .NET Framework
Version 4.5.51641

Xamarin 3.11.445.0 (5061f92)
Visual Studio extension to enable development for Xamarin.iOS and Xamarin.Android.

Xamarin.Android 5.1.0.115 (d23da369e436488f38c8ab8fe8a9ae7d9ea5256b)
Visual Studio plugin to enable development for Xamarin.Android.

Xamarin.Forms Intellisense 1.0
Provides intellisense for Xamarin.Forms in the XML editor.

Xamarin.iOS 8.10.0.0 (7741cc495ab0baf04ff0405d0604bc27f0ecae2e)
Visual Studio extension to enable development for Xamarin.iOS.

Xamarin.iOS Unified Migration 1.0
Automated migration for Xamarin iOS Classic projects to Unified

Xamarin.TestCloud.Integration 1.0
Early preview of Xamarin Test Cloud integration

Version numbers on Mac OS X:
OS X Yosemite
10.10.3

Xamarin.iOS 8.10.0.267

Build Host 3.11.0.446

Posts

  • tomnuentomnuen VNMember ✭✭

    I'm experiencing the same issue with latest Xamarin.iOS 8.10.0.267. Breakpoints not hit as well.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    I believe you're seeing the following issue that is now mentioned in the release announcement:

    Bug 29628 - [XamarinVS] [iOS] Breakpoints in Portable Class Libraries do not work because the .mdb symbol files are not copied properly. Related warning in the "Output -> Debug" window: "Symbol file ... doesn't match image". Workaround: force the .mdb files to be copied properly: https://bugzilla.xamarin.com/show_bug.cgi?id=29628#c5.

    If you try the workaround and it does work for you, let me know, and I'll close this thread to help make sure anyone else who might run across this thread can quickly find the list of other known issues in the XamarinVS 3.11.445 release.

  • HelmutLubikHelmutLubik DEUniversity ✭✭

    The same issue and the workaround doesn't work for me

  • jbunderwoodjbunderwood USMember

    The workaround does solve the problem for me. Thanks for pointing me to the necessary information.

  • SonNguyen.8158SonNguyen.8158 USMember, University ✭✭

    @BrendanZagaeski Your workaround from Bug 29628 solved the problem for me, and my coworker, who were both encountering this issue while using Xamarin 3.11.445 and Xamarin.iOS 8.10

  • jonathanyatesjonathanyates GBMember ✭✭✭

    The workaround works until you do an update for the latest stable X.iOS, then the workaround gets overwritten and breakpoints don't get hit again. I really can't believe that Xamarin have released another update without fixing this issue. I therefore have to reapply the workaround.

  • VictorHGarciaVictorHGarcia USUniversity ✭✭

    I fixed this issue by setting up in the PCL project this:

    Project Options -> Build -> compiler -> Debug information: "Symbols only"

    Hope this helps others.

    Thanks

  • JackRobsonJackRobson USMember
    edited July 2016

    Would this workaround work for Xamarin Studio on Mac? Not sure where to put the Xamarin.iOS.Common.After.targets file.

  • DWestDWest USMember

    @VictorHGarcia Thanks worked like a charm!!

Sign In or Register to comment.