Archive for publishing does nothing

ChristopherDrososChristopherDrosos GRMember ✭✭
edited April 2015 in Xamarin.Android

I have install the new version, but when im clicking on archive for publishing, archive all, view archives nothing happens.
It seems for a few seconds that something is happening but nothing is showing up
what am i doing wrong?

On build output i get 0 errors, View archives doesnt do anything at all

Posts

  • ChristopherDrososChristopherDrosos GRMember ✭✭

    Xamarin Studio version 5.9 (build 431)

  • Joost-van-HasselJoost-van-Hassel NLMember

    Same here: it seems the 'View archives' tab is not displayed after archiving and when 'View archives' is clicked.

    I suspect the problem to be caused by permissions; I have opened Xamarin Studio as Administrator once yesterday. To solve the problem, I relocated my project out of my documents folder and I've renamed it (so there is no cache of any archives).

    Hope this helps

  • ChristopherDrososChristopherDrosos GRMember ✭✭
    edited May 2015

    It was a problem with the beta (the project was created on a previous version), for me is solved now, i have file this bug here:
    https://bugzilla.xamarin.com/show_bug.cgi?id=29583
    For me the problem was some greek characters on the name of a folder

  • I am having the same problem the archive screen show no archives. I am using Xamarin Studio 5.9.5 build(10). The bug reported above is reported to have been fixed in this version. Please share what you did to fix this issue. Thanks.

  • Hello, in order to fix it i have change the date format of my windows from greek to english. If your date format has strange characters (like greek in my case) you will have problems. this is supposed to be fixed, you can try a beta version if this fix wont work

  • Greg767Greg767 CHMember ✭✭

    I am on XS 5.9.7 (build 9) and when I Archive for publishing its still doesn't show any archive!! Whats going on? The apk is put in the release folder by the way.

  • I use 5.9.6 and the local naming problem is fixed, it must be something else, what the ast 3 error logs say?
    check at C:\Users\YourName\AppData\Local\XamarinStudio-5.0\Logs

  • Greg767Greg767 CHMember ✭✭

    In the log directory I don't see any updated logs after having published for archiving, by the way I am on Mac.

  • no error at all? stange, report the bug to bugzilla

  • Greg767Greg767 CHMember ✭✭

    well I just created a new test project and archiving that creates an archive entry.... My current project was created with an older version of XS, so this could be the problem. But in this case I cannot reproduce the behavior, so I don't know if I can create a bug report with this.

  • EvanHarrisEvanHarris USMember

    Just resolved a very similar sounding issue. In our case the APK package name contained invalid characters (in our case the apk name contained a hyphen '-'). Although the APK would be built and placed in the bin directory, the archive tool did not complete and no error was produced.

    By changing the Package name in the Droid project from CUSTOMER-PRODUCT to CUSTOMER_PRODUCT we resolved the issue.

  • Greg767Greg767 CHMember ✭✭

    Thanks for your input. In my case the product id is xx.some.id so I guess its not the issue.

  • DannyNLDannyNL USUniversity ✭✭

    Thanks Evan. Had a "-" in a bundle id for my app.. Very annoying no feedback is given...

  • LaumaniaLaumania DKMember ✭✭✭

    I had a "-" in the bundle id too, changed it to a "." and it all worked now! :)

  • JonathanDibbleJonathanDibble GBMember ✭✭

    I've just had the same issue with a '-' in my package name. Thanks for sharing, you've help me resolve things.

  • ConorMurphyConorMurphy USMember ✭✭

    Same issue for me with the "-" in the package name. No error's where being thrown , just closed when i clicked next on the ad hoc screen.

    Thanks.

  • Had the same issue caused by my package name starting with a number. Android doesn't like that - I had to fix that somewhere else too. But this process needs to be fixed to give some feedback about errors like this. I would have never figured it out if I hadn't come across this thread!

Sign In or Register to comment.