Updated XS today, now Info.plist missing error in build

Simply ran stable updates today in Xamarin Studio for Mac.

the moments before updating, project was running fine, compiling, building, running.

Xamarin studio shuts down to restart after the update, now this info.plist missing error:

/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: error : Info.plist not found.

Posts

  • NealCulinerNealCuliner USBeta ✭✭✭

    I can't build either, but not related to info.plist - mine is a IBtool error. I wonder how many really beta tested this.

  • MrAPolkMrAPolk USMember
    edited April 2015

    I am also seeing this "Info.plist not found" error:

    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: Info.plist not found.

    Xamarin Studios Version: 5.9 (build 431)

    Xamarin.iOS Version: 8.10.0.267

  • MrAPolkMrAPolk USMember

    I was able to fix this issue by cleaning my projects, restarting Xamarin Studios and re-adding the Xamarin.iOS framework.

  • MarkWilkinson.4991MarkWilkinson.4991 USUniversity

    Tried the same, removed Xamarin.iOS from project, quit XS, restarted, cleaned all, re-added, still same error.

  • MrAPolkMrAPolk USMember

    Another step I forgot to mention was I also downloaded the previous version of Xamarin Studios (8.9.1) and Xamarin.iOS (5.8.3) and updated to the latest versions again.

    You can download the previous versions from here:
    https://store.xamarin.com/account/my/subscription/downloads

    Those were the only steps I took which caused the error to disappear.

    Hope this helps.

  • MarkWilkinson.4991MarkWilkinson.4991 USUniversity

    Was able to get it running again with your suggestion of going back to previous XS and iOS versions.

    Won't even try to upgrade again.

  • ChaseCarlileChaseCarlile USMember

    I'm also getting this error. Thanks for the info.

  • ChaseCarlileChaseCarlile USMember

    Also noticing that Visual Studio doesn't stop at breakpoints on my mac that can compile. Rolling back on that machine as well.

  • MarkWilkinson.4991MarkWilkinson.4991 USUniversity

    This seems to be a recurring problem for me, in my short time this year using XS. This is the first time however that after an update I was unable to get it resolved.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Follow my guide for getting diagnostic build logs and look for the FindItemWithLogicalName task. What files does it get as inputs? Is your Info.plist among them? If not, what is the BuildAction you have set on your Info.plist? Is it set to "None" like it is supposed to be?

  • MrAPolkMrAPolk USMember

    I started to get this error again this morning.

    I have attached the Build Output you suggested to the bug I raised regarding this issue found here:
    https://bugzilla.xamarin.com/show_bug.cgi?id=29579

  • MrAPolkMrAPolk USMember

    I found a work around solution to remove the error that seems to work reliably enough for me.

    If I completely close Xamarin Studios and open my workspace then build a project
    I get this issue.

    If I then open a empty test project it will build fine with no errors.

    Now if I reopen my workspace and build the same project it now builds successfully and I get no error.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    I suspect this has to do with the fact that you are using Workspaces. If you open a single Solution at a time, you will probably not hit this bug.

  • ShannonHaas.5932ShannonHaas.5932 USUniversity ✭✭

    I have also updated to XS 5.9 on Mac and IOS published to Archive with the same info.plist missing error when trying to use the Application Loader. I have successfully published just last week with my previous version of XS going through xcode 6.1.1 and Archive file process.

    I have verified that the info.plist property Build Action was set to 'None'. I have noticed when viewing the archive in xcode 6.3.1, it shows the archive type as 'Mac App Archive' and a missing Version Code.

    I notice that the info.plist properties has a 'Include in deploy', I have tried various combinations here. Should it be included in deploy? It was originally not checked and I have deployed successfully in the past.

  • JDLeonJDLeon ESMember

    the same mistake when updating XS 5.9. help

  • Same error occured here. Reverting back to previous version of Xamarin Studio and Xamarin iOS fixed the errors (thank god).

  • DanielBarrrosAmorimDanielBarrrosAmorim BRUniversity ✭✭

    I also got the same error. Should I back the XS version to 5.8.3 and iOS 8.9.1.3?

  • ShannonHaas.5932ShannonHaas.5932 USUniversity ✭✭
    edited May 2015

    Here is a link to another forum with the same issues.

    http://forums.xamarin.com/discussion/39452/cannot-build-ios-solution-in-xam-studio-5-9-stable

    Some options there but doesn't seem to be much as far as a consistent solution.

  • DiwakarSinghDiwakarSingh USMember

    Tried everything and still couldn't get it work, still getting the same error Info.plist could not be found.
    I am using

    Xamarin Studios Version: 5.9 (build 431)
    Xamarin.iOS Version: 8.10.0.267
    Xcode version 6.1

    Tried downgrading XS as well as Xamarin.iOS version as well, still the same error.

  • JoeyZacherlJoeyZacherl USMember ✭✭

    Same issue here, I fixed it by removing Xamarin and reinstalling monotouch-8.8.1.9 and XamarinStudio-5.8.1.8-0. I've been NOT updating to the Xamarin stable lately because there have been so many issues with the stable builds over the past few months.

  • JGoldbergerJGoldberger USMember, Forum Administrator, Xamarin Team, University Xamurai

    I am not sure if this will apply to everyone here, but I just found an odd issue where just moving my project out of the Documents directory to somewhere else resolved the issue with Info.plist not being found. For more details see my comment on the bug report:
    https://bugzilla.xamarin.com/show_bug.cgi?id=29579#c18

    I was able to move my project back to my Documents folder after I got my Documents folder to look correct in the Finder sidebar after rebooting my Mac and removing and re-adding the Documents folder in the Finder sidebar.

    Don't ask me how or why this worked, but I do see why it may have broken the build if the some things were looking in the wrong path, "~/documents" as opposed to "~/Documents", or so it would seem.

  • PaulJohnson.0531PaulJohnson.0531 GBMember ✭✭

    I'm building out of a dropbox folder and getting the info.plist error - makes no difference where the sources are held, same error.

  • GuiWaltrickeGuiWaltricke BRMember ✭✭

    The same error here... every xamarin update have an error.... this is horrible

    Screen:

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    If anyone could get diagnostic MSBuild logs for this using this build of Xamarin.iOS, that would be hugely helpful.

    http://storage.bos.internalx.com/macios-mac-macios-cycle5-missing-info.plist/53/53f9a49e17e0b42a707cee339ad0591223249e23/monotouch-8.10.1.57.pkg

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    This post explains how to get diagnostic build logs: https://forums.xamarin.com/discussion/27515/how-to-obtain-diagnostic-build-logs

  • ScottColestock.9238ScottColestock.9238 USMember ✭✭
    edited May 2015

    We started having this issue on both build server and local machines.

    We're finding that a fresh workspace on the build server (or fresh get of the repo when working locally) solves this issue for us.

    It would appear that the newer version of Xamarin Studio isn't working well with build cruft created by an older version. Building "clean" is insufficient to fix, but a brand new build tree is.

  • AaronBratcherAaronBratcher USMember ✭✭

    I'm see this error with XS 5.9.1 and Xamarin.iOS 8.10. I was able to fix the problem by installing Xamarin.iOS 8.9.1.

  • johnschwenkerjohnschwenker USMember
    edited May 2015

    Using XS 5.9 w/ Xamarin.iOS 8.10, getting this 'Info.plist not found' on build.

    On the diagnostic build logs I can see that Info.plist is included under FindItemWithLogicalName Task Items: Info.plist with Logical Name: Info.plist and the correct ProjectDir it is located. FindItemWithLogicalName repeats again with several Resources files under Items and Info.plist set to LogicalName. Finally, the 3rd iteration for FindItemWithLogicalName shows for Items and LogicalName set to Info.plist

    Also, my Info.plist Build Action is set to None

  • johnschwenkerjohnschwenker USMember

    I followed what Andrew and Mark attempted above. I downgraded to XS 5.8.3 and X.iOS 8.9.1.3, removed my iOS project and added it back, cleaned, built and received a new but familiar looking error:

    'Error initializing task FindItemWithLogicalNameTask: Not registered task FindItemWithLogicalNameTask'

    Updating back to the current versions for both XS and X.iOS yields the original error.

  • johnschwenkerjohnschwenker USMember

    I've fixed the issue (so far) by moving my project's folder location to another spot, then moving it back.

  • ReynaldoGalindoReynaldoGalindo USMember

    Just ran into this same issue, I had to remove the project from my local machine and then pull from my bitbucket repo. This worked last night, worked on the code, built fine. Then I started my Mac this morning and go to build the project and get the same info.plist issue. WTH

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Quick Fix:

    Edit your .csproj file change your Info.plist XML from:

    <None Include="Info.plist"/>
    

    to:

    <None Include="Info.plist">
        <LogicalName>Info.plist</LogicalName>
    </None>
    

    This bug seems to be a problem with symlinks. At least for the people who have responded to the bug report: https://bugzilla.xamarin.com/show_bug.cgi?id=29579

  • NealCulinerNealCuliner USBeta ✭✭✭

    Any "rumors" as to when these beta's are going to bubble up to stable?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Unfortunately the patch to compare file system paths case-insensitively will not make it into the SR1 release (Xamarin.iOS 8.10.1), but it will be in 8.10.2.

    The workaround in the meantime is to use the LogicalName solution.

  • IanVinkIanVink CAInsider, University ✭✭✭

    I solved it by closing the Workspace it was in, then openning the solution by itself.

  • joehannajoehanna AUBeta ✭✭

    I had the same issue opening a very old project (TweetStation actually!).

    Setting Info.plist "BuildAction = None" did the trick.

Sign In or Register to comment.