New Android Blank applications created in Xamarin Studio crash on first run.

SergeiGarciaSergeiGarcia MXMember, University
edited April 2015 in Xamarin.Android

They are giving Xamarin a chance on the company I work at for a Android/iOS project, and I've been tasked to learn as much as I can in the 1 month business trial.

I'm following along the "Hello, Android" quick start tutorial on:
https://developer.xamarin.com/guides/android/getting_started/hello,android/hello,android_quickstart/

I created a Blank Android application, made no edits whatsoever, and just to make sure everything was working I tried to run the app in debug mode after creating it, and before even opening it crashed instantly giving me a not too helpful "Unfortunately, App_Name_Here has stopped". I first tried debugging this on my physical android Device (Moto X, Android 5.0.1), and then on a Android Virtual Machine from AVD with Android 4.4.2 using the Nexus One device preset, and both tries crashed the app and gave the same message.

Also, I got the following 2 warnings:
C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets(2,2): Warning: No -tsa or -tsacert is provided and this jar is not timestamped. Without a timestamp, users may not be able to validate this jar after the signer certificate's expiration date (2044-07-25) or after any future revocation date. (BlankApp)
C:\Users\sergei.garcia.ortega\work\code\local\xamarinplaground\XamarinStudioPlayground\PhoneWord\Properties\AndroidManifest.xml: Warning XA4211: AndroidManifest.xml //uses-sdk/@android:targetSdkVersion '14' is less than $(TargetFrameworkVersion) ''. Using API-22 for ACW compilation. (XA4211) (PhoneWord)

According to another thread, I should ignore both warnings for now, but I admit I am rather concerned about the last warning's "Using API-22 for ACW compilation" since I never said explicitly to use API-22 for anything, and I already set Android 4.0 (API-14) as the minimum and target android version on the Manifest file. Also, I should point out this is not a device problem since previously today, I have successfully debugged a Xamarin.Android application on both the physical, as well as the Virtual device from Visual Studio following a Pluralsight Xamarin tutorial. I tried setting breakpoints on Main Activity.cs they aren't even entered. Does anyone know what's going on?

Sign In or Register to comment.