Cannot build iOS solution in Xam Studio 5.9 STABLE

2»

Posts

  • EldonTenorioEldonTenorio PHUniversity
    /Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: error : Error executing tool '/Applications/Xcode.app/Contents/Developer/usr/bin/ibtool': Argument cannot be null.
    Parameter name: unformatted
    

    I have been experiencing the same thing when I upgraded to 5.9.1 (build 3) lately, @jstedfast .

  • sawingsawing FRMember

    Someone find a solution to fixe it?

  • SergijSobol.9561SergijSobol.9561 USMember

    Got same bug! Any solution??

  • KentPickard.4186KentPickard.4186 USMember

    Downgrading to Xamarin.iOS 8.9.1 fixed the issue for me. I haven't tried 8.10.1.

    @jstedfast - We need to do a production release this week. Would you recommend we go with the last stable release that works (8.9.1) or should we go with a 8.10.1 alpha build?

  • EldonTenorioEldonTenorio PHUniversity

    Hi All,

    This is what I did:

    1. I downgraded my Xamarin Studio to 5.9 (April 30, 2015)
    2. I downgraded my Xamarin.iOS to 8.9.1 (April 14, 2015)
    3. Installed these two to my iMac.
    4. Opened my Solution file with XS.
    5. Build your solution successfully.
    

    I am attaching screenshots of the exact builds I have downloaded to downgrade my latest XS and Xamarin.iOS versions to.

    I hope this helps. Please let me know if these steps did.

    Many thanks.

  • sawingsawing FRMember

    @ebtenorio Thanks a lot for your solution, works perfectly. Since two week I look like how to fixe this bug.

  • EldonTenorioEldonTenorio PHUniversity

    Good to know, it works perfectly for you, @sawing. I hope Xamarin releases the latest builds that fixes this bug.

  • SamuelJocelynSamuelJocelyn USMember

    Hi,
    I too have been having this problem. So I went on upgrading both Xamarin Studio and XCode but the problem persists...
    I don't use Storyboards, but have several xib files. How do I locate which one is causing the problem?

    Thanks
    S

  • EldonTenorioEldonTenorio PHUniversity
    edited May 2015

    Hi @SamuelJocelyn, have you done the "workaround" I posted above? I am not sure if this is because of Xamarin.iOS or XS or both. But then when I downgraded to the previous build (shown as attachments in my post), building my app using those worked fine.

  • AlexSAlexS USUniversity ✭✭✭

    Using diagnostic build log I found which xib was producing "problem". Opened it and in properties saw it was for iOS 6 and up while project targets 7 and up. Fixed that, cleaned project and everything worked.

  • SamuelJocelynSamuelJocelyn USMember

    Thank you,
    I downgraded Xamarin IOS and Studio and the problem went away. I guess I will have to be careful Not to upgrade for a while until this is fixed for good.

  • EldonTenorioEldonTenorio PHUniversity

    @SamuelJocelyn, good to hear that. I will take note of that myself too:
    "Not to upgrade for a while until this is fixed for good."

  • RaduSimionescuRaduSimionescu USMember

    let this be a lesson to you all: never update to the latest version of Xamarin right away, unless you really have to. Wait at leas for a month.

  • MirMajeed.1120MirMajeed.1120 USMember, University

    This issue has been fixed in the latest xamarin studio beta build 5.9.2 (build 2).

  • MaurizioCaputoMaurizioCaputo ITMember

    Sorry for my english. I got the same error and worked out. Open the storyboard with TextEdit (notepad or something else you prefer) and discovered a reference to a missin barbuttonitem. Deleted the reference and everything works fine. Hope could help someone else.

Sign In or Register to comment.