Error ITMS-90096 "Your binary is not optimized for iPhone 5"

Hi,

When submitting a universal (iPhone/iPad) Xamarin Forms app to Apple's TestFlight, I'm getting the ITMS-90096 error code complaining about a missing iPhone5 launch image of 320x568. I have supplied all possible launch images in Visual Studio 2013, but makes no difference.

Is there anyway to solve this? Setting the app to iPad only makes it work on iPad, and setting it to iPhone only makes it fail as well.

Any help would be greatly appreciated!

«1

Answers

  • MichieldeRondMichieldeRond NLMember

    Here's a little update. I have not been able to get this working using Visual Studio. On the Mac, using Xamarin Studio I did finally get this working. As I had to copy my project to the Mac locally (due to other build errors), this is not ideal, but for now I can move forward.

    If anybody knows of a way to get this working from Visual Studio I would love to hear it.

  • NathanChannonNathanChannon GBMember ✭✭

    I've got this exact same problem. How can something so trivial hold up the whole submission process!?

    I amended the xcassets.launchimages contents.json and manually added a reference to an image specified in the error but it still doesn't work.

    Surely someone from Xamarin can answer this? :-s

  • NathanChannonNathanChannon GBMember ✭✭

    The description on the error has been updated by Apple with more clarity: You must include a launch image referenced in the info.plist under UILaunchImages with a UILaunchImageSize value set to 320, 568.

    That's their description of the error. My info.plist launchimages are below (notice they include that image and 2x version as well.

    Can anyone shed any light on this?

    Thanks

    <key>UILaunchImages</key>
        <array>
            <dict>
                <key>UILaunchImageMinimumOSVersion</key>
                <string>7.0</string>
                <key>UILaunchImageName</key>
                <string>Default</string>
                <key>UILaunchImageOrientation</key>
                <string>Portrait</string>
                <key>UILaunchImageSize</key>
                <string>{320, 480}</string>
            </dict>
            <dict>
                <key>UILaunchImageMinimumOSVersion</key>
                <string>7.0</string>
                <key>UILaunchImageName</key>
                <string>Default</string>
                <key>UILaunchImageOrientation</key>
                <string>Landscape</string>
                <key>UILaunchImageSize</key>
                <string>{320, 480}</string>
            </dict>
            <dict>
                <key>UILaunchImageMinimumOSVersion</key>
                <string>7.0</string>
                <key>UILaunchImageName</key>
                <string>Default-568h</string>
                <key>UILaunchImageOrientation</key>
                <string>Portrait</string>
                <key>UILaunchImageSize</key>
                <string>{320, 568}</string>
            </dict>
            <dict>
                <key>UILaunchImageMinimumOSVersion</key>
                <string>7.0</string>
                <key>UILaunchImageName</key>
                <string>Default-568h</string>
                <key>UILaunchImageOrientation</key>
                <string>Landscape</string>
                <key>UILaunchImageSize</key>
                <string>{320, 568}</string>
            </dict>
            <dict>
                <key>UILaunchImageMinimumOSVersion</key>
                <string>7.0</string>
                <key>UILaunchImageName</key>
                <string>Default-667h</string>
                <key>UILaunchImageOrientation</key>
                <string>Portrait</string>
                <key>UILaunchImageSize</key>
                <string>{375, 667}</string>
            </dict>
            <dict>
                <key>UILaunchImageMinimumOSVersion</key>
                <string>7.0</string>
                <key>UILaunchImageName</key>
                <string>Default-667h</string>
                <key>UILaunchImageOrientation</key>
                <string>Landscape</string>
                <key>UILaunchImageSize</key>
                <string>{375, 667}</string>
            </dict>
            <dict>
                <key>UILaunchImageMinimumOSVersion</key>
                <string>7.0</string>
                <key>UILaunchImageName</key>
                <string>Default-736h</string>
                <key>UILaunchImageOrientation</key>
                <string>Portrait</string>
                <key>UILaunchImageSize</key>
                <string>{414, 736}</string>
            </dict>
            <dict>
                <key>UILaunchImageMinimumOSVersion</key>
                <string>7.0</string>
                <key>UILaunchImageName</key>
                <string>Default-736h</string>
                <key>UILaunchImageOrientation</key>
                <string>Landscape</string>
                <key>UILaunchImageSize</key>
                <string>{414, 736}</string>
            </dict>
            <dict>
                <key>UILaunchImageMinimumOSVersion</key>
                <string>7.0</string>
                <key>UILaunchImageName</key>
                <string>Default-Portrait</string>
                <key>UILaunchImageOrientation</key>
                <string>Portrait</string>
                <key>UILaunchImageSize</key>
                <string>{768, 1024}</string>
            </dict>
            <dict>
                <key>UILaunchImageMinimumOSVersion</key>
                <string>7.0</string>
                <key>UILaunchImageName</key>
                <string>Default-Landscape</string>
                <key>UILaunchImageOrientation</key>
                <string>Landscape</string>
                <key>UILaunchImageSize</key>
                <string>{768, 1024}</string>
            </dict>
        </array>
    
  • GertPostGertPost EEMember

    Same issue here, all the images with right dimensions are provided but Application Loader gives the ITMS-90096 error code.
    Any solutions?

    Xamarin Studio version 5.9.1.3
    Apple Developer Tools 6.3.1
    Xamarion iOS 8.10.0.267

  • JunaidShaikhJunaidShaikh USMember

    Same here. I tried putting the 320x568 images in the Resources folder and in the root. No luck still.

  • Buddy.0568Buddy.0568 GBMember ✭✭

    Has anyone resolved this as I am getting the same error

  • Buddy.0568Buddy.0568 GBMember ✭✭

    Xamarin Support,

    I'm a business customer and I've sent you an email about this problem on Friday. I am completely stuck I cannot release my app any more, those file do exist but not in the IPA package you've created, neither in the app folder you created. This use to work in the previous version until I updated my stable release, I've also tried this in the Alpha release and I get the same issue. URGENTLY FIX THIS PLEASE, I cannot deploy to App Store.

    Don't you test your releases as this is a SERIOUS bug.

    I await for your reply

  • NikiNiki BGMember ✭✭✭

    Buddy.0568, if you urgently need to deploy to the App Store, why don't you downgrade your Xamarin version?

  • Buddy.0568Buddy.0568 GBMember ✭✭

    Thanks Niki, thats what I've done but wanted to make it clear to Xamarin Support that they keep breaking things.

  • Buddy.0568Buddy.0568 GBMember ✭✭
    edited May 2015

    Problem solved by copying old info.plist file.

  • Buddy.0568Buddy.0568 GBMember ✭✭

    I’ve compared the info.plist file and found the following line was removed.
    XSLaunchImageAssets
    Resources/Images.xcassets/LaunchImage.launchimage

    Now I can 100% confirm I DID NOT remove it myself, I however use Visual Studio to edit the file via using the designer to change the version and I can only say it removed it.

  • Buddy.0568Buddy.0568 GBMember ✭✭
    edited May 2015

    Just reproduced again by changing the version number and it removed it again.

    Workaround use editor to modify the file. Do not use the designer.

    Also used the latest stable version 5.9.

  • GertPostGertPost EEMember

    Buddy.0568, has anyone from Xamarin contacted you about the issue? Any dates? Fixes? I really can't roll-back the version either as I'm getting the ERROR: ERROR ITMS-90047: "Disallowed paths ( "iTunesMetadata.plist" ) found at: Payload/iPhoneApp1.app" if I do.

  • RHoevenRHoeven NLMember

    I'm getting this error too, tried everything to fix it without any luck. Also tried the workaround Buddy.0568 mentioned. Any updates on this issue?

  • NathanChannonNathanChannon GBMember ✭✭

    @Xamarin - come on guys - this is still happening? Why do these pathetic small bugs always hold us up. I worked around this once, but since I updated Xamarin it's now broken again?!

    This is an unpleasant experience.

  • RHoevenRHoeven NLMember

    The issue is resolved for me, I think it's because I turned off and deleted my storyboard file (in VS iOS properties -> iOS Application -> Launch Storyboard field emptied). Though it might be something else I've done.

    I've been in contact with Xamarin support and they have been able to reproduce the issue. I'm sure they will fix this soon.

  • yvindVoldsundyvindVoldsund NOMember

    Issue resolved for me as well, by doing what @RHoeven explained. (in VS iOS properties -> iOS Application -> Launch Storyboard field emptied).

  • GertPostGertPost EEMember

    Now the issue is resolved for me as well, did nothing on my side, must been fixed by Xamarin/Apple.
    Thanks!

  • VytautasVytautas USMember

    Hi,

    I started experiencing this issue.
    A week ago it was working just fine and I haven't change anything in plist or other places that might have affect.

    Am I the only one who's getting this?

  • TroelsThistedTroelsThisted DKMember ✭✭

    I have the same issue at the moment - I am supplying every png file the projekt ask's for yet i get this error when i try to upload :/

  • RBrianLindahlRBrianLindahl USMember ✭✭

    I resolved it (temporarily) by changing the build target to 8 instead of 7. It doesn't look for that image in that case. I was thinking about dropping v7 support anyway, so it's not a big deal for me.

  • I had the same issue today, i had to re add the LaunchScreen.xib to the resouces folder.

  • StefanoBaraldiStefanoBaraldi ITMember ✭✭

    Hello,
    I am banging my head and cannot release the app!
    The Default-568h.png is there, plist is provided... anyone has some help? Maybe @TroelsThisted ?

    Help!

  • TroelsThistedTroelsThisted DKMember ✭✭

    @StefanoBaraldi said:
    Hello,
    I am banging my head and cannot release the app!
    The Default-568h.png is there, plist is provided... anyone has some help? Maybe @TroelsThisted ?

    Help!

    yea i figured it out - you need to upload a picture with your apk file that have the Ipad Pro size. You have to do it manually... I am on on my way home from the office now, but i will give you a explanation tomorrow.

    if you are impatient, and cant wait for tomorrow, then there is a solution somewhere on the forums - at least i found it.

  • StefanoBaraldiStefanoBaraldi ITMember ✭✭

    I am more ore less dead-on-the-keyboard, so any help is really appreciated, anytime! :) @TroelsThisted

  • StefanoBaraldiStefanoBaraldi ITMember ✭✭

    Hello @TroelsThisted , i tried to look also for the solution you drafted (iPad pro image?!?) but couldn find any.
    Do you have some other information to share?
    Thanks a lot.

  • TroelsThistedTroelsThisted DKMember ✭✭
    edited March 2016

    @StefanoBaraldi Alright i remember it now! You need a Icon for the Ipad pro to be able to upload the package to the apple store. All my icons are named "Icon.png" and when i add them to my Info.plist they get added automatically to the bundle icon file - the problem is there is no way to add a 167x167 icon.

    To handle this you need to add a icon to your Resource folder manually in the right format - I added a icon in the format "167x167" and named it: "[email protected]". then you have to add a string to your Info.plist manually where you add the icon.

    After that i had no problem delivering the apk to the Store.

  • TroelsThistedTroelsThisted DKMember ✭✭

    bump.

  • StefanoBaraldiStefanoBaraldi ITMember ✭✭

    Thank you! So it complained about the missing Default-568h.png and you resolved adding another (unrelated) icon?
    Just to realize the level of madness this error message is generating :)

    Update:
    Btw, i just passed the upload removing the Launchscreen.storyboard, which DOES NOT reference Default-568h.png.
    So now i have an app that can be submitted, but without any lanchscreen...

  • TroelsThistedTroelsThisted DKMember ✭✭

    @StefanoBaraldi said:
    Thank you! So it complained about the missing Default-568h.png and you resolved adding another (unrelated) icon?
    Just to realize the level of madness this error message is generating :)

    Update:
    Btw, i just passed the upload removing the Launchscreen.storyboard, which DOES NOT reference Default-568h.png.
    So now i have an app that can be submitted, but without any lanchscreen...

    This needs some trial and error... i think i removed all icons and store logos completely 3 or 4 times... didn't tamper with the launch screen tho :S

  • MarkErickson.91MarkErickson.91 USMember ✭✭

    I have tried this both on Xamarin Studio 5.10.3 (build 51) and Visual Studio Enterprise 2015 update 2 with Xamarin.IOS 9.6.1.8 and I am STILL getting this error and it's blocking me from submitting my app.

    My app is using a storyboard as the launch image.

    I tried @StefanoBaraldi troubleshooting tip and removed all references in the app settings (plist) so NO launch screens are configured. No launch images and no references to the storyboard. After building this, I was able to upload the app to the app store. However, this now means my app loads without a launch screen. Not acceptable in my opinion.

    Has anyone been able to resolve this? I've followed EVERY piece of documentation I could find on this.

  • StefanoBaraldiStefanoBaraldi ITMember ✭✭

    Hello, my app has been submitted without launchscreens as you said, and that may be not acceptable by most customers.
    Imho the Visual Studio handling of iOS icon and resources is very outdated (and not aligned to MonoDevelop) and also misleading, we need at least a working template with StoryBoard to look at...

  • LeeOlsen.5615LeeOlsen.5615 USUniversity

    Having this issue as well.

  • AlexSSAlexSS USMember

    I solved this issue by targeting iOS 8 instead of iOS7. I hope this helps.

  • KentCHKentCH USUniversity

    Unbelievable (and yet so believable) that not a soul from Xamarin has replied to this thread. Here I am, over a year after this thread was started, several major releases since, and still suffering from the same problem.

    I have a launch storyboard (not a XIB, not images) that is working fine. I am targeting iOS 9, and yet I'm still getting this error about not supporting iOS 7. I've tried building on VS and XS, checked and re-checked my Info.plist etcetera, and everything looks perfect.

    Why?

  • StefanoBaraldiStefanoBaraldi ITMember ✭✭

    Hello Xamarin, many months passed.. i managed to have a working LaunchScreen.. but the bug is still there, AppStore won't recognize Default-568h even if there.
    My Customer needs an update and won't accept a launchscreen-less app, please help!!!

  • I solved this issue like this:
    Change this LaunchScreen.storyboard in the Info.plist file
    to this LaunchScreen (without the fileextension) otherwise you will have ERROR ITMS-90096.
    BTW don't forget to add the icon for the ipad pro 167x167 which is not in icon drag and drop menu from Xamarin in VS.

  • I can confirm the solution from @ManuelDiggelmann

  • Same here. Changed LaunchScreen.storyboard to LaunchScreen in Info.plist

    <key>UILaunchStoryboardName</key>
    <string>LaunchScreen</string>
    
  • @BerndtHamboeck said:
    Same here. Changed LaunchScreen.storyboard to LaunchScreen in Info.plist

    UILaunchStoryboardName
    LaunchScreen

    Can't believe the solution yolo

«1
Sign In or Register to comment.