Xamarin Debugger not hitting the breakpoints

2456

Answers

  • NMackayNMackay GBInsider, University mod

    @EdElliott.3788

    I think Andre was referring to downgrading the SDK not Xamarin.Forms but as stated before it broke other stuff for us in Visual Studio. I'm using Forms 1.4.2.6359. It doesn't trigger breakpoints in Xamarin Studio or Visual Studio.

  • OndrejSkrabanekOndrejSkrabanek CZMember

    Same here, breakpoints don't work in VS neither XS. Also the call stack is not accessible in VS. Need to access it using Android Device Logging.

  • DanielRoberts.3517DanielRoberts.3517 USMember ✭✭

    Breakpoints not working in iOS project in Xamarin Studio 5.9.1 (build 3) Xamarin Forms 1.4.2.6359.

    Seems to be having issues only in async callbacks at the moment. The break points are hit but break at the wrong random point in code.

    I've been experiencing transient debugging issues for weeks, was hoping latest version would solve it finally. Have tried cleaning, rebooting ect.

  • KasperOvergrdNielsenKasperOvergrdNielsen DKBeta, University ✭✭

    Hi

    I'm not sure what to make of this, but I hit this issue after upgrading from XF 1.4.2.6359 to 1.4.3.6358-pre2.

    First thing I did was to do a quick git stash, out of old habit. I didn't really expect this to have an effect - after all why would a couple of updated references influence my ability to set breakpoints - but alas it did.

    So downgrading XF to the latest stable (ahem) version, fixed the issue for me on Android (I'm not focusing on iOS or WP for the moment). Actually it was enough to downgrade the references in the PCL project, so I still use XF 1.4.3.6358-pre2 in the Android project. It is probably not recommended, but it seems to run fine.

    Just thought I would share this, as it might help others.

    I'm running on the Alpha Channel, ie. Xamarin Studio 5.9.2 (build 2), Mono 4.0.1 ((detached/ed1d3ec) and Xamarin.Android 5.1.2.1.

    Best regards, Kasper

  • KasperOvergrdNielsenKasperOvergrdNielsen DKBeta, University ✭✭

    I just realised this thread is in the iOS forum, and while the symptoms are similar, it may not be the same issue.. Anyway.. the issue I see was already raised by @GeorgeCook as 29861 - in case anybody here wants to track the progress on this.

  • SupreetTare.9314SupreetTare.9314 GBUniversity ✭✭

    Can someone please confirm if this is working in the latest build? v.3.11.658 (Alpha)

  • SupreetTare.9314SupreetTare.9314 GBUniversity ✭✭

    Update: Its working fine in v.3.11.658 (Alpha) on IOS

  • KenWenyonKenWenyon USMember, University

    Has there been any updates on this issue, We have tried Alpha, Beta and Stable releases as of 06/17/2015 and still cannot debug on Android or iOS in VS 2013.4, Windows Store App debugging is working. All Windows updates, VS updates applied as of 06/17/2015.

    On Android Uninstall app on device.
    Set Android App as Startup Project
    Debug --> Start new instance
    App Builds, deploys and starts on device
    No Breakpoints are hit

    Have tried all suggested workarounds in this thread with no joy!

    XAMAIN Please Help!

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    @KenWaynon Try cleaning your project.

  • WilliamRaifordWilliamRaiford USMember ✭✭

    @TimF I am getting this on Android...and it's in June!

  • WilliamRaifordWilliamRaiford USMember ✭✭
    edited June 2015

    @KenWenyon I feel your pain, and I'm not sure if this applies to you, but I've finally gotten it working on Xamarin.Android.

    What finally worked for me was going to the solution options, unchecking "Use Shared Mono runtime" and "Enable developer instrumentation...". I also uninstalled the app from the device itself (not using an emulator) via Google Play Store > Uninstall.

    Then I cleaned, deleted bin/obj folders, rebuilt, and redeployed and no breakpoints were hit (expected because of the disabled instrumentation I think). I then re-enabled the developer instrumentation, uninstalled the app from the device, and redeployed again. This time breakpoints were working again!

    This is a summary of narrowing down the most recent steps that seemed to work. Unfortunately, I cannot re-enable the "Use Shared Mono runtime" as it won't allow my app to start anymore, which is too bad because now deployment takes at least twice as long. But I'm sure the Xamarin team will get it working again!

    Ah yes, I also wanted to mention that I do NOT have any Xamarin.Forms stuff installed...this is strictly Xamarin.Android.

  • QAcGQAcG MXMember

    And they charge us a lot of money for this faulty software ... :(

  • TimFTimF USMember ✭✭

    I've found the simplest thing to do is to just
    1) clear all breakpoints
    2) delete all the *.mdb files in my project folder.
    3) rebuild entire project.
    4) re-add breakpoints as needed

    1&2 aren't so bad, but 3) is getting annoying because of the time it takes. I really hope this gets fixed soon.

  • AdalicioJuniorAdalicioJunior BRMember
    edited June 2015

    None of the proposed solutions that i found on the web worked for me (even those stackoverflow's). I'm on a MAC OS X Yosemite - Xamarin Studio 5.9.4 (Build 5) - Xamarin.ios 8.10.

    I understand that a lot of stuff can break in an update, but seriously, breakpoints? I write code with C# since early 2000's, and i love the idea of making apps in different platforms with it, but this is the kind of thing that tempts me to just left Xamarin, because in every update, i have a bad surprise. I did a few workarounds on some updates (mainly in xamarin.forms), but deleting mdb files everytime i need a breakpoint is a whole new level. Sorry, i'll just wait next update to fix it, if don't, i'll write my app in xcode.

  • AlexanderOsokinAlexanderOsokin USMember ✭✭

    Breakpoints working, but debugger unable to display value of a property(((

  • ChitoSalanoChitoSalano PHUniversity ✭✭

    I have tried cleaning all of my project’s bin folders manually and it worked for me. :) This is something like the same steps that @TimF did, except that I didn't perform the steps (1) and (4).

  • RupertRawnsleyRupertRawnsley GBMember ✭✭✭

    Breakpoints are not working for me in Xamarin Studio on Android.

    Breakpoints early in execution seem to work, for instance in Application.onCreate(). After a short execution time the breakpoints appear misaligned, i.e. they stop in the wrong place, and finally they stop working at all.

    Nothing listed here fixes the problem even temporarily: rebuilds, manual bin folder deletion, removing all breakpoints.

    I am on Xamarin Studio 5.9.4 (build 5) and currently release = beta = alpha, so if there's a fix in the pipeline, it isn't available.

  • VictorAndTinyVictorAndTiny USMember

    I'm in exactly the same situation as RupertRawnsley (including version info). I got around it once by copying around mdbs, but that only worked once. I'm now stuck in a non-debuggable state for Android. This only started happening for me after the latest Xamarin update.

  • AndrewNemtsevAndrewNemtsev USMember ✭✭
    edited July 2015

    The same issue with breakpoints behavior - some breakpoints are ignored, some are triggered at obviously wrong time of application run time. It's looks like some cache (*.pdb / *.mdb ?) are affecting the debugging process. Or in other words it's looks like debug info is not matching the executing application binary.

    Application .SLN consists of several .PROJ files.
    Debugging is works in all projects, except one (but it worked before).
    Debug configuration with "Debug information: Full" are selected for all projects.

    Full solution clean/rebuild or manual deleting of bin/out folders for all projects is not helped.

  • TimYocum.2842TimYocum.2842 USUniversity ✭✭

    This just started happening for me as well in the past few days.

  • AlecTucker.2208AlecTucker.2208 AUInsider, University, Developer Group Leader mod

    My breakpoints are being hit, execution stops until I tell it to continue, but Xamarin Studio does not show me the code or the breakpoint which was hit. I've cleaned, manually removed object files and rebuilt many times (to get around the fact that deploying and running is currently not working at all from Visual Studio, but is fine in Xamarin Studio...)

  • SeanThorpeSeanThorpe USMember

    I've been battling this for a month or two now and the best solution I've come up with is to put in a pre-build event to wipe out everything debug related in the bin directory.

    I pasted this in several of my projects 'Properties->Build Events->Pre-build event command line:' dialog
    cd $(OutDir)
    del *.mdb
    del *.pdb

    This has reduced the number of "unable to delete" errors immensely and has helped deal with the breakpoints that were not being hit as well, which I believe are somehow related to each other in the build process.

    The main issue with this solution being that breakpoints disappear from one debug session to the next, because the files are being deleted every time that project builds. So even if the editor shows it, it may not actually be hit till its removed and re-added.

  • darrin.6295darrin.6295 USMember

    I am experiencing the same issues in Xamarin Studio running an Android project. My breakpoints turn from circles to donuts at runtime and are not being hit.

  • MarkDownesMarkDownes USUniversity ✭✭

    This is also happening for me, but only when trying to debug an Android library that is part of my Xamarin Forms solution. I have tried deleting my entire source repository, rebooting my PC and device, then rebuilding and deploying still without the breakpoints getting hit. Can anyone say refund?

  • TimYocum.2842TimYocum.2842 USUniversity ✭✭

    I contacted support and they recommended that I install a hotfix from the Alpha channel and that fixed the issues that I was seeing last week. Here's a link to what I installed: http://download.xamarin.com/MonoforAndroid/Mac/mono-android-5.1.5-2.pkg

  • nhamawinhamawi USMember

    I was having similar issues with missed or misaligned breakpoints in my Android project running from VS 2013--particularly inside async tasks. When I say "misaligned", I'm talking about hitting breaking on classes I'm not even referencing. Nothing above worked--not even deleting all obj and bin folders, clearing all breakpoints, or deleting my .SUO file. However, Tim's answer above led me to the right solution.

    SOLUTION: I upgraded to the latest Alpha channel (Xamarin 3.11.785 which contains Android v5.1.5) and it solved my debugging issues. I still have the age-old issue of breaking on some code outside of my project which can't be disassembled or which has no debug info, but hitting "Continue" or F5 brings you to the correct breakpoint.

    I don't know what caused the issue. I had not upgraded Xamarin in at least 2 months but I had just upgraded my Android SDK tools/libraries (not changing my targets), went from Debug to Release back to Debug builds in my project, and turned on "Use Shared Runtime" to create an APK for my client, but then I turned it back off. I also noticed that "Bundle assemblies into native code" got checked somehow, but disabling this only helped part of the problem which was to go from hitting no breakpoints to hitting misaligned breakpoints.

  • AndrewNemtsevAndrewNemtsev USMember ✭✭

    Confirm. Upgrade to Alpha channel fixed issue with non-debugable project (library).

  • MortenHjortMortenHjort DKMember ✭✭

    Me as well... running Xamarin.Android 5.1.4.16

  • ThibaultDThibaultD SEMember ✭✭✭

    Same issue here, Xamarin Studio + Xamarin.Android + Library
    Breakpoint gets hit, but totally misaligned (I guess it's the same issue, if you're lucky you hit the wrong line, if you're unlucky you won't hit anything).
    Since this thread is in the iOS section, I created one in the Android section:
    https://forums.xamarin.com/discussion/47059/breakpoints-broken-since-last-updates-android#latest
    (Truth be told, I only found the iOS thread after I created to Android one)

  • ThibaultDThibaultD SEMember ✭✭✭

    Alpha channel did the trick for me too, thanks guys!

  • WilliamRaifordWilliamRaiford USMember ✭✭
    edited August 2015

    Well this go-round, I am getting the "misaligned" breakpoints as mentioned previously (Android). Unfortunately the alpha channel is not working for me. I get the attached error. I'm also attaching the ide log.

    EDIT:
    I missed some bin/obj folders (and the *.mdb files within). I wrote a utility to delete these recursively and now it's working again with the alpha channel.

  • ThibaultDThibaultD SEMember ✭✭✭
    edited August 2015

    Same thing as @WilliamRaiford , I still run into the issue every now and then with the Alpha channel.
    Sometimes cleaning fixes it but something I have to stop Xamarin Studio, remove all .mdb files and restart everything.

  • WilliamRaifordWilliamRaiford USMember ✭✭

    @ThibaultD Do you switch between Visual Studio and Xamarin Studio, or are you strictly staying within Xamarin Studio? I ask because the only three times this has happened to me, it seems it was just following compiling in Visual Studio (something I try rarely per circumstances).

  • ThibaultDThibaultD SEMember ✭✭✭
    edited August 2015

    @WilliamRaiford Only using Xamarin Studio (on MacOS) yet. I will use Visual Studio as well (Windows Phone) later but I will make it work toward a different copy, to be sure they don't conflict :)

  • I still have this issue and is driving me crazy. Its bad enough it takes 20-30 seconds to start the debugger but let alone having to do a full clean + rebuild then restart the debugger adds up over time. Grrrrrr

  • This problem just started happening to me today since there was an update to both ios sdk and Xcode i decided to install those to se if they solved the problem. But no dice. I have since tried most of what is in this thread but to no avail. Getting desperate here !

  • zahikramerzahikramer ILMember ✭✭✭

    Same problem for me, only not on the main Android project, but on Class Library Android Project.
    Anyone?

  • zahikramerzahikramer ILMember ✭✭✭

    Problem Solved for me!
    Disabled Linking (Linking = None)
    and breakpoints are back again! walla!

  • DavidMarshDavidMarsh USMember

    I've had the same problem in Xamarin Studio (breakpoints not being hit, or being hit intermittently) for quite a while.

    You can tell this is happening since execution stops on the breakpoint, waiting for your input, but the code being displayed on screen isn't where the breakpoint is.

    One work-around solution whenever this happens: select the "Show Current Execution Line" menu option under the "Run" main menu, and it will always sync up the source code on screen that matches your breakpoint.

  • recently happend to me, no solution or work around give me the possibility to debug my application. Impossible to work in this way. Any other suggestion?

Sign In or Register to comment.