Stable release: Xamarin Studio 5.9.0, new features and bug fixes

2»

Posts

  • MichalDomanMichalDoman ATMember

    @BrendanZagaeski Yeah, I'll file the report over the course of the day :)

  • DarrelLiuDarrelLiu USMember

    2 issues I haven't seen reported yet:
    1) while debugging, "Locals" tab sometimes doesn't show anything. Restarting Xamarin Studio seems to recover.
    2) "Watch" tab loses expressions every time debug is started.

  • DavidDancyDavidDancy AUMember ✭✭✭✭

    Followup: I see from the latest Mads Torgersen video that "when" is the supported keyword for exception filters. Pardon my ignorance. :)

  • Ross_BRoss_B USMember ✭✭

    Thanks for the update!

    Quick question: Reading through the release notes I was curious what the different was between AdHoc and Enterprise builds for iOS builds.

    Thanks!

  • PaulMace.0768PaulMace.0768 USMember ✭✭
    edited May 2015

    Xamarin Studio Mac 5.9 installed and now will not recognize physical IOS devices. XCode and iTunes see them just fine.

  • i_NateCooki_NateCook USMember ✭✭

    @BrendanZagaeski Why do some of the bugs and known issues not have bugzillas associated with them? For example, this one seems pretty critical, so would like to subscribe to it on bugzilla:

    [Android] In certain cases breakpoints will only pause program execution the first time they are hit.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Why do some of the bugs and known issues not have bugzillas associated with them?

    @i_NateCook, fair question. The complication with most of those is that the corresponding bug reports are "private" Xamarin-only bug reports, so the links aren't publicly accessible. I wasn't certain of the best way to represent that on the release announcement. Now that you mention it, I think I'll update all of those to say "Non-public Bug ... ".

    For now, one way to see when those private bugs are fixed will be to watch for the upcoming service release forum announcement. I will be copying-and-pasting all of the "new known issues" from this thread into that thread, and then moving all of the issues that have been fixed to a "Fixes" section in that new thread.

    I'll also discuss the topic of non-public bugs that correspond to Stable channel regressions with some of the folks here and ask if it might make sense to change the release workflow to make more of them publicly accessible in the future.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @XiaoHippo, thanks for the reports!

    1) while debugging, "Locals" tab sometimes doesn't show anything. Restarting Xamarin Studio seems to recover.

    I haven't yet managed to reproduce this issue myself, so the most direct way forward would be for someone who has seen it to file a bug report. In particular, if anyone is hitting this issue fairly often and has an answer of "yes" to either of the "File a bug if..." questions on the bug filing KB article, please do file a bug report that follows the "best practices" from the KB article as far as possible. (If the KB article link redirects to the top-level kb.xamarin.com/ page the first time you click it, try clicking it once more.)

    2) "Watch" tab loses expressions every time debug is started.

    I was able to reproduce this issue, so I filed a bug for it here: https://bugzilla.xamarin.com/show_bug.cgi?id=29725. I will accordingly add this bug to the "new known issues" in the first post in the thread.

  • mcleodiamcleodia GBMember ✭✭

    Hi

    We have just updated to Xamarin Studio 5.9 and discovered that when invoking an mdtool build call on our solution via the command line, we no longer get an ipa file out of the build process. The build process seems to stop after generating and signing the .app file now.

    I understand from the above post and release notes that you have moved to a new publishing workflow, which would explain this breaking change.

    However, we use a Jenkins based process to generate publishable artifacts and we rely on the output of this build process to generate an ipa without any human intervention, so this has created a bit of a problem for us.

    Can you please indicate whether there is a workaround we can use on the command line to complete our builds?
    Perhaps an msbuild task we can manually invoke after performing an mdtool build in order to accomplish the generation of the ipa - or some other equivalent call?

    Thanks in advance.

    Regards
    Iain McLeod

  • mattwardmattward GBMember Xamurai

    @mcleodia - You can build an .ipa file by adding the following to your project file (.csproj):

    <BuildIpa>true</BuildIpa>
    

    Another way, without having to add the above xml to your project file, is to call xbuild directly and pass set this property on the command line:

    xbuild YourSolution.sln /p:Configuration=Debug /p:Platform=iPhone /p:BuildIpa=true
    
  • JohnHardmanJohnHardman GBUniversity mod

    @BrendanZagaeski @Xamarin-Ian @Mark.Smith - Since applying this update, amongst many other non-trivial problems, Visual Studio 2013 (Pro version running on 64 bit Windows 8.1 Pro) is hanging when I try to debug Android apps on physical devices (via USB). Could this be the same issue as https://bugzilla.xamarin.com/show_bug.cgi?id=29133 ? If so, is there a timescale for getting out a tested fix? It's usually Windows Phone that is playing catch-up with the other platforms, but right now Windows Phone is the only platform that is working since applying the update.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @JohnHardman, it is likely to be Bug 29133, if you are using Visual Studio (I mention that condition because this is the Xamarin Studio forum).

    See some of the comments on the corresponding XamarinVS release thread for more details.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @PaulMace.7801, here are a few first experiments to try:

    1. Double-check that the "Project Options -> iOS Application -> Deployment Target" is set to the current version of the iOS device (or lower).

    2. Check if a "new from template" iOS app project has the same problem. If a new project does show the device:

      1. Backup your whole solution directory before starting since this test involves some manual editing.

      2. Open the .csproj file in a text editor and delete all of the following elements:

        • <CodesignProvision>
        • <CodesignKey>
        • <CodesignEntitlements>
    3. If a new project does not show the device, maybe explicitly setting the signing identity will help. Under "Project Options -> iOS Bundle Signing", try explicitly picking your "Developer" signing identity, and then rotate through the available provisioning profiles to see if any of them change the availability of the physical iOS device.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    @BrendanZagaeski that won't help.

    If it's not showing any devices in your dropdown list, then it's because you've chose "iPad" in your Info.plist and the device you are looking for is an iPhone, which cannot run iPad apps.

  • MatthieuMatthieu USMember ✭✭

    @mattward I added the BuildIpa in the property group for AdHoc|Iphone Configuration but the ipa file is still not generated (XS 5.9 build 431)

    The last line is still
    /Users/matthieugd/dev/xyz/xyz.app: signed bundle with Mach-O thin (armv7) [com.xyz]

    Here's the csproj section :
    <PropertyGroup Condition=" '$(Configuration)|$(Platform)' == 'Ad-Hoc|iPhone' "> <DebugType>none</DebugType> <Optimize>True</Optimize> <OutputPath>bin\iPhone\Ad-Hoc</OutputPath> <ErrorReport>prompt</ErrorReport> <WarningLevel>4</WarningLevel> <ConsolePause>False</ConsolePause> <CodesignKey>iPhone Distribution</CodesignKey> <BuildIpa>true</BuildIpa> <CodesignProvision>Automatic:AdHoc</CodesignProvision> <MtouchI18n> </MtouchI18n> <MtouchArch>ARMv7</MtouchArch> <IpaPackageName></IpaPackageName> </PropertyGroup>

    Any idea ?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    @Matthieu Go into your Project Options / Build / General and then check the checkbox labeled "Use the MSBuild build engine" (I know it says the feature is not supported but ignore that, that string was accidentally left in by mistake).

  • ChandraganeshSChandraganeshS USMember

    Hi,
    I have upgraded to V5.9 today.
    After that my iphone app fails to start (which was working before the update).
    I get the following error on main.cs : UIApplication.Main (args, null, "AppDelegate"); - System.NullReferenceException has been thrown (Object reference not set to an instance of an object).

    I have not changed anything in my code after the update, but it shows this error and application fails to start.
    Please help me to resolve this issue.

  • MatthieuMatthieu USMember ✭✭

    thanks @jstedfast , it did the trick !

  • jacobberkmanjacobberkman USMember

    After updating, Finder says "You can’t open the application “Xamarin Studio” because it may be damaged or incomplete." I've attached the updater log.

  • Leonardo.8015Leonardo.8015 USMember ✭✭

    Hi guys! How are you ?

    Error when Up to date version xamarin for Version 5.9 (build 431)
    The compilation of my application normally occurs but still gives the error below:

    ---------------------- Done ----------------------

    Compilation failed. Object reference not set to an instance of an object
    Compilation: 1 error, 0 warnings

    My app project for ios with Xamarin is not compiling.
    After upgrading some libraries can no longer compile.
    I think it's a bug Xamarin.
    This happens when you try to compile the interface definitions. With errors like:

    /Applications/Xcode.app/Contents/Developer/usr/bin/ibtool --errors --warnings --notices --minimum-Deployment-target 8.3 --output-format human-readable text---compile

    Someone is going through it?

    Error: Build failed. See the build log for details.

    Compilation failure. Object reference not set to an instance of an object.

  • Leonardo.8015Leonardo.8015 USMember ✭✭

    I did the installation of this package and not worked. I understand that I have to change some reference.

    What?

    I use the studio Xamarin 5.9

    Follow my references

  • Leonardo.8015Leonardo.8015 USMember ✭✭

    my references atached!!

    01.png 51.7K
  • OtaMaresOtaMares DEMember ✭✭

    What am i doing wrong when i dont have the option "Use the MSBuild build engine" in my Project Options / Build / General settings? :)

  • MarianBrosteanMarianBrostean ROUniversity ✭✭

    Hi,
    I upgraded today from XS 5.9.0 to 5.91 (build3). When I run the Simulator, it tries to open the app, loads a couple of assemblies, and then terminates without any error, it simply stops:

    Starting iPhone 5
    Launching application
    Application launched. PID = 40944
    Press enter to terminate the application

    Loaded assembly: /Users/YYY/Library/Developer/CoreSimulator/Devices/8C23BDF3-1341-4D17-BF58-C8A710E73B3D/data/Containers/Bundle/Application/402CE83D-2FD3-4A73-BEB3-104B14F5D8D4/XXX.app/.monotouch-32/Xamarin.iOS.dll [External]

    Loaded assembly: /Users/YYY/Library/Developer/CoreSimulator/Devices/8C23BDF3-1341-4D17-BF58-C8A710E73B3D/data/Containers/Bundle/Application/402CE83D-2FD3-4A73-BEB3-104B14F5D8D4/XXX.app/.monotouch-32/System.dll [External]

    After trying to run it again 2-3 times, it works. Any idea if there is a workaround to this?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    @Ota Your project is probably a Universal API project which requires MSBuild so obviously does not offer that checkbox. That checkbox is ONLY available for Classic API projects.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    @MarianBrostean 5.9.1 is exactly the same as 5.9.0 as far as launching simulators and building apps. The only changes it has are for publishing archives to the AppStore.

  • BCSharpBCSharp CAMember

    @DavidDancy: Expression-bodied properties are supported as well. Unfortunately, they throw intellisense off. Release Notes politely say:

    Partial C# 6 Support
    Mono 4.0 includes support for C# 6, and although Xamarin Studio doesn't yet fully support code completion and refactoring operations for all C# 6 constructs, it will now work for some of them.

    The problem is bigger than just lack of code completion for the new C# 6 styled Expression-bodied properties. From the point of a declaration of one of them down to the end of the source file, the editor will complain about any parameter in any ordinary method. The workaround is to declare Expression-bodied properties as last class members.

    Does anyone know where to trace implementation progress of C# 6 support in the Xamarin Studio editor?

  • GaborFurediGaborFuredi HUMember ✭✭
    edited May 2015

    @BrendanZagaeski I've just upgraded to XS 5.9, I can't sign the Android archive (ad-hoc, not trying Google Play as it's for internal distribution for now for testing) as XS crashes as soon as I enter the passphrase for my keystore. I'm trying to import a keystore that I've been using with earlier versions to sign and distribute, no changes there.

    Excerpt from the native crash report

    (Complete native crash report attached here.)

    // Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
    ...
    // 3   libmonosgen-2.0.dylib            0x030bfba5 mono_handle_native_sigsegv + 757
    // 4   libmonosgen-2.0.dylib            0x0310ff81 sigabrt_signal_handler + 129
    // 5   libsystem_platform.dylib         0x9aef103b _sigtramp + 43
    // 6   ???                              0xffffffff 0 + 4294967295
    // 7   libmonosgen-2.0.dylib            0x0310ff00 sigusr1_signal_handler + 256
    // 8   libsystem_c.dylib                0x97e90eee abort + 156
    // 9   libglib-2.0.0.dylib              0x078b2cd1 g_assertion_message + 641
    // 10  libglib-2.0.0.dylib              0x078b2db8 g_assertion_message_expr + 152
    // 11  libgtk-quartz-2.0.0.dylib        0x07cbd3f4 gtk_text_view_validate_onscreen + 340
    

    EDIT May 19 by @BrendanZagaeski: Cut out an excerpt of the native crash report for readability, and attach the complete crash report.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited May 2015

    @GaborFuredi,

    1. There's a chance this is a variation on Bug 29329. That bug is now fixed on the current Beta channel version of Xamarin Studio (5.9.2), so you can try updating to that version and see if it helps.

    2. There might be more informative error messages about the error you're hitting in the Xamarin Studio log file. See the KB article about log files for help locating those log files. (If the link to the KB article redirects to the top-level kb.xamarin.com/ the first time you click it, try clicking it once more.)

    3. As long as you include the log files from Xamarin Studio (from step #2) in addition to any native (OS X) crash reports, then you are welcome to file Xamarin Studio crash reports directly in Bugzilla. Filing a bug would a good next step for this issue. Once the bug report is ready, you can post a link to it back in this thread if you like. Thanks!

    On an unrelated side note, I might recommend cutting stack traces down to just an example snippet (for example, the first 10-15 lines) for use in the body of the comment. You can then attach the complete stack trace in a .txt attachment on the comment. That will help keep the thread easy to read. As an example, I have now edited your original post and added the complete original stack trace as an attachment in this post.

  • GaborFurediGaborFuredi HUMember ✭✭

    @BrendanZagaeski
    1. thanks, it seems to be different though, I did not have a problem archiving. XS crashed when I tried to import an existing keystore.

    Interesting thing however: I created a new keystore to test deployment, and I was able to deploy with the new one. After this, I am also able to import the old keystore without XS crashing on me. Maybe it only crashes when the keystore list is still empty in XS?

    1. Unfortunately I don't have good experience with reporting bugs in Bugzilla. There's a confirmed bug I've reported in XF since last August, still not fixed.
  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @GaborFuredi, just in case it's helpful to know, the bugs for different products are handled differently. If you happen to run into the problem again and get a chance to file a bug, I would recommend filing one for this crash against Xamarin Studio. Crash reports in the Xamarin Studio product are often reviewed by the developers shortly after they are filed. But no worries if you don't hit the problem again or don't get a chance to file a bug. Glad you've got it working for now!

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Ah ha. In case anyone comes across the same problem, it looks like Bug 30072 is a closer match to GaborFuredi's reported issue. That bug is currently targeted to be fixed for the next service release (after the current Beta/Alpha is promoted to the Stable Channel).

  • Andrem0Andrem0 USMember

    Hi. After updating to Stable version 5.9.1 (3), I suddenly can't set "InputAccessoryView" or "InputAccessoryViewController". Before updating, the get method was publicly available. Now it's not. Can somebody point me in the right direction on this?

    This is the error I'm getting:
    Error CS0200: Property or indexer `UIKit.UIResponder.InputAccessoryView' cannot be assigned to (it is read-only) (CS0200)

    Thanks in advance.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    @Andrem0 that sounds like a question that would be better suited asked on the iOS forum.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    This thread has now been closed to direct all further updates onto the thread for the follow-up service release:

    http://forums.xamarin.com/discussion/42671/stable-service-release-xamarin-studio-5-9-2-bug-fixes-for-5-9-0/p1

    For anyone who has been commenting on this thread, feel free to continue the conversation in that new thread.

This discussion has been closed.