Stable release: Xamarin Studio 5.9.0, new features and bug fixes

BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
edited May 2015 in Visual Studio

Released versions:

Windows

Mac

Reason for release: New features and bug fixes.

Release notes: http://developer.xamarin.com/releases/studio/xamarin.studio_5.9/xamarin.studio_5.9/

Date published:

NOTE: This feature release includes a significant number of changes. There are several breaking changes as well as several known issues (see below) compared to the previous Stable versions. Many of the known issues have been addressed in the follow-up "service release" currently available on the Beta and Alpha channels.

Previous versions, downgrading

You can downgrade back to the previous Stable version by manually reinstalling each Stable package (see also the article about downgrading). The links to the previous Stable versions are:

Windows

Mac

Guidelines for this thread

  1. This first post will be updated regularly.

  2. Hopefully this thread will help answer "what might break if I update to this release?"

  3. If you find a new problem that is specific to this version, please file a bug report (if this link redirects to the top-level https://kb.xamarin.com/ page the first time you click it, try clicking it once more).

  4. Please discuss older bugs that are unchanged in this release compared to the previous Stable version in Bugzilla instead.

  5. Of course for questions and discussions about topics other than bugs, feel free start new forum threads.

Android breaking changes

Important: Xamarin.Android 5.1 contains several breaking changes that will require corresponding code changes in your projects. These changes also alter the way unhandled exceptions behave in the debugger.

See the "Android breaking changes" section on the corresponding release announcement in the Android forums for some examples of how to work with these changes: http://forums.xamarin.com/discussion/37277/stable-release-xamarin-android-5-1-0-breaking-changes-new-features-and-bug-fixes/p1

For more technical details see: http://developer.xamarin.com/releases/android/xamarin.android_5/xamarin.android_5.1/#Breaking_Changes

Xamarin Studio new publishing workflow

Important: Xamarin Studio 5.9 uses a new workflow to create final Android, iOS, and Mac apps for publication. The old menu items for creating publishable APKs, iOS archives, and iOS .ipa files have been removed.

See: http://developer.xamarin.com/releases/studio/xamarin.studio_5.9/xamarin.studio_5.9/#Publishing_Workflow

Fixes for common old known issues from previous releases

(Where not already documented in the release notes)

  • Non-public Bug 29100 - [iOS] "Could not find a storyboard named 'MainStoryboard' in bundle NSBundle" when using Xcode 6.3 with size classes and deploying to iOS 7

New known issues compared to the previous stable versions, with more common or severe issues near the top

  • Bug 29570 - [Android] Greater-than and less-than comparisons of decimal numbers do not work correctly. Now fixed in the latest Stable, Alpha, and Beta channels.

  • Bug 28961 - [iOS] "error MT3001: Could not AOT the assembly", "error: invalid symbol redefinition". (This can also appear as "System.ArgumentOutOfRangeException: startIndex > this.length" in the "Output -> Xamarin Log" in VS.) One common cause of this error is the use of [MethodImplAttribute(MethodImplOptions.Synchronized)]. Workaround for projects that use [MethodImplAttribute(MethodImplOptions.Synchronized)]: remove [MethodImplAttribute(MethodImplOptions.Synchronized)] and manually synchronize the methods using lock statements instead (https://bugzilla.xamarin.com/show_bug.cgi?id=28961#c6).

  • Bug 29605 - [iOS] "Error executing tool '/Applications/Xcode.app/Contents/Developer/usr/bin/ibtool': Argument cannot be null. Parameter name: unformatted". Now fixed in the Alpha and Beta channels.

  • Bug 28918 - [iOS] "Unexpected error ... Failed to resolve System.Security.Permissions.SecurityPermissionFlag". Now fixed in the Alpha and Beta channels. (Old workaround: https://bugzilla.xamarin.com/show_bug.cgi?id=28918#c21.)

  • Bug 29568 - [Android] "No resource found that matches the given name", for AppCompat resources in the Android Support library. Now fixed in the Alpha and Beta channels.

  • Non-public Bug 29172 - [Android] "'...Resource' does not contain a definition for `Id'" (for example, when using the Scandit component). Now fixed in the Alpha and Beta channels.

  • Non-public Bug 28995 - [Android] On certain devices, certain apps crash frequently due to "System.ExecutionEngineException: SIGILL".

  • Bug 30171 - [Mono] [iOS] [Android] BinaryReader.ReadChar() returns incorrect result. Now fixed in the Beta and Alpha channels.

  • Bug 29730 - [Android] Event handlers subscribed to (some?) events that are bound to Java callbacks no longer work (for example ViewTreeObserver.GlobalLayout). Now fixed in the Alpha and Beta channels. (Old workaround: use the corresponding "Add/Remove...Listener" methods instead: https://bugzilla.xamarin.com/show_bug.cgi?id=29730#c2.)

  • Bug 30318 - [Android] Windows only: Breakpoints in PCL projects do not work after cleaning solution, redeploying, and restarting debugging. Partial workaround: delete all the bin folders in the solution after cleaning.

  • Bug 30371 - [Visual Studio] [Android] Project Properties display incorrect default values for "BundleAssemblies" and "EmbedAssembliesIntoApk" if they are not explicitly specified. This means that these properties can "automatically" change to incorrect values when you update other properties under "Project Properties -> Android Options". The incorrect values can cause secondary symptoms like Bug 30334 where breakpoints are not hit in the Debug configuration.

  • Non-public Bug 30057 - [Android] Windows only: the debugger will not be able resolve breakpoints unless "Shared Runtime" is ON and the Linker is OFF (under "Project Properties -> Android Options" in Visual Studio or "Project Options -> Android Build" in Xamarin Studio).

  • Bug 29326 - [Android] String resources defined in NuGet packages overwrite sting resources defined in app project, causing the displayed app name to be incorrect for example. Workaround: avoid using the same string key that is used in the NuGet packages.

  • Bug 29211 - [iOS] Enabling linker with Profile 7 PCL that uses System.IO.Compression causes "Could not load file or assembly 'System.IO.Compression'" at run time. Workaround: add -linkskip=System.IO.Compression under "project options -> iOS Build -> Additional mtouch arguments".

  • Bug 30548 - [Android] Under certain conditions new threads take several seconds to start. This problem seems to be triggered by Xamarin.Insights 1.10. Partial workarounds: downgrade Xamarin.Insights to version 1.9, or remove it entirely.

  • Bug 30420 - [iOS] DequeueReusableCell(cellIdentifier) returns null if this.TableView is called in the TableView constructor. Workaround: perform all initialization operations for the TableView in the ViewDidLoad() or ViewWillAppear() methods rather than the constructor.

  • [Bug 30072](https://bugzilla.xamarin.com/show_bug.cgi?id=30072) - [Xamarin Studio] [Android] Xamarin Studio sometimes crashes with SIGABRT in gtk_text_view_validate_onscreen() after password is entered during "Import an Existing Key" in "Build -> Archive for Publishing -> Sign and Distribute" workflow.

  • Bug 29745 - [iOS] Error due to duplicate symbols during native compilation for device: "duplicate symbol _monoeg_g_array_new" (and many similar messages). Workarounds: disable profiling under "Project Properties -> iOS Build", or if your app uses the -all_load linker flag (via either gcc_flags or LinkerFlags) try removing it.

  • Non-public Bug 29170 - [Android] Profiling via log:sample causes the app to crash at startup. Now fixed in the Alpha and Beta channels.

  • Non-public Bug 29538 - [Android] Profiling via the graphical Xamarin Profiler ("Run -> Start Profiling") causes the app to crash at startup.

  • Bug 29261 - [Xamarin Studio] Switching Xamarin Studio to full-screen on recent versions of OS X 10.10 causes Xamarin Studio to crash. Now fixed in the Alpha and Beta channels. (Old workaround: Option-click the green "full-screen / maximize" button to maximize the window before switching to full-screen.)

  • [Xamarin Studio] Xamarin Studio 5.9 for Mac requires OS X 10.9 or higher. The updater does not currently block this update on OS X 10.8. The behavior of the updater for this kind of version incompatibility will be improved in the future.

  • Bug 29088 - [Xamarin Studio] "No access to the given key" when adding custom NuGet feed. Now fixed in the Alpha and Beta channels. (Old workaround: create the following two folders: /Library/Frameworks/Mono.framework/Versions/4.0.0/etc/mono/registry and /Library/Frameworks/Mono.framework/Versions/4.0.0/etc/mono/registry/LocalMachine.)

  • Non-public Bug 28557 - [Android] In certain cases breakpoints will only pause program execution the first time they are hit. Now fixed in the Alpha and Beta channels.

  • Bug 29039 - [Mono] [iOS] [Android] CultureInfo.GetCultureInfo("ar-SA").DateTimeFormat throws a NullReferenceException for the ar-SA culture. Now fixed in the Alpha and Beta channels.

  • Bug 28808 - [Xamarin Studio] Uncommon "Too many open files" error, possibly related to keeping a solution open in Xamarin Studio across several sleep/wake cycles, leads to an inability to save the solution, and consequently a loss of the solution file contents.

  • Bug 29001 - [Xamarin Studio] Under certain conditions, clicking in the universal search bar can trap the cursor focus, preventing text entry into the text editor window. Now fixed in the Alpha and Beta channels.

  • Bug 29731 - [Android] Android.Bluetooth.BluetoothAdapter.Enable is incorrectly marked as [Obsolete("deprecated")] for API level 20 and higher.

  • Non-public Bug 29725 - [Xamarin Studio] [iOS] [Android] Expressions in the Watch window are cleared each time you stop debugging.

  • Non-public Bug 29314 - [Xamarin Studio] [iOS] "Project Options -> iOS Build" shows two "Enable incremental builds" checkboxes. Workaround: use the bottommost checkbox. Now fixed in the Alpha and Beta channels.

New known issues in new features

  • [Android] The AOT compiler does not prevent multithreaded apps from being targeted to the armeabi architecture. These apps will crash at runtime because the armeabi architecture does not support multiple threads.

  • [Android] Some AOT compilation scenarios fail by design but do not yet offer informative error messages.

  • Non-public Bug 28600 - [Android] Intermediate AOT LLVM build files are written to the base project directory rather than the obj/ folder.


Latest edits

EDIT May 19: Update the "fixed in" annotations to mention the new Beta channel release.
EDIT May 21: Increase severity ranking of Android Bug 28995 based on additional customer reports.
EDIT May 21: Add Mono Bug 30171, Android Bug 30057, iOS bug 29605, iOS Bug 30059.
EDIT May 21: Update versions for XamarinVS and iOS iTunesMetadata.plist hotfix (also fixes 29703). Delete some of the old EDIT history for simplicity. Add Android Bug 30318, Xamarin Studio Bug 30072.
EDIT May 27: Add XVS.Android Bug 30371. Beta channel now fixes 30171.
EDIT May 28: Add Android Bug 30548, iOS Bug 30420. Replace Android breaking changes text with link to Android release thread due to forum post character limit.

«1

Posts

  • DavidDancyDavidDancy AUMember ✭✭✭✭

    My recently-updated XS 5.9 stopped saving just now, complaining of "too many open files" and when I quit it wiped the contents of my .sln file.
    Not friendly.
    I had to recreate the whole solution using the original solution's files and folders.
    In an effort to avoid the tedium of fetching each of the 10+ packages I've included in each project I just edited the packages.config file in each project to match the original.
    This correctly updated the packages shown in the Packages folder, but not the package references in the References folder. The references dialog hasn't picked them up either so I can't select them as references. Looks like I'm going to have to remove them all and re-attach them one by one after all. :{
    Bug report: https://bugzilla.xamarin.com/show_bug.cgi?id=28808.

  • Just installed the new version and tried to create a new test project.

    Unfortunately the .Net installation seems to be corrupted. I get the following error:

    ERROR [2015-04-03 12:31:03Z]: Error reading name for assembly '/Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/System.Runtime.Remoting.dll' in framework '.NETFramework,Version=v4.5.1': System.IO.FileNotFoundException: Could not load file or assembly '/Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/System.Runtime.Remoting.dll' or one of its dependencies. The system cannot find the file specified. File name: '/Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/System.Runtime.Remoting.dll'

    When I check the path its a symlink;

    System.Runtime.Remoting.dll -> ../gac/System.Runtime.Remoting/4.0.0.0__b77a5c561934e089/System.Runtime.Remoting.dll

    and indeed the target does not exist.

    Searching console its not the only bad link:

    System.IO.FileNotFoundException: Could not load file or assembly '/Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/EntityFramework.SqlServer.dll' or one of its dependencies. The system cannot find the file specified. System.IO.FileNotFoundException: Could not load file or assembly '/Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/EntityFramework.dll' or one of its dependencies. The system cannot find the file specified. System.IO.FileNotFoundException: Could not load file or assembly '/Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/Mono.Cecil.VB.Mdb.dll' or one of its dependencies. The system cannot find the file specified. System.IO.FileNotFoundException: Could not load file or assembly '/Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/Mono.Cecil.VB.Pdb.dll' or one of its dependencies. The system cannot find the file specified. System.IO.FileNotFoundException: Could not load file or assembly '/Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/System.Runtime.Remoting.dll' or one of its dependencies. The system cannot find the file specified. System.IO.FileNotFoundException: Could not load file or assembly '/Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/System.Web.Razor.dll' or one of its dependencies. The system cannot find the file specified. System.IO.FileNotFoundException: Could not load file or assembly '/Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/System.Web.WebPages.Deployment.dll' or one of its dependencies. The system cannot find the file specified. System.IO.FileNotFoundException: Could not load file or assembly '/Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/System.Web.WebPages.Razor.dll' or one of its dependencies. The system cannot find the file specified. System.IO.FileNotFoundException: Could not load file or assembly '/Library/Frameworks/Mono.framework/Versions/3.10.0/lib/mono/4.5/System.Web.WebPages.dll' or one of its dependencies. The system cannot find the file specified.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    DavidDancy, many thanks for the report. I have added that bug to the known issues, and I will request further investigation by the Xamarin QA team.

    DanielDoubleday.9072, many thanks for the report. At first glance, it looks like perhaps the MonoFramework-MDK-4.0.0.121.macos10.xamarin.x86.pkg installer didn't complete successfully (because the error messages are still referring to version 3.10.0). It's possible the Mono 3.10 installation might have picked up some unusual state at some point while it was installed. My first guess would be that you might be able to solve the errors by uninstalling Mono and then re-running the MonoFramework-MDK-4.0.0.121.macos10.xamarin.x86.pkg installer (if you updated via Xamarin Studio, this file might still be cached in ~/Library/Caches/XamarinStudio-5.0/TempDownload).

  • thetamindthetamind CAMember

    This may be long-standing behaviour before 5.9.0 but it came to light with the new minimum OS X requirement.

    Xamarin Update should block upgrading to a version that has unmet requirements.

    I'm using OS X 10.8 and Xamarin Studio 5.9 requires OS X 10.9. Switching to the Alpha Channel in the updater installed a version of Xamarin Studio that cannot run. At the end of the install process, this error:

    Xamarin Update could not restart Xamarin Studio.

    Launching Xamarin Studio displays:

    You can’t use this version of the application “Xamarin Studio.app” with this version of OS X.
    You have OS X 10.8.5. The application requires OS X 10.9 or later.

    I attempted to switch to a different update channel launching Xamarin Update directly. But it displays a truncated error:

    Xamarin Update must be launched from Xan

    This leaves me with a broken application and I must resort to downloading a fresh installer. The installer claims all components are installed and makes no changes. The Launch Xamarin Studio button on the finish screen does nothing. I trash Xamarin Studio.app and then the installer is willing to install the missing Mac component. Strangely the Xamarin.Mac component is marked with (version 0.0.0.0 already installed).

  • OtaMaresOtaMares DEMember ✭✭

    In your changes list there are only reports regarding new features. Doesnt the update include any fixes regarding crashes or stability?

  • laygrlaygr MXMember, University

    Can somebody with 5.9 tell if F# PCL projects will be available at last?

  • PaulMace.0768PaulMace.0768 USMember ✭✭
    edited April 2015

    Looks like mono 4.x Breaks System.Net.Websocket.ClientWebSocket.

    Stable version is fine.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Many thanks @thetamind. Disallowing updates that break the installed version is a good idea. I've filed a corresponding bug report here: https://bugzilla.xamarin.com/show_bug.cgi?id=29215.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    PaulMace.7801, thanks for the report! I tried quickly running the unit tests for ClientWebSocket from the Mono repo, and they all had the same results on Mono 4.0 as on 3.12, so if you have a test case that shows a problem, please do file a bug report with that test case. Thanks!

  • RogisterAlainRogisterAlain BEBeta ✭✭✭

    found two problems with Xamarin Studio 5.9 (and 5.8)

    1) I have a project with a library reference. (my Library). When I change something in my project in my library and I recompile it. I return to my main project with the reference library. I run the project, it doesn't detect that the DLL has changed. I have to recompile all my main project for the changes to take effect.

    2) When you reference a library in a project. => Everything works. When you delete this reference and we want it back. Looks like Xamarin Studio keeps "references" of the former. If you leave Xamarin Studio and we stimulus Xamarin Studio, it takes out the new library.

    Alain

  • RogisterAlainRogisterAlain BEBeta ✭✭✭

    Idem with Xcode. If I change my Xib file, Tamarin Studio detect correctly but I must recompile my project to run my app.

  • TomGilderTomGilder GB ✭✭

    @RogisterAlain that's this bug: https://bugzilla.xamarin.com/show_bug.cgi?id=29159

    Really hoping it makes it in to 9.0, it's a nasty regression.

  • FokkeVermeulenOldFokkeVermeulenOld USMember ✭✭

    My Xamarin Studio crashes now, if I use the search and by typing an exception will be catched and Xamarin Studio has to restart.

    Do you know how to solve this problem?

  • DavidAllenDavidAllen USDeveloper Group Leader ✭✭✭

    Just updated to Xamarin Studio 5.9 (build 431) and it will no longer build Debug builds for deployment on the simulator without a signing key. Please fix. I always do my initial debug build without the signing key.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited April 2015

    DavidAllen, any chance the "Project Options -> iOS Bundle Signing -> Custom Entitlements" field is not blank in your project settings for the "Debug|iPhoneSimulator" configuration? See for example: http://forums.xamarin.com/discussion/comment/100097/#Comment_100097.

  • DavidAllenDavidAllen USDeveloper Group Leader ✭✭✭

    @Brendan Zagaeski, Thanks for the quick response.

    No, its blank, the first thing did was to go through all the build settings. Interestingly, when I first closed the solution and Xamarin Studio, then reopened them, the configuration had been changed to "Entitlements.plist", so I removed it and rebuild - same error. It's now blank when I reopen everything.

    As per your suggestion on the other thread (forums.xamarin.com/discussion/comment/100097/#Comment_100097. ) , I tried a new dummy solution, and that was OK. So it looks like the issue is associated with existing solutions. I always create solutions in VS (as I think it creates better structured solutions than XS and its adds in the WinPhone project), then move them to XS (and copy the solution file to a WinPhone only solution file so I can open the same solution in VS from virtualized Windows 8.1).

    The bottom line is that something has been broken in how XS treats existing projects, at least those created from VS.

    How can I downgrade back to a working version of XS?

    Thanks

    David

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Interesting. I'll see if I can hit anything by moving projects around between VS and XS.

    For details about downgrading, see "guideline" #1 from the first post in the thread:

    You can downgrade back to Stable either by switching updater channels or by manually reinstalling each Stable package

  • DavidAllenDavidAllen USDeveloper Group Leader ✭✭✭

    @Brendan Zagaeski,

    So, I think that I’ve got to the bottom of the problem and it does appear to be linked to the ‘Custom Entitlements’ setting.

    Here is the (a) failure scenario:

    Solution created in VS.
    Open solution in XS (pre 5.9.0) - builds in Debug>iPhoneSimulator OK
    Upgrade to XS 5.9.0
    Open again in XS, and Build for Debug>iPhoneSimulator
    Build fails if no signing key.
    Go to ‘Custom Entitlements’ - find that this has been set to ‘Entitlements.plist’ by default. Delete so is blank.
    Clean solution.
    Rebuild for Debug>iPhoneSimulator.
    Build still fails.

    Now, if a VS solution is opened in XS 5.9.0 and ‘Custom Entitlements’ is cleared before any build is done (so its never been built with a Custom Entitlement), it builds ok.

    The issue does not appear to be present if the solution was created in XS - if you build it with a ‘Custom Entitlements’ setting it fails but if you then clear ‘Custom Entitlements’, clean and rebuild, it builds ok.

    So the problem appears to be that whatever reference/setting is being set by a selection for ‘Custom Entitlements’ is not being removed once its cleared, even if the solution is cleaned for solutions created in VS.

    Regards

    David

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    @DavidAllen FWIW, I cannot seem to reproduce this problem.

  • DavidAllenDavidAllen USDeveloper Group Leader ✭✭✭

    @jstedfast - thanks for looking into it, I appreciate it. I can still recreate the issue, so maybe it's due to a configuration on my systems. Anyway, I have a work around so its not critical, and if anyone else experiences anything similar, hopefully that will work for them also.

    Regards

    David

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    These versions have now been released to the Stable channel. The first post in the thread has been updated accordingly.

  • IanGeogheganIanGeoghegan USUniversity ✭✭

    Build 431 of 5.9 crashes when the green maximize button is clicked on my Air running Yosemite 10.10.3.

    This crash happens across reboots and without fail.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Ah yes, thanks for the heads-up igeoghegan. I missed including that bug in the known issues: https://bugzilla.xamarin.com/show_bug.cgi?id=29261. I will add it now. The issue should be resolved in the next upcoming service release.

  • MariusUngureanuMariusUngureanu ROXamarin Team Xamurai

    @igeoghegan As a workaround for that crash, please maximize the window (alt + click) before fullscreening, and the crash goes away.

  • FokkeVermeulenOldFokkeVermeulenOld USMember ✭✭

    Hello I have a big problem with the actual version of Xamarin Studio on Mac OS. I use 10.10.3 Yosemite.

    Everytime I use the search and type in something Xamarin Studio is crashing.

  • mattwardmattward GBMember Xamurai

    @FokkeVermeulen - From your other post you mentioned the problem was the NuGet extensions addin.

    Xamarin Studio 5.9 was updated to use NuGet 2.8.3 so the NuGet Extensions addin version 0.6 no longer works on the Mac since it is still using NuGet 2.8.1.

    I am currently unable to publish this to the main Xamarin Studio addin repository.

    For now I have uploaded a 0.6.1 version of the NuGet extensions addin to GitHub which works with Xamarin Studio 5.9. Download the .mpack file, open the Add-in Manager and select Install from file to install the addin. You may need to restart Xamarin Studio after installing.

  • FokkeVermeulenOldFokkeVermeulenOld USMember ✭✭
    edited April 2015

    @mattward
    Exerything with the search is good now.

    At the moment I have problems to install Xamarin Android. The installer says everything is fine and Xamarin Android is installed, but when I start Xamarin Studio and load my solution there is marked on my android project that I have to install Xamarin Android and everytime I run the installer I can install Xmaarin Android. The other options are grayed out. Only the Xamarin Android not.

    I uninstalled and reinstalled the complete Xamarin Studio. Do you have any idea, what I can do?

  • voidvoid DKBeta ✭✭✭
    edited April 2015

    Accepting the XS 5.9/mono 4/etc update this morning rendered this.FontAttributes = FontAttributes.Bold mute. My Forms iOS app no longer have any bold text.

    Compiling and running the project on another machine (on which I haven't accepted the update yet), bold fonts works as expected.

    Android bold fonts works in both scenarios.

  • RahulPRahulP USMember ✭✭

    Font attributes stopped working for me as well on iOS

  • PaulFarrowPaulFarrow USMember

    Since updating Xamarin Studio to 5.9 on Yosemite it no longer shows what you type in the search box up on the right hand side. Its typing but it seems white text on white background !! Do I have some gooky setting set or something. Reverting back to 5.8.3 I can see what I type in there.

  • DH_HA1DH_HA1 USMember ✭✭✭

    I cannot create a WatchKit extension. It does nothing when clicking the Next button.

    Does anyone else see this behavior?

  • GouriKumariGouriKumari USXamarin Team Xamurai

    @PaulFarrow : I couldn't reproduce the issue with stables in Yosemite. If you are able to still reproduce the issue from your end, could you file a bug with IDE Logs and full version info.

  • DylanJKellyDylanJKelly USMember Xamurai

    @void @RahulPatil :

    I am unable to reproduce this issue in Yosemite using either Forms 1.4.2 or Forms 1.4.3. Could you give us info on the device(s) you're seeing this on, the version of Forms you are using, and, if possible, upload the project?

    Thanks!
    Dylan

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @void @RahulPatil, just as a quick follow-up to Dylan's request, if you wouldn't mind filing the information he requested directly in a bug report (on https://bugzilla.xamarin.com), and then linking the report back on this thread, that would be perfect. Thanks!

  • PaulFarrowPaulFarrow USMember

    Bug 29616 filed for the search box issue I am seeing.

    Thanks

    Paul

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @FokkeVermeulen, if you're still running into trouble with getting the Xamarin.Android installer to install properly, you can:

    1. Try deleting the ~/Library/Caches/XamarinStudio-5.0 folder (you can for example copy-and-paste this path into the Finder "Go -> Go to Folder" dialog).

    2. Try manually uninstalling Xamarin.Android, and then reinstalling it. (You can reinstall using the individual installer package if you like.)

    3. If that still doesn't stop the problem, you can contact support using one of the email addresses on https://store.xamarin.com/account/ for some further troubleshooting help.

  • NicWiseNicWise NZMember, Insider, Beta mod

    Sorry. Missed this post (thanks @chrisntr). Having issues with Archiving and publishing. No info.plist if I use the new workflow, and it's identified as a Mac App if I use XCode.

    http://forums.xamarin.com/discussion/39630/cant-archive-or-publish-to-appstore-after-going-to-5-9

    Any ideas?

  • MichalDomanMichalDoman ATMember
    edited May 2015

    Having a lot of unix transport error remoteexceptions since the latest update from 5.8.3 to 5.9 (OSX 10.10.4) when running my nUnit tests. I have not installed any kind of nUnit visual studio adapter, only nUnit 2.6.4. All of my tests were running perfectly fine with Xamarin Studio x.y.z - 5.8.3 over the last year. Now a third of my unit tests (400 tests) are basically corrupted. There is exactly no change in my git repository since the Xamarin update. I also did a git cleanup and rebuild just to be sure.

    Furthermore I did notice, that I am not able to step into certain classes with the debug mode enabled (no symbol loaded) and the unit tests seem (?) to crash therefore at this point.

    What's even more confusing, when debugging through a particular test setup, some lines are executed BEFORE other ones, although being technically AFTER these (e.g. first line of TestSetup is executed after line 30, no loops or any kind of magic involved).

    These issues make 5.9 basically unusable for me, so I have to downgrade back. Any chances this behaviour will be fixed soon?

    Edit : Just downgraded to 5.8.3 and 5.8.1 but the issue still persists. Seems like there is still some local state that causes this issue. Any ideas? I have an intuition, that this issue is rare and fixable on my side.

    Edit 2 : Seems the issue is actually related to Mono 4.0

    Edit 3 : Downgraded to Mono 3.12.1, now all my unit tests run perfectly fine again. As I do not see any special magic happening in a lot of the affected unit tests, I assume that there is a bug within the latest Mono 4.0.0 release

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    @MichalDoman, if you get a chance, I think the Mono team would love one or more bug reports, each with a unit tests attached that demonstrates one (or more) of the problems you're seeing.

  • DavidDancyDavidDancy AUMember ✭✭✭✭

    Checking C# 6 features that have been enabled in the latest (stable) version of Mono (4.0.0) and Xamarin Studio (5.9 b431).

    So far the list comes to

    • nameof (however the text editor highlights the keyword in red as if it's an error)
    • null checking operator [?.]
    • string interpolation (provided string is prefixed with "$" before first quotation mark); older preview-style {} interpolation doesn't work
    • indexed initialisers
    • exception filters (though bizarrely the compiler requires "where" instead of "if" as the filter keyword)

    It's fun experimenting, but is the list of supported features documented somewhere?

This discussion has been closed.