Add In Stopped Working

I just realized that our soft debugger add-in completely stopped working in the latest version of Xamarin Studio (5.8.1)
https://github.com/mcneel/RhinoMonodevelopAddin

I rolled our Xamarin Studio installation back to 5.7.2 and the soft debugger started working again.

I'm at a bit of a loss about what to do. Does anyone know if I need to update our add-in or if there is a regression in Xamarin Studio? If I need to update our add-in, is there any documentation about what it is I need to change?

Thanks, -Steve

Posts

  • mhutchmhutch USMember, Xamarin Team Xamurai

    How exactly did it stop working? Are there any errors at all?

  • SteveBaerSteveBaer USMember

    That's the mysterious part. I don't see any errors or other messages when I attempt to run this custom soft debugger in the latest Xamarin Studio. Just nothing happens.

    I tried debugging this project and the AddIn Maker gave me a message that I need to update my project based on notes on your blog. I tried this and was still unable to debug this add-in.

    We're okay right now since I told everyone in the company to stick with 5.7.2 for the time being, but I would like to solve this issue and get everyone back on to the latest version of Xamarin Studio.

  • SteveBaerSteveBaer USMember

    Is there any way to output some sort of trace statements from the add-in so I can try and see where things stop working? I would like to get our developers back on to the latest build of Xamarin Studio.

  • SteveBaerSteveBaer USMember

    Here's some interesting information that a coworker discovered.

    Xamarin Studio 5.7.2 - our debugger add-in works if you use the right click context menu in the solution pad or from the application's main menu

    Xamarin Studio 5.8.1 - our debugger add-in does not work from the context menu, but does work when run from the application's main menu

    Xamarin Studio 5.8.2 - our debugger add-in does not work from either menu

  • SteveBaerSteveBaer USMember

    Hey Michael,
    Curtis figured out how to make our add-in start working again so we are all happily debugging again with the latest Xamarin Studio.

    In case you are interested, you can see what changed at
    https://github.com/mcneel/RhinoMonodevelopAddin
    on April 10th

Sign In or Register to comment.