Designer wont render styles

HenrikLund.8404HenrikLund.8404 DKMember
edited March 2015 in Xamarin.Android

My designer wont show any styles from external file.

I've created a new project and added a simple button. Then created a styles.xml in the values folder and setup af style for the button. In the designer the button wont render, but if I debug the project on a phone it works fine. Anyone tried this issue and found a solution?

In the log files located at I've found the following errors:
Xamarin.VisualStudio.Shell.XamarinShellPackage Information: 0 : [2015-03-30 14:19:17.0] ERROR: java.lang.NullPointerException
at mono.android.eclipse.AdtFolder.members(AdtFolder.java:49)
at com.android.ide.eclipse.adt.io.IFolderWrapper.listMembers(IFolderWrapper.java:70)
at com.android.ide.common.resources.ResourceRepository.ensureInitialized(ResourceRepository.java:124)
at com.android.ide.common.resources.ResourceRepository.doGetConfiguredResources(ResourceRepository.java:747)
at com.android.ide.eclipse.adt.internal.resources.manager.ProjectResources.getConfiguredResources(ProjectResources.java:141)
at mono.android.DesignerSession.initialize(DesignerSession.java:109)
at mono.android.Project.createSession(Project.java:362)
at mono.android.Project.processMessage(Project.java:393)
at mono.android.MessageListener.executeMessage(MessageListener.java:87)
at mono.android.MessageListener$Runner.run(MessageListener.java:44)
at java.lang.Thread.run(Thread.java:745)

Anyone know that the ADTfolder might be or why this error exist everytime the designer is starter?

Answers

  • After allot of testing I tried to install an older version of Xamarin. The newest version which works on my system is vers. 3.9.347.

    I've created a support case on it and hope they will help me upgrade to the latest version.

Sign In or Register to comment.