What is this errors means ?

Hi every one

when i create a project and then debug it i encounter this message :

Error: The targeted Android API Level 1.6 cannot be found. Please use the Android AVD manager to install the platforms you're targetting

what y think solution ?

Posts

  • JonathanPryorJonathanPryor USXamarin Team Xamurai

    Error: The targeted Android API Level 1.6 cannot be found. Please use the Android AVD manager to install the platforms you're targetting

    This means that you've set your $(TargetFrameworkVersion) 1 to Android v1.6, but you don't have that installed in the Android SDK manager. Either change your $(TargetFrameworkVersion), or install the Android v1.6 SDK:

    1. Open the Android SDK Manager.

      • Visual Studio: Click Tools > Start Android Emulator Manager. Within the Android Virtual Device Manager click Tools > Manage SDK...
      • Xamarin Studio: Click Tools > Open AVD Manager. Within the Android Virtual Device Manager click Tools > Manage SDK...
    2. Within the Android SDK Manager, click the checkbox next to the Android 1.6 (API 4) > SDK Platform entry.

    3. Click Install x packages...


    1. In Visual Studio:

      1. Click Project > Project Name Properties...
      2. Click the Application tab.
      3. Change the Minimum Android to target dropp-down.
      4. Click File > Save All.

      In Xamarin Studio:

      1. Click Project > Project Name Options
      2. In the left-hand tree click the Build > General entry.
      3. In the right-hand panel change the Target framework drop-down.
      4. Click OK.

      ↩︎

Sign In or Register to comment.