Designer not working

Hi,
after install on Win 8 with VS 2010 or 2012 the designer in VS don't run. Always get error Xamarin.AndroidDesigner.DesignerException. It's the same when opening an existing xaml file or create a new one. I'm not even see the code...
What's the Problem? I run the newest monodroid 4.2.8

Peter

Posts

  • Peter.ArteltPeter.Artelt DEMember

    No answer for me? New Installation didn't solve the problem. How do you do your Layouts?

  • ChrisHardyChrisHardy Xamurai GBForum Administrator, Xamarin Team Xamurai
    edited November 2012

    Hey Peter,

    What's the full exception that you're getting? Does using MonoDevelop have the same issue with the designer?

    ChrisNTR

  • Peter.ArteltPeter.Artelt DEMember

    Hi Chris,
    thanks for your answer.
    I get no other Information just as a small dialog box from VS2010 with the text Xamarin.AndroidDesigner.DesignerException. In MonoDevelop I can open the .axml file as text. Is there a Designer?
    Peter

  • Peter.ArteltPeter.Artelt DEMember

    Installing 4.2.8 didn't solve the Problem
    What Designers do you use?

  • TeHaTeHa ✭✭✭ DEMember ✭✭✭

    I've got the same problem with using the designer, that's why I use the disgner in eclipse in combination with droiddraw. And in the VS I changed the standard open-action of the axml-files to a normal xml-text-editor.

  • ChrisHardyChrisHardy Xamurai GBForum Administrator, Xamarin Team Xamurai

    Hey all,

    We have a bug on this issue, which should have been fixed in Mono for Android 4.2.7 but I don't think this has resolved the issue in all cases, the designer should show as expected. Is it possible to run through the steps in comment 1 on https://bugzilla.xamarin.com/show_bug.cgi?id=6532#c1 to see if we can get more information to debug this issue?

    Thanks in advance,

    ChrisNTR

  • Peter.ArteltPeter.Artelt DEMember

    Hi Chris,

    in Attachment the Output file from opening the axml file.

    Hope it helps.

    Thanks for your time.

    Peter

  • Peter.ArteltPeter.Artelt DEMember

    No idea what the Problem is?

  • Peter.ArteltPeter.Artelt DEMember

    My designer still doesn't work...

  • ChrisHardyChrisHardy Xamurai GBForum Administrator, Xamarin Team Xamurai

    Hey Peter,

    Is it possible to e-mail Xamarin at [email protected] so we can look into the issue further and ask for a few more things so we can debug the issue?

    Thanks,

    ChrisNTR

  • I'm getting this from XamarinStudio on the mac, I've uninstalled and reinstalled and I'm still getting the same error message whenever I open any axml.

  • I got it working, the only thing that got it to work was a fresh install of OS X.

Sign In or Register to comment.