Proposal: Solving of the debugger-problems / Version 3.9.302?

FredyWengerFredyWenger CHInsider ✭✭✭✭✭

@Xamarin-Ian, @BrendanZagaeski and at all.

Since months now, I am not able to debug my app in iOS and Android without problems.
There are various threads here in the Visual Studio forum, what is very confusing and time-consuming for every user (and also don’t make a good impression for Xamarin).
Some of the threads are related to iOS, some to Android (where both environments don’t work correct).

It seems, as there are some users, that don’t have problems and other users (like me!) that have massive problems.

I have seen, that there is a new version 3.9.302 out, but I don’t have found any information about it here in the forum (only the release notes here:
developer.xamarin.com/releases/vs/xamarin.vs_3/xamarin.vs_3.9/

It should be in the interest of all (Xamarin + Xamarin-customers) to solve the problems in the near future!

Therefore my proposal:

  • Create a NEW thread “Problems with debugger (iOS & Android)” (or similar)
  • Overtake the latest (collected) relevant information’s from all existing thread (if there are some)
  • Move the old threads to a “collecting-thread” like (old information’s or similar)
  • Define a start-version of the integration-software (I think, this should be 3.9.302)?
  • Restart the problem-solving-process in ONE thread
  • Start with a description to 3.9.302 (what should be solved with this version)?

Inform the users, that only problems should be reported in the new thread (still existing problems after update to a new version or solved problems by a new released version).

At all:
- If you like my proposal, please vote here.

I am willing to work with Xamarin to solve the problems on this way (report all problems once again and also submit my project if this helps) and I think, that also other users still having problems will help. But this should be on a new "clean" base...

Best Answers

Answers

  • pwojtowiczpwojtowicz USMember ✭✭

    Good idea, I gave up with my struggle with it after 10+ hours, testing every single tip from other thread, every single update, nothing helped. So for me this issue is still not resolved.

  • I_am_a_duckI_am_a_duck GBUniversity ✭✭

    Very sensible suggestions, Freddy.

    Xamarin folks?

  • SmathsSmaths USMember ✭✭

    I like this idea.

  • BenLevy.4265BenLevy.4265 USMember ✭✭

    Great.

    I am using 3.9.302.

    The developers / support got this to me as a hot fix on Feb. 11th. I will say they really busted their buts to get this to me.

    This solved the problem I was having with Storyboards not loading (loosing the view controllers). Everything seemed to work fine after I installed it (iOS storyboards, Andriod, debug and build).

    I needed to install this on my PC and my Mac to correct the storyboard issue.

    I have not updated the Xamarin versions since I installed this because everything is working fine.

    One of my biggest struggles when searching for answers is finding old posts. I agree that there should be a thread for specific Xamarin builds. I would also like to see some convention where the user posts info about their environment. I had tons of issues a while back with the build host. Apparently these issues were not present if you were running VS on your Mac.

    I am currently struggling with trying to get builds working with iTunes connect internal testing. Testflight is gone. Again, something new from Apple. No good documentation out there. All the docs are about XCode. Building in VS is different.

  • I am also using 3.9.302 and I cannot deploy to the iPhone through the build host. Visual Studio simply displays the message "Launching Application for debugging..." and doesn't proceed any further. After initially upgrading to version 3.9.302, I was able to deploy to the device, but have not been able to since.

    We are currently weighing up Xamarin vs Phonegap for cross-platform development and this is basically a show-stopper. Any assistance would be greatly appreciated.

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    @Xamarin-Ian, @BrendanZagaeski, further (cc) @pwojtowicz, @I_am_a_duck, @Smaths, @BenLevy3, @BinaraRatnayake and at all readers of this thread.

    I have posted this thread over a week ago and don’t have received any answer from Xamarin until now.
    As you can see here, there are other user’s that find my proposal a good idea.

    So… can we start now, to just do it, please ?!

    Please have a look at my proposal (my first posting in this thread).

    I think, it would make sense, if you would post a template with the information’s you need, so that every developer can copy-paste the template and fill it out.

    I have created (just!) an example (only you know, which information's you need) for a template (word and .pdf) and have filled it with my real problems after I have updated to V. 3.9.344
    Please see attachment...

    Maybe it make sense, that you would create an editable adobe form or word-document (like my example).

    However… but please... just do it…

    Thanks for a statement!

  • rmaciasrmacias USBeta, University ✭✭✭✭✭
    edited March 2015

    I propose any issues and problems you can re-create, produce a step by step re-production, and any error logs, stack traces, etc, be created here:

    https://bugzilla.xamarin.com/

    That's where the Xamarin engineers track everything and it is open to the public to use. I disagree with using the Forum as a bug tracking system. You should use an actual bug tracking system. The problem with the forum is you get a lot of noise and unhelpful "me too" threads. And in many instances, it is not even the same bug people are "me too"ing about. I'm one of those whose had very few problems with the Visual Studio plug-in. But when I have, Bugzilla was the fastest and best way I could get an Engineer to look at it, not the forums.

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    @rmacias

    Thanks for your posting, but it seems, as you misunderstand this thread :smirk:
    I already have filled bugs in bugzilla - nothing happens…
    I already have sent my whole project to the Xamarin people - nothing happens…

    It seems as there are various different bugs/problems which (I tough) depends on the different used environments (this may start by the used VS-Version).

    Therefore, I have created a (filled) template here as example.

    The problem with the forum is you get a lot of noise and unhelpful "me too" threads. And in many instances, it is not even the same bug people are "me too"ing about.

    Exactly - therefore Xamarin should make a proper restart and say the users, which versions they should install, what exactly information’s they need and the users have to provide (therefore I have created a template - just as example).

    So… I do not care, how they do it, but they have to do it.

    I also have no problem, if the problem-solving-process goes over bugzilla (you are right, it should better go over bugzilla) but it should give a problem-solving-process (I don’t see any yet).

  • JeremyKolbJeremyKolb USMember ✭✭✭

    If the bug is urgent to you then use your support links from your Xamarin account. See the top of bugzilla.xamarin.com for details. The support engineers are very good and will at least make sure someone looks at your bug.

  • JeremyKolbJeremyKolb USMember ✭✭✭

    @FredyWenger while I agree that issues with Visual Studio should be fixed it's ultimately up to Xamarin to do so and bugzilla and their support emails are the proper channels to do so. It's hard to track data across forum posts. Now if everyone commented on the right bugs on bugzilla or sent them emails that would probably get their attention but ultimately the forums aren't the right vehicle for this (it will just be us complaining and no one listening).

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    @JeremyKolb:
    So... the forums should be shut down (as they are not useful, as Xamarin do not listen to it...) :flushed:
    I have tried here to make a constructive proposal for a new (professional) restart of the problem-solving-process (and have invested time for that).
    But... I don't receive any feedback from Xamarin and - it seems - as I am the only one that want a proper restart...

    So... I stop waste my time here...

  • JeremyKolbJeremyKolb USMember ✭✭✭

    @FredyWenger I get that you are frustrated (I am too with some of these bugs!). The forums are a good place for users to help each other and to bring visibility to issues but in order to actually get feedback from the Xamarin team you need to go through the proper channels and those just aren't the forums.

    I would recommend that you keep commenting on bugzilla and keep emailing Xamarin priority support. Those emails don't just go into a black box (like bugzilla posts can) they are read and followed up on pretty quickly in my experience. They pay people to read those and respond.

    Don't give up!

    Good luck.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited March 2015

    Jeremy's and rmacias's comments are exactly right. Thanks guys! The forums are indeed intended for discussions among Xamarin users more than investigating bugs.

    So... the forums should be shut down

    Users discuss other problems and questions besides bugs on the forums. The forums are a good place to ask "how-to" questions or questions about unexpected (but not necessarily incorrect) behavior. For example, questions about which libraries or APIs to use to achieve a certain behavior are perfect questions for the forums.

    The Xamarin team likes to contribute to forum discussions when we get a chance, and we do occasionally post announcements for more widespread issues to help improve visibility outside of the release notes. (We also have some plans to start posting a new forum announcement for every new release.) But the Xamarin team does not read or respond to every forum thread. Part of the reason for that is that the support team focuses on email support, and the developer and QA teams focus on Bugzilla. For example, as a member of the support team, I myself only have a limited amount of time each week to work on forum threads (as noted on [1]). (And for the most recent few weeks I've had almost no time to work on the forums.)

    If you would post a template with the information's you need, so that every developer can copy-paste the template and fill it out.

    In a word, that is a bug report. The general template for filing a bug report is here: https://bugzilla.xamarin.com/page.cgi?id=bug-writing.html. And Bugzilla is the correct place to file this information. Ideally the bug report will contain either (a) a set of steps that are likely to reproduce the problem when the Xamarin QA team tries them, or (b) a description of some very particular circumstances surrounding the bug (for example, "I normally hit the problem 75% of the time, but if I change this one thing then I can avoid the problem completely"). Receiving just 1 or 2 customer reports that include very specific clues about a problem is more valuable than receiving many customer reports that contain less specific clues. That said, problems that are reported by many customers who all see exactly the same symptoms (preferably all CC'd on a single bug report) will be prioritized above less common problems.

    It's also good to keep in mind that finding the right information to collect or the right questions to ask is not always straightforward. It can be a bit of an "art form" or, maybe more often, a guessing game.

    Partly motivated by this forum thread, I'm working on a preliminary version of an article for the Xamarin knowledge base titled "When and how to file a bug report" that discusses a few additional bug-filing recommendations that are specific to Xamarin. I will plan to add a link to that article in this forum thread early next week.

    I already have filled bugs in bugzilla

    The exception stack traces from your PDF attachments earlier in this forum thread look interesting. I do not yet see any bug reports [2] that mention the "EvaluatorException" from those screenshots. So I would definitely recommend filing a new bug report (or adding information to the existing bug report that corresponds to this particular problem) to make sure these recent results are on-file in bugzilla.

    [2] https://bugzilla.xamarin.com/buglist.cgi?list_id=133994&classification=Xamarin&query_format=advanced&longdesc=evaluatorexception&longdesc_type=allwordssubstr&product=Visual%20Studio%20Extensions

    Best,
    Brendan


    (Update, Mar 10)

    Here's the knowledge base article I mentioned (still a work-in-progress):
    https://kb.xamarin.com/customer/portal/articles/1910343-when-and-how-to-file-a-bug-report-
    (If this link redirects to the top-level https://kb.xamarin.com/ page the first time you click it, try clicking it once more.)

    It lists a few fairly general recommendations about the "ideal" contents of bug reports. I'll look into getting some similar articles added to discuss forum posts and support emails too.

    Also be sure to keep an eye out for the upcoming release threads. We'll be starting to post those for each new release in the near future. They will be similar to the release threads in the Xamarin.Forms forums. Those should hopefully make it easier to keep new issues sorted by exact versions, and should also make it easier to keep track of any experimental hotfix releases.

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    @BrendanZagaeski
    Thanks for your reply.
    Since I work with Xamarin, I have filled over 30 bugs in bugzilla (most to bugs of XF). Some of them (e.g. one filled at 2014-09-30) still have the state „New“.
    Further I have sent my whole project to Ian (who is - I think - a college of you and also directly responsible to the VS-Integration). I also had a remote-session (for about two minutes) with Ian, where he was on my machine.
    So… I know bugzilla and have spent a lot of time to feed it. In the last months I (really) have spent more than half of my time to feed bugzilla, implement workarounds for bugs, try to bring my environment to work after updates from Xamarin and try to debug my application (instead of working on my app).
    Since 18 Years, I own a small IT-Company. If we would do such development / support, we would be dead in no time.
    However… I have tried here, to help the developers to bring some method in the problem-solving process and prevent them to have read thru many old postings and waste a lot of time for nothing.
    As you can see in the first replies to this thread, I am not the only one that thinks so…
    It seems as you can’t or don’t want to understand what I mean…
    As I wrote, I don’t care, how the problems becomes solved, but they have to be solved (and I suggest there should be used some method to do this).

    If you say, that bugzilla is the (only) right way -> O.K. then you should restart the process over bugzilla.
    But you should inform the users here in the forum:
    Create a new thread with a collection of the latest (relevant) information of the existing threads. Inform the users, that they have to create entries in bugzilla and you won’t answer to postings here.
    You further should define a clear base to the software (VS-Integration, XS on the MAC, XCode, ...) here in the forum, where to start (like in my template in the attachment).

    So... I’m definitely tired now, to further post here (and hope for a constructive problem-solving now :smirk:)

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    @BrendanZagaeski:

    At 2015-03-09 (10 day’s now) , I have filled the bug to iPhone5 (like you wanted) in bugzilla:
    https://bugzilla.xamarin.com/show_bug.cgi?id=27776
    (Debugger crashes after deploy to iPhone5 (device) with reference to Android.)
    -> This bug still have status „New“.

    Since today I have - why ever - a crash by every second try to debug to the iOS-Simulator (I then have to restart VS every time!)
    Link: https://bugzilla.xamarin.com/show_bug.cgi?id=28193

    :open_mouth: So… what have we to do, to receive any help so that we can do our work…? :open_mouth:

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    It becomes better and better...
    Now, I also can only debug one time to Android.
    Error-Message by the second try:

    Fehler 6 Die Zeit für den letzten Zugriff/Schreibzugriff auf die Datei "bin\Debug\MatrixGuide.Android.dll.mdb" kann nicht festgelegt werden. Der Prozess kann nicht auf die Datei "M:\SW\VS_2013\Xamarin\MatrixGuide\MatrixGuide.Android\bin\Debug\MatrixGuide.Android.dll.mdb" zugreifen, da sie von einem anderen Prozess verwendet wird. C:\Program Files (x86)\MSBuild\Xamarin\Android\Xamarin.Android.Common.targets 1553 2 MatrixGuide.Android

  • pwojtowiczpwojtowicz USMember ✭✭
    edited March 2015

    XamarinSupport -= 1; // as we can see one people say something (BrendanZagaeski) other (support) do something else, in this case they simply do nothing

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    Exactly ... but that seems not to interest anyone (except you) :flushed:

  • JeremyKolbJeremyKolb USMember ✭✭✭

    @FredyWenger did you email your Xamarin support contact? I usually get a pretty quick response.

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭
    edited March 2015

    More then one time...

  • Hamid.7455Hamid.7455 USMember

    It's because of the emulator.
    Every time you have to close the emulator and rebuild your project.

Sign In or Register to comment.