Socket error while connecting to MonoDevelop on 127.0.0.1:10000: Connection refused

Tea-yo-deeTea-yo-dee USMember
edited April 2013 in Visual Studio

I'm using a mac and the current Xam studio version on the download site. I did try to reinstall but I still get the message "Socket error while connecting to MonoDevelop on 127.0.0.1:10000: Connection refused"

It runs the app on IOS Simulator (iphone & ipad) but the on application output it display that message. I'm not sure if this is just a warning because the application is running fine on the simulator. Please advise.

Thank you.

Posts

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    This is a bug in Xamarin Studio related to trying to connect the debugger to the app running in the Simulator.

    It's been fixed, but a release with the fix hasn't been made yet.

    You can read about a workaround here: http://forums.xamarin.com/discussion/comment/8748/#Comment_8748

    I think this workaround does break it for debugging on device, however, so keep that in mind.

  • Hi, I get MonoTouch:Socket error while connecting to MonoDevelop on 127.0.0.1:10000: Connection refused. I have tried out "netstat -n -a -p tcp | grep 10000" , I get no results.
    I am using Xamarin Studio 4.0 in Max OS. ( the latest versions of both as of today) .
    I do not see ~/Library/Prefernces/Xamarin ...I am using iphone 6.1 Simulator. ( It was running fine for last couple of days( i started using xamarin a couple of days ago)

  • I am able to debug ..though still i can see teh above line in "application output"

  • SupreethADoddabelaSupreethADoddabela USMember, University

    Clean build resolved the issue for me.

  • willemodendaalwillemodendaal USMember, University

    Cleaning the build, resetting my simulator to factory state and rebooting my computer worked. :/

Sign In or Register to comment.