Can't get any components

Hi Guys,

I have been trying to get some components I need to develop my app but I can't seem to get anything from the Component Store in the Xamarin Studio. I have made sure to login to my account to do this but still cant. I get this error: "Error resolving component: The underlying connection was closed: An unexpected error occurred on a send."

I have tried getting other components just to check but would give me the same error. This is my first time using Xamarin studio for developing apps.

Can someone help???


  • moljacmoljac HRBeta ✭✭✭


    I'll try to help You if i can.

    This is on mac. Right?

    open terminal or Finder

     # first let's clean everything by nuking everything in this folder: 
     # ~/Library/Logs/XamarinStudio-5.0/*
     rm -f ~/Library/Logs/XamarinStudio-5.0/* 

    then close and reopen XS. In folder from above You'll get few files we'll have interest in Components.yyyy-MM-dd_HH-mm-ss.log and maybe ide.log which is symlink to ide.yyy-MM-dd_HH-mm-ss.log

    Then post or upload that file here, so we can take a look.



  • moljacmoljac HRBeta ✭✭✭

    @JohnVargas Hi! Did you manage to get the logs. Do You need further assistance?



  • JohnVargasJohnVargas USMember

    Hi Mel,

    No this is on a PC. How would I be able to access the logs the PC?

    Issue still not fixed. :|

  • JohnVargasJohnVargas USMember

    I cleaned my log files and got these. The components didn't really have anything on there but I attached it still for your reference.

    Thanks Mel,

  • JohnVargasJohnVargas USMember

    This is my components log from before cleaning out the folder.

  • JasonBSteeleJasonBSteele USUniversity ✭✭


    I also have this problem. I am using VS 2015 and Windows 7 and am behind an authenticating proxy.

    I do not have any problems accessing web pages.

  • JasonBSteeleJasonBSteele USUniversity ✭✭

    My issue was resolved by going around my corporate authenticating proxy by connecting to public WiFi and disabling the proxy.

    Xamarin, this is a real issue for your corporate customers using VS2015 with Xamarin.

  • JasonBSteeleJasonBSteele USUniversity ✭✭

    Any update on this issue? It was reported over a year ago in Buigzilla

Sign In or Register to comment.