IOS Release build in Visual Studio shows error "Debug is not enabled in the current configuration."

GuidoKerstenGuidoKersten NLUniversity ✭✭

Hi all,

Since a few days (I think since last updates of Xamarin.Forms), I am getting an error message when I try to do a Release build of my IOS app. The message says: "Debug is not enabled in the current configuration. Please Start Without Debugging or change it in Properties -> iOS Build."

A screenshot of the error message:

So I took a look at the properties, but I did not understand what I had to change. As far as I know I did not change anything in the properties.

Also a screenshot of the properties of the project:

Setup information:

  • MacBook with Parallels, running Windows 8.1
  • Visual Studio 2013
  • Project was previous created in Xamarin.Forms 1.2.3 and updated to 1.3.1 last week.

Does anyone know how to resolve this problem?

Answers

  • GuidoKerstenGuidoKersten NLUniversity ✭✭

    I found this bug report on BugZilla, which seems to be about the same problem. I have Xamarin 3.9.236.0 installed with Xamarin.IOS 8.6.0.0, so it should be fixed in this version, right?

  • GuidoKerstenGuidoKersten NLUniversity ✭✭

    Checking the "Enable debugging" checkbox and build in Release mode enables me to make a Release build, but of course this way the appsize is significantly larger.. When I uncheck this checkbox again I get the same error message.

  • prashantvcprashantvc USXamarin Team Xamurai

    @Guido_Kersten‌ It is not recommended to enable debugging on release build. Release build will not contain any debugger symbols to keep smaller binary size, which is ideal for publishing.

    but of course this way the appsize is significantly larger

    You may need to change the Linker behaviour to Link SDK Assemblies Only to reduce the appsize.

  • GuidoKerstenGuidoKersten NLUniversity ✭✭

    I know @Prashant‌ it was just to check if it works and it did, but it's not what I want to do.. I just want to build a normal Release build..

    I also tested a creating a news Forms project and try to build for Release.. Same error message is shown.. So it's not project bound

  • GuidoKerstenGuidoKersten NLUniversity ✭✭

    I found out that when I build my app using the DEBUG -> Start without debugging, from the context menu with Release configuration selected the app builds.. but after the splashscreen the app immediately crashes without any errors being logged.. I normally use the 'play button' but that's still giving me the error message.

  • 15mgm1515mgm15 USMember ✭✭✭✭

    I am having the same problem.

  • GuidoKerstenGuidoKersten NLUniversity ✭✭

    Ok, so I installed the hotfix after @Prashant‌ sent me an email, more info about the hotfix on BugZilla. When I build my app via DEBUG -> Start without debugging, from the context menu with Release configuration selected it builds successfully and I can finally publish my app again. But I am still getting the error message when I try to build the app by normally clicking the "play" button. Hopefully this gets fixed with the next stable release. For now I can at least move on with my work.

  • KimNieblingKimNiebling DKMember ✭✭

    Same as @Guido_Kersten‌. When I have to debug on my iPhone, I have to choose “Ad-Hoc" | "iPhone" in the Release Configuration Menu, and thereafter, in the Visual Studio menu, clicking "Debug" --> "Start Without Debugging".

    Following these exact steps, I was finally able to deploy to my iPhone.

    When simply clicking "Play" next to the "Release Configuration Menu", a message occurred stating that I should turn off debugging in my properties.

  • hasanirmakhasanirmak CHMember ✭✭

    same problem...

  • I have the same issue. Cannot deploy to an iPhone

  • +1

  • RaymondKellyRaymondKelly USMember ✭✭✭

    Same issue here. But to add, I have another configuration that works fine. I created a new configuration to get around another issue (spaces in path breaks remote simulator). So:

    1. Configuration "Debug iOS" tries to launch but gets "Failed to Install" error.
    2. Copied configration to "DebugiOS", now I get "Debug is not enabled" error.

    Ideas?

  • This is still happening, at least for me. Got to use: Debug -> Start Without Debugger.

  • DJTTBaxDJTTBax USMember ✭✭

    I have the same issue too :(

  • KingGamesKingGames USMember ✭✭

    so how to resolve this problem?

  • DonCB2BDonCB2B USMember ✭✭✭

    @KimNiebling said:
    Same as @Guido_Kersten‌. When I have to debug on my iPhone, I have to choose “Ad-Hoc" | "iPhone" in the Release Configuration Menu, and thereafter, in the Visual Studio menu, clicking "Debug" --> "Start Without Debugging".

    Following these exact steps, I was finally able to deploy to my iPhone.

    When simply clicking "Play" next to the "Release Configuration Menu", a message occurred stating that I should turn off debugging in my properties.

    thanks, that's working

  • AsMax2017AsMax2017 Member ✭✭

    @DonCB2B said:

    @KimNiebling said:
    Same as @Guido_Kersten‌. When I have to debug on my iPhone, I have to choose “Ad-Hoc" | "iPhone" in the Release Configuration Menu, and thereafter, in the Visual Studio menu, clicking "Debug" --> "Start Without Debugging".

    Following these exact steps, I was finally able to deploy to my iPhone.

    When simply clicking "Play" next to the "Release Configuration Menu", a message occurred stating that I should turn off debugging in my properties.

    thanks, that's working

    @DonCB2B said:

    @KimNiebling said:
    Same as @Guido_Kersten‌. When I have to debug on my iPhone, I have to choose “Ad-Hoc" | "iPhone" in the Release Configuration Menu, and thereafter, in the Visual Studio menu, clicking "Debug" --> "Start Without Debugging".

    Following these exact steps, I was finally able to deploy to my iPhone.

    When simply clicking "Play" next to the "Release Configuration Menu", a message occurred stating that I should turn off debugging in my properties.

    thanks, that's working

    yeah , its working

  • thanks :smile:

  • ArunPrasad.007ArunPrasad.007 USMember ✭✭

    @GuidoKersten said:
    Hi all,

    Since a few days (I think since last updates of Xamarin.Forms), I am getting an error message when I try to do a Release build of my IOS app. The message says: "Debug is not enabled in the current configuration. Please Start Without Debugging or change it in Properties -> iOS Build."

    A screenshot of the error message:

    So I took a look at the properties, but I did not understand what I had to change. As far as I know I did not change anything in the properties.

    Also a screenshot of the properties of the project:

    Setup information:

    • MacBook with Parallels, running Windows 8.1
    • Visual Studio 2013
    • Project was previous created in Xamarin.Forms 1.2.3 and updated to 1.3.1 last week.

    Does anyone know how to resolve this problem?

    In Visual Studio 2017, it will be available in iOS Debug tab.

  • DooksDooks ZAMember ✭✭

    January 2019 here. Still fucked

Sign In or Register to comment.