'OutputPath' property is not set for this project - XamlSamples

2»

Posts

  • MrAPolkMrAPolk USMember

    I stopped this error occurring in my project by creating a new blank project & building that before opening and building my project.

  • Hello,
    Today, without making ANY Changes in my projects I started to get this error.
    I was working on a new App yesterday and everything was working, I was able to compile and debug in my Simulator. Then suddenly this error keeps happening today, I cannot compile any projects. I even opened a previous project which was working perfectly and did a simple compile. it happens.
    This is really frustrating.
    Any suggestions, please?

    /Library/Frameworks/Mono.framework/Versions/4.0.4/lib/mono/4.5/Microsoft.Common.targets: Error: 'OutputPath' property is not set for this project. Usually this is caused by invalid Configuration/Platform combination. Original values: Configuration: Debug Platform: iPhoneSimulator. (Eznetsoft Audiobook)

  • TektonTekton USMember ✭✭✭

    @SamuelJocelyn Try the MDK patch described here. Just worked for me.

  • I

  • I simply did a Clean All, close Xamarin, Restart my MAC the problem went away.

  • AlessandroCaliaroAlessandroCaliaro ITMember ✭✭✭✭✭

    Take a look to bugzilla. Should be a patch

  • RaymondBradyRaymondBrady USMember

    Same problem here this morning. Opened a solution I have been working on for several weeks now. First time for this error. My project was created in Xamarin studio, never been touched by VS. I checked solution build config mappings and all good.

    I cleaned and closed the solution, quit Xamarin studio and simulator, rebooted my mac. Working fine now.

  • Sridhar.6103Sridhar.6103 USMember
    edited October 2015

    Hi , I get the same error when i run Xamrin IOS project in Jenkins Build using Execute shell, saysing OutputPath p[roperty is not set for this project, Usually this is caused by invalid configuration/Platform combination, Original Values: COnfiguration : Release Platform: Iphone. Build step Execute Shell marked build as failure.

    My Build Command uses "-c=Release|iPhone"
    My Xamarin Version is 5.9

    Actually it the referenced project (a .net library), that fails, hence forth the ios project fails.

    But when i build the solution in Xamarin studio or Visual Studio it is builds successfully.

  • IanGeogheganIanGeoghegan USUniversity ✭✭
    edited January 2016

    Like others I have been hit by this suddenly; without having made any changes. When I went to bed I could build; when I woke up I could not. I have cleaned. I have restarted, rebooted; all to no avail.

    Update: Ben Beckley's steps to fix corrected this error. Find them here:

    https://bugzilla.xamarin.com/show_bug.cgi?id=25480#c13

  • NielsCupNielsCup NLMember ✭✭✭
    edited April 2016

    Same problem here: I have created a new project in XS on my mac, PCL, Android and iOS (MvvmCross). There were no issues building and running the project. After the weekend I wanted to continue with this project and I got the 'Outputpath' property error. I tried running the same project in VS and it builds and runs without any issues. After an hour playing around with build options etc. I tried @IanGeoghegan / Ben Beckley's solution and it works, no idea why...

    Another thing I noticed is that when I set the iOS project as startup project, only debug and release were available in my config selector, I was missing the debug|iPhone and debug|iPhoneSimulator configs. After Ians solution these configurations somehow reapppeared.

    ps. @IanGeoghegan: Thanks!!!

  • NielsCupNielsCup NLMember ✭✭✭

    @Xamarin (or @Microsoft?): This issue is really annoying and time consuming, are you working on a fix?

  • BenReesBenRees NZUniversity ✭✭

    I've also experienced this issue, but not with the Xaml Samples, but in my team's project. It turned out to be from the custom build configurations I added to the solution.

    Long story short, xbuild builds differently to msbuild, Visual Studio, or Xamarin Studio. xbuild takes the csproj file as its entry point, for example:
    From my build system log output (Bitrise - which is awesome ;-) )
    xbuild /t:PackageForAndroid /p:Configuration"PlayStore" "./MyApp/MyProject.Droid/MyProject.Droid.csproj"
    Where as normally you'd point to the solution file in other tools. The solution file contains mappings to know what build config to use for each project, because its possible to have a solution level build config and different configs for each project under that solution config.

    The solution was to ensure that the build config passed to xbuild you see in the command line executed by your build system also exists for any PCL projects you have.

    Full details in a blog I wrote to document the solution here: http://bit.ly/2abqs6D

2»
Sign In or Register to comment.