Frustrated about Xamarin upgrade(s): iOS Unified - app doesn't build anymore

I am very frustrated about the latest Xamarin upgrade (Jan 12) (and actually most previous upgrades).

The app I'm currently working on doesn't build anymore after the latest upgrade.
It did build and ran perfectly the day before.

Error MT2002: Failed to resolve "System.Void UIKit.UIPickerView::set_Delegate(UIKit.UIPickerViewDelegate)" reference from "Xamarin.iOS, Version=0.0.0.0, Culture=neutral, PublicKeyToken=84e04ff9cfb79065" (MT2002)

I don't use UIKit.UIPickerView in my code, I use UIImagePickerController directly, and again, it did work as expected before the upgrade.

Frankly, every time Xamarin announces an update, I'm scared to push the button.
I never know what to expect next. What will break now? What errors are introduced or reintroduced this time?

It comes to a point that, when I'm in a project with a deadline near, I NEVER push the update button.
I have missed deadlines (some with serious repercussions) by doing updates mid project and running into build issues, so I've learned my lesson.

IMHO, Xamarin should do way more quality-testing before releasing updates than they are doing now and don't rely on their -paying- customers to report / iron out bugs. I, as a freelancer -and probably many more clients with me-, have no time for that and simply refuse to be a guinea pig.

Working with Xamarin for several years now, with bussiness licenses for iOS / Android & MAC.

Regards

Gerd

Posts

  • Suggestion: There should be a single-click Downgrade button in Xamarin Studio, to revert a buggy update in the stable channel.

  • adamkempadamkemp USInsider, Developer Group Leader mod

    I think that particular issue is caused by a mix of unified and non-unified code in the same app. Either your app is not unified but some component you use is or your app is unified but someone component you use is not. The migration to unified is painful for sure, but I'm not sure this particular issue is a bug in Xamarin.

  • RolfBjarneKvingeRolfBjarneKvinge USXamarin Team Xamurai

    @Zambiorix: you can download earlier versions from your Xamarin Store account (https://store.xamarin.com/account/my/subscription/downloads)

  • @adamkemp‌, the app (and all libs it's using) was unified before that. It did build and worked great right before the upgrade to "stable" version.

    I'm pretty sure the issue is not in my code.

  • @RolfBjarneKvinge‌, thank you Rolf. I downgraded Xamarin Studio and everything builds again.

    Can you confirm that this is an issue in the stable version?

  • RolfBjarneKvingeRolfBjarneKvinge USXamarin Team Xamurai

    @Zambiorix: no, it's not an issue in Xamarin.iOS, it's most likely an issue with one of the components you're using which has not been updated to the stable Unified API (released on Jan 12th).

  • @RolfBjarneKvinge‌, that was indeed the case. It was the Xamarin.Social component.

    Right after the upgrade (Jan 12th) I removed all components and added them again. But that didn't work, so I reversed the install to an older build (on the same day).

    I updated Xamarin Studio again earlier today, removed and added the components in my project and now it works.

    As said above, the issue was with the Xamarin.Social component.

    I apologise for my rant above. Frustration got the better of me.

Sign In or Register to comment.