New install, lots of errors, bad experience

TonyGTonyG USMember ✭✭

I just installed to a virtual machine and have been dealing with a slew of errors. This doesn't give me the warm fuzzies...

VM with Windows 7 and VS 2013 Community Edition

Installer 3.5.0.0 installed all dependencies but the VS, reported that all of the dependencies needed to be reinstalled. A reboot and re-run showed that everything was OK except the VS addins. Ran separate Xamarin.VisualStudio_3.9.236.msi and as I recall there were still errors. I did a Repair on VS and it seemed to be fine from there.

My first effort in this system was to view examples from the xamarin-forms-samples-master.zip.

On loading FormsGallery.sln it said I didn't have a license. I added my email/psw which it seemed to accept, saying I now have 1 of 2 systems licensed for a trial. Every time I open the solution it gives me the same message and requires login.

The solution opened and showed a dialog for the Windows Phone Project: "This computer must be upgraded to Windows 8.1 to load this project".
Great. I'll need to reload a whole new virtual just to see WP ... actually I don't care about, I'm really just focused on Android for now.

I closed that and got the dialog to connect to a Xamarin.iOS Build Host. I'm not doing iOS now either so I cancelled through this.

I attempted a build and got an Unhandled Activation Error. I clicked the links but they open a browser to xamarin.com/support and don't pass any info over. It would be much more helpful if the error got passed to the site for a quick evaluation and recommended solution, as this seems to be a common issue over at least the last year.

Closing that error I got another dialog with the same licensing message. I did the login and got a confirmation just like the first time.

The build proceeded and I got a slew of errors from the iOS and Android projects.

  • Xamarin.iOS for Visual Studio requires Business account or greater. Please log in with your Xamarin account to proceed.
  • Unzipping failed. Please download https://dl-ssl.google.com/android/repository/google_play_services_5089000_r19.zip and extract it to the C:\Development\Xamarin\xamarin-forms-samples-master\xamarin-forms-samples-master\FormsGallery\packages\Xamarin.GooglePlayServices.19.0.0.1\lib\MonoAndroid23\19\content directory.
  • Reason: The specified path, file name, or both are too long. The fully qualified file name must be less than 260 characters, and the directory name must be less than 248 characters.
  • Android resource directory C:\Development\Xamarin\xamarin-forms-samples-master\xamarin-forms-samples-master\FormsGallery\packages\Xamarin.GooglePlayServices.19.0.0.1\lib\MonoAndroid23\19\content\google-play-services/libproject/google-play-services_lib doesn't exist. FormsGallery.Android

OK so with Win7 and VS 2013 Community Edition, I can't build any of the projects in the sample. I really wish the installer or some documentation had said that this is an unsupported platform so I could have avoided the wasted time.

So I opened Xamarin Studio, v5.7 build 661 and tried to open the same Solution. I got issues with packages, warnings that Xamarin.Forms.Label.Font is obsolete, and an unzipping error. But after modifying the .csproj file for a NuGet issue, I got close to a build. The final issue is tha file names/paths are too long which I suspect comes back to a requirement for Win8. IT' also saying I need to install Google Play Services which might be the same issue.

I'm not asking for help on these issues. With enough googling and a few hours of free time (LOL) I'm sure everything will be resolved.

Don't get me wrong. I'm a fan and will get through all of this. I just think so far this has been a really bad experience. "All I want to do" (I love when end-users say that) is to build and run the examples that come from Xamarin. You can't make that a weekend project. We need to be able to install, build, and start learning about tools and syntax as soon as possible in order for this relationship to work. If Xamarin wants developers to jump in and give this environment a try, the out-of-box experience can't be as dreadful as this. That's bad technically and very bad for marketing.

HTH

Posts

  • TonyGTonyG USMember ✭✭

    Follow-up: I reinstalled to Win8.1 and had most of the same errors. Moving the solution folders closer to my C: root got beyond the "path too long" errors. On attempt to build the FormsGallery solution I got a ton of these new warnings:

    Warning: iCCP: Not recognizing known sRGB profile that has been edited (FormsGallery.Android)

    I'll do my homework on that, but how pleasant is it to get errors like this on a fresh install of any software?

    After many hours of reinstallations, updates, reboots, research, and tweaks, I finally got to these errors:

    Xamarin.Android.Common.targets(5,5): Error XA9005: User code size, 5769563 bytes, is larger than 131072 and requires a Indie (or higher) License. (XA9005) (FormsGallery.Android)

    Xamarin.Android.Common.targets(5,5): Error XA9006: Using type Android.Runtime.JNIEnv requires Indie (or higher) License. (XA9006) (FormsGallery.Android)

    That's pretty clear. It's telling me I can't even build the samples project with my trial license. Again, not pleasant. The limit on assembly size is documented. My complaint is that I can't even successfully build the project that is intended to help me learn the tools. That's like putting putting gum on the pages of a hardcopy instruction manual.

    I'm at the point where I think I can at least write new projects, do my homework, and learn the environment. I'm certain that over time I'll transition into a license-holding Xamarin client. But I think the point here is clear that this installation does not lead to a user/developer-friendly experience. In fact it's downright hostile.

    My recommendations:

    • Reduce the size of the samples solution into smaller projects which can be built on the trial license.
    • Add a README to the package, or an in-your-face link to a up-to-date README on this site, and warn newbs of exactly where this software will and will not run.
    • Package this software so that a new installation immediately leads a new developer to a small amount of encouraging success, not a stream of discouraging roadblocks and disappointments.

    Thanks for your time.

  • JaikishenJayadev.8553JaikishenJayadev.8553 USMember
    edited March 2015

    Facing the same issue. Throwing the same errors in trial version as well. Using Xamarin studio 5.7.2 (build 7) and trying to build a new xamarin.forms shared mobile apps project but getting the same errors.

  • TonyGTonyG USMember ✭✭

    I was able to move on to create new projects in Xamarin Studio, haven't tried anything large or complex. I also haven't gone back to Visual Studio yet, as I really just want to try to understand Xamarin itself more than any specific environment. I recommend trying XS and only go back to VS if you get a license and really need to move forward in that direction.

Sign In or Register to comment.