Xamarin Studio and iOS Provisioning Issues

KMullinsKMullins Kevin MullinsUSXamarin Team Xamurai

Because of changes that Apple recently made to the way provisioning works, Xamarin Studio currently is unable to refresh changes or additions to iOS Provisioning profiles directly. As a current work around, you'll need to do the following:

  1. Quit Xamarin Studio.
  2. Start Xcode.
  3. Select Xcode menu > Preferences... > Accounts and click the View Details... button.
  4. Click the Refresh button and then click the Done button.
  5. Restart Xamarin Studio.

This issue will be corrected in a future release of Xamarin Studio.

For more information, please see our Set Up Device for Development Documentation.

Posts

  • SharpmiceSharpmice Sharpmice USMember

    Thanks for the input.
    Nevertheless, my provisioning profile is still not available. Actually the dropdown is dimmed/disabled.
    I do see my personal signing identities for development and distribution, and I've tripple-checked my bundle identifier.
    I tried to follow your documentation as linked above - but with no luck. All I need is a demo deployment on my IPhone.

  • LannyDeVaneyLannyDeVaney Lanny DeVaney USMember ✭✭

    XS is unable to find my ad-hoc provisioning profile as well. The work around described in this announcement does not work . Any other suggestions? I've been using a development provisioning profile for quite some time, and as I move my app to beta I was going to ad-hoc, however I see my profile in XCode buy XS doesn't see it when I go to build my distribution file.

  • stilwdrstilwdr Dan Stilwell USMember

    I have the same issue. Ad Hoc provisioning not found by XS, but profile is good in XCode. Anybody else have this issue?

  • JeffreyStedfastJeffreyStedfast Jeffrey Stedfast USXamarin Team Xamurai

    The list of Provisioning Profiles changes based on the Signing Identity that you choose.

  • kugjokugjo Maxim Biyanov USUniversity ✭✭
    edited July 2015

    Dear community,
    I see that XS is currently supports XCode 6.X.
    Is there a plan to integrate at least the XCode 7's functionality of FREE device provisioning in the nearest future?
    Or is there a workaround to setup iOS Bundle Signing on an exisiting Xamarin project for my iPhone device but using an "auto-generated" provisioning profile (by XCode 7 beta)

  • kugjokugjo Maxim Biyanov USUniversity ✭✭

    ... Workaround is found:
    1) Open XCode 7
    2) Create a new blank project for your iOS device
    3) Use link to setup free provisioning. USE THE BUNDLE IDENTIFIER you need for your EXISTING Xamarin Studio project. https://developer.apple.com/library/prerelease/ios/documentation/IDEs/Conceptual/AppDistributionGuide/LaunchingYourApponDevices/LaunchingYourApponDevices.html#//apple_ref/doc/uid/TP40012582-CH27-SW3
    4) After the free provisioning is ready for your device, open Xamarin Studio and choose your identity and the new provisioning profile in the project's options.
    5) I was able to start my xamarin iOS app on my device

  • w.atenw.aten Wiyono Aten GBMember

    @kugjo, thanks for sharing the workaround. However I tried it with no luck. Did you by any chance try this with an alpha channel of Xamarin.iOS?

  • GaganKaushikGaganKaushik Gagan Kaushik USMember

    @waten.7306 are you also getting this error?

    "/Library/Frameworks/Mono.framework/External/xbuild/Xamarin/iOS/Xamarin.iOS.Common.targets: Error: Could not locate the iOS '9.0' SDK usr path at '/Applications/Xcode-beta.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS9.0.sdk' (Phoneword_iOS)"

    apparently xamarin isn't currently compatible with ios 9. everything worked fine for me up till i actually tried to build it.

  • PhilippLPhilippL Philipp Lulay USMember

    @KMullins is it still not working? I have provisioning issues again and again :-1: I can build my main project but if i open a project (one of the xamarin solutions Tasky, Sport...) always provisioning issues because profiles cannot be found

  • KennethThormanKennethThorman Kenneth Thorman DKMember ✭✭

    @PhilippL I have the same problem and newly generated provisioning profiles (even wildcard ones - for testing) on an empty skeleton app, with no custom entitlements, and no fancy stuff enabled.

    The devices UUID are correct and part of the profile
    The certificates are valid and I have used XCode/Preferences/Account/Download All a multitude of times as well as restarted the computer and Xamarin Studio

    I am currently running the Alpha Channel and XCode 7.1.1 in an attempt to fix the problem in Stable channel.

    I do not see the new provisioning profiles or signing identites anywhere in XS

    Did you find a solution to you problem?

  • PhilippLPhilippL Philipp Lulay USMember

    @KennethThorman Sorry, not really. I did most what you already tried - creating a new provisioning profile (wildcard) helped. But i really don't know if that was the reason. Im still in stable channel but i dont think there is any difference in that issue. Generally i have more and more issues while working with xamarin studio.

  • leoslimaleoslima Leonardo Soares Lima BRUniversity ✭✭

    Hey guys, i have some troubles with my ad-hoc distribution provisioning profile.

    i've followed all the steps from link (https://developer.xamarin.com/guides/ios/getting_started/installation/device_provisioning/).

    But when i need to generate ad-hoc ipa file, the wizard show me the message "No valid provisioning profiles found". However in iOS project, selecting the "iOS Bundle Signing" in options just appears my iOS Development provisioning profile, but i need to select the "Distribution Provisioning Profile" created from my company.

    What i'm doing wrong?

  • DavidDancyDavidDancy David Dancy AUMember ✭✭✭✭

    @leoslima Did you ever fix this issue? I just ran into it and found that there were duplicate <CodesignProvision> XML nodes in my iOS project's .csproj file. After removing the duplicate I was able to select the correct profile and everything started working again.

  • leoslimaleoslima Leonardo Soares Lima BRUniversity ✭✭

    @DavidDancy I managed to solve the problem after resetting the access keychain and redo the steps from link (https://developer.xamarin.com/guides/ios/getting_started/installation/device_provisioning/). Probably there was some conflict between my certificates with keys that I had. But thank you so much.

  • MichaelRumplerMichaelRumpler Michael Rumpler ATMember ✭✭✭✭

    I tried to switch to a new build host cause the old crashed. The new Mac has Xcode 8.3.1 and in that version there is no "View Details..." button anymore in Preferences / Accounts. The Device Provisioning page linked above has not been updated.

    I have "Manage Certificates" where I had two certs with status "not in keychain" first. I downloaded the certs from developer.apple.com and imported them and now I get "Missing Private Key". I can create new certs here but not delete broken ones.

    The other button is "Download All Profiles". According to the Xcode help "Xcode downloads only the necessary provisioning profiles depending on what is found locally." As Xcode doesn't know anything about the Xamarin projects on my Windows machine it doesn't download anything at all. I tried manually downloading and double clicking the files, but I don't find the Provisioning Profiles anywhere. Does anybody know where I can find them now?

    In Visual Studio I can connect to the new build host, but when I open the project properties, then it says "Failed to obtain Profile Information from the build server.". The build fails obviously.

  • MichaelRumplerMichaelRumpler Michael Rumpler ATMember ✭✭✭✭

    In this SO question I found a reference to the Xamarin.Studio 6.3 release notes. There they say that all this provisioning profile stuff works with fastlane now. Xamarin proves once again that they are unable to write proper installers, because you need to install the Xcode command line tools and fastlane manually. How this is done is described here.

    After I did all that, I could finally download all my existing provisioning profiles with

    fastlane sigh download_all
    

    And I see them with

    fastlane sigh manage
    

    Of course I also fell into bug 53906 and the UI doesn't list any profiles at all.

    Although I do see the profiles with fastlane now, I still cannot build with Visual Studio on Windows.
    If I leave the Identity and Provisioning profile at Automatic in the iOS project properties / iOS Bundle Signing, then I get "No installed provisioning profiles match the installed iOS signing identities" in both VS2015 and VS2017.
    I can also select the appropriate profile there, but then I get the error "No iOS signing identities match the specified provisioning profile". So it seems like the identities do not match the provisioning profiles.

  • MichaelRumplerMichaelRumpler Michael Rumpler ATMember ✭✭✭✭

    I had to revoke my old signing certificates on https://developer.apple.com/account/ios/certificate/, change all provisioning profiles to use only the new certificates and do a fastlane sigh download_all again.
    Now I still have the old signing certificates in Xcode and I have all provisioning profiles three times but at least it works.

  • Minh_DinhMinh_Dinh Minh Dinh USMember
    edited April 18
    1. You could go to ~/Library/MobileDevice/Provisioning Profiles/ and remove all provisioning profiles at there.
    2. Then download provisioning profile you need from developer apple portal and double click to install it.
  • RichardMcGoughRichardMcGough Richard McGough USMember
    edited May 2

    I was stuck on this problem for about an hour. I solved it by toggling my build configuration in Visual Studio from Ad Hoc to Debug and back to Ad Hoc. That apparently made a fresh call to the mac to get the Profile Information and it worked.

Sign In or Register to comment.