Forum Visual Studio

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

iOS - Visual Studio Locks up on "Launching Application for debugging"

13»

Posts

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Hi David and Fredy, that most recent issue (from today) sounds like it might be Bug 28027, mentioned on the XamarinVS 3.9.525 and XamarinVS 3.9.483 release threads.

    To further confirm if you're hitting that same bug (so that I can increase its priority), I'd be curious to know:

    • Does deploying to an iOS simulator succeed (at least most of the time)?

    • Does the problem happen every time you attempt to deploy to an iOS device, or does it occasionally succeed? (In my local tests for bug 28027, I saw successful launches on about 3/16 attempts.)

    • Does the app launch on the device but then the VS debugger never connects to the app? (In my tests, the app starts on the device, but VS never connects.)

    Thanks in advance.

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    @BrendanZagaeski:

    Does deploying to an iOS simulator succeed (at least most of the time)?

    After start of VS2013, it works one time
    Mostly the second time don’t work. Error Message “Failed to start application on the target simulator”
    I then have to restart VS to be able to start the debugging one more time

    Does the problem happen every time you attempt to deploy to an iOS device, or does it occasionally succeed? (In my local tests for bug 28027, I saw successful launches on about 3/16 attempts.)

    Yes, every time

    Does the app launch on the device but then the VS debugger never connects to the app? (In my tests, the app starts on the device, but VS never connects.)

    No, the app is not launched on the device

    Since weeks I’m also not able to debug to my iPhone 5:
    The app is deployed to the device and started, the I have a hard crash, whereby the error-message is related to Android
    I have filled a bug for this, almost a month ago:
    https://bugzilla.xamarin.com/show_bug.cgi?id=27776

    On Android-device (tablet and phone), I have similar problems (mostly, I can debug only one time to device, and further it is extremely slow (if the first breakpoint is reached, VS stops and show the line, the I have to wait minutes until the debugger is servable further).

    Further, in both IOS and Android, various objects are “unknown” = not observable (e.g. the application-object -> “Unknown identifier: Application” in debugger)
    I have filled a bug for this, more than two months ago:
    https://bugzilla.xamarin.com/show_bug.cgi?id=26492

    To be able to debug “a bit”, I have to change the platform/device by every debug-session (to be able to debug one time for each platform), then I have to restart VS. Actually, I am simply not able to debug my iPad and/or my iPhone.
    So, I have to “debug” blind without debugger (with DisplayAlerts or something similar) on the device
    Further I am not able to find out, where exactly a bug occurs / what exactly causes a crash and therefore I'am also not able to fill meaningful bugs to new XF-Version's (I normally overtakes the newest XF-versions to test it)

    Every debug session - if it then can be started - takes minutes until the debugger is available.
    Some of the objects can’t be observed, as they are “unknown”.

    :warning:Seriously, how should we work meaningful in this environment?!? :warning:

  • LukasEkstrmLukasEkstrm USMember
    edited April 2015

    I am having problem mentioned earlier - VS gets stuck on "Launching application for debugging..." using the simulator.
    I am currently using version 3.9.483.0.

    It deploys succesfully to the simulator but no debugging

  • mbalsam_nycmbalsam_nyc USMember ✭✭

    I just found that i did not have to restart if i erased the contents of this directory every 20 min or so

    C:\Users\\AppData\Local\Xamarin\Log\12.0

    You can do this while VS is running.. Its keeping a WCF trace log of every call between PC and MAC.

    I also converted by C drive to a SSD.

  • CorradoCavalliCorradoCavalli ITInsider, University ✭✭
    edited April 2015

    Same here! Stuck on "Launching Application for debugging" using 3.9.533.
    No errors, i just see Visual Studio debugger returning back to normal state, debugger probably gets detached under the hood.

    frustrating

  • CorradoCavalliCorradoCavalli ITInsider, University ✭✭

    Did a connection test between VS and Mac machine and i see this error, I've just updated SDK and no request to sync SDK appears.

  • FabioMelendezFabioMelendez USMember, University ✭✭

    Started getting this problem on iPAD emulator on Friday and today I updated packages and now it is also happening on the IPhone emulator, are there any known fixes for this ????

  • MilenPavlov.0879MilenPavlov.0879 USUniversity

    Same issue when debugging with iPad Air 2, Xamarin 3.9.547, Xmarin iOS 8.9.1.0, VS 2015. Using the emulator works fine..

  • RaphaelSchindlerRaphaelSchindler USMember ✭✭✭

    @CorradoCavalli I found this bug today. If you're looking in the logs under %LOCALAPPDATA%/Xamarin/Logs in the newest log file you will be presented with this error:

    Xamarin.VisualStudio.IOS.BuildHost Warning: 0 : [2015-04-22 11:39:53.8] There is a minor mismatch between the installed Xamarin.iOS (version 8.10.0.258) on the Mac Build Host 192.168.111.101 and the local Xamarin.iOS 8.10.0.0. When applying updates, make sure to keep both the Mac and Windows in sync.

    After I found this error message I started investigating and what I found is really surprising to me^^ On my Build-Host Mac there is Xamarin.iOS 8.10.0.258 installed. On my PC there is Xamarin.iOS 8.10.0.0 installed. So the missmatch is from the .258 from the version number.

    Sadly though if I try to Sync them nothing happens. So no debugging or deploying to iOS anymore^^

    @BrendanZagaeski This should be easy to fix. I'm currently on Beta Channel.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited April 2015

    Unfortunately, the "minor mismatch" warning in the log files is ignorable. As long as you have the Mac build host and the Windows machine updated to the same updater channel, they are properly synced. The SDK sync feature has been removed because new versions of Xamarin.iOS for Mac and Xamarin.iOS for Windows are now always released at the same time.

    Likewise, the last step in the build host diagnosis where it fails due to an "Outdated" SDK is ignorable. I've asked to have that step removed: https://bugzilla.xamarin.com/show_bug.cgi?id=28473.

  • RaphaelSchindlerRaphaelSchindler USMember ✭✭✭

    The thing is, I'm on the same release channel. I'm gonna update now to the new Release 3.11.445 maybe it is working then.

  • RaphaelSchindlerRaphaelSchindler USMember ✭✭✭

    Works now :smile:

  • DavidHessDavidHess DEMember ✭✭

    I'm having the same problem since updating to Xamarin.iOs 8.10 and Xamarin 3.11.445. Tried to reboot Windows and Mac severall times but didn't help. Im running VS2012 on my Windows machine.

  • ShahbazSAShahbazSA USMember

    I am facing the same problem with Visual Studio 2013. Xamarin.iOS 8.10 and Xamarin 3.11.445. All updated under stable channel. Please help @BrendanZagaeski . Could not debug on Mac through Build host showing Visual Studio Busy Notification while hanged.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    One known cause of the issue in recent builds (anything more recent than 3.9.347) is https://bugzilla.xamarin.com/show_bug.cgi?id=28027. If (a) the app launches successfully on device, but (b) Visual Studio never shows any output from the application in "Output -> Debug" and (c) trying to stop debugging causes VS to hang, then you are most likely seeing bug 28027. In that case, feel free to add yourself on CC on the bug report, or if you have a Business or Enterprise license, feel free to contact support (if this link redirects to the top-level kb.xamarin.com/ page the first time you click it, try clicking it once more) to let us know, and we'll add you to the tally of affected customers.

    If the symptoms on bug 28027 do not match the issue you're seeing, the most direct way forward would be to file a bug report with as much detail as possible (if this link redirects to the top-level kb.xamarin.com/ page the first time you click it, try clicking it once more). Feel free to post the link to any new bug report back on this thread. Thanks!

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Shoot. It turns out there is another cause of VS hangs when debugging iOS apps, this one specific to XamarinVS 3.11.445: Bug 29133. I had thought that bug was specific to Android, but I just confirmed that it also affects iOS. The "good" news for that bug is that it already has a fix and will be resolved in the upcoming service release (due to be released to the Alpha channel sometime this week).

    See the current release announcement for some additional details about both bug 28027 and bug 29133 (including how to request a "draft" development build that includes the fix for bug 29133).

  • JustinKeysJustinKeys USMember

    Updating to the Alpha channel fixed the iOS debugging issue for me.
    Thanks!

  • Edwin.3770Edwin.3770 USMember

    I also experienced this bug.

    VS2013
    Xamarin 3.11.458

    I tried switching to the Alpha channel, but this did not resolve it :(

  • opiantsopiants NZMember ✭✭

    Keep getting this as well. Soooooo frustrating! Happens every not and then and at random so can't really give proper repo steps.

  • CarlosCamposSVCarlosCamposSV SVMember

    I'm experience this but on VS2015 but happends each 3 or 4 successfully deploy :sweat:

  • CarlosCamposSVCarlosCamposSV SVMember

    Tried Alpha Release, and it got a bit better.. but the problem persist on VS 2015. Any solution to this already @BrendanZagaeski ?

  • CarlosCamposSVCarlosCamposSV SVMember
    edited July 2015

    I have noticed that If you disconnect your computer from WIFI (haven't tested on LAN) of the network you are connected with your build host, VS also hangs. I don't know if you already know this but I'm just putting that out there

  • Having the same issue on VS2015. Can deploy/debug to Android but deploying to connected iPhone hangs VS. (I also hang adding new resources through Visual Studio UI, so must edit csproj directly) -- perhaps weirdly related issues?

  • NoName2NoName2 USMember

    This problem is still current.

    Interestingly, debugging works on an iPad3, but not on an iPhone 6+ (both with same provisioning profiles etc)

  • Same problem here. VS freezes for about 5 minutes, then says:
    There was an unhandled exception trying to deploy and run your application.
    Failed to start debug proxy on the Mac

  • :| Just switched over to the alpha channel. Is there no longer a Xamarin Build Host application? Because I now do not have one. Color me irritated.

  • FredyWengerFredyWenger CHInsider ✭✭✭✭✭

    @LeoArgyropoulos, @DebugErr, @MichaelArner.4520, @CarlosCamposSV and at all other readers if this thread:
    We all have the same problems...
    If you don't have seen it already, there is a brand new SW for the connection VS <-> MAC underway...
    I have gave up to hope for a stable VS integration software based on the actual as, it seems to be extremely buggy already in the base and the problems only are moved from one to anther over a full year now (and also the "terminator speak" ("I will be back...") to the evergreens (solved - reappears - solved - reappears) are extremely annoying (at least for me :smirk:)

    But the new IS-SW seems to be re-developed from ground so we all can hope, that the problems we all have, really are solved in the new version and the terminator then don't speak anymore!

    Therefore, I have opened a new thread here (where the users, that have done a test should post their findings):
    http://forums.xamarin.com/discussion/52913/new-visual-studio-ios-support-blog-your-findings#latest

    Unfortunately, the first version seems to work only with an English-Language installation...

    I suggest you, to keep an eye on the thread above... and let's hope that soon a user is able to check-out the new version and... only can post good things.... (as we all know... the hope dies last...)

    Or... better... maybe you have an English installation, want to test the new version and then post your findings in the other thread...? :wink:

    Cheers :sunglasses:

  • NoName2NoName2 USMember

    Yeah, I had similar thoughts. I couldn't install the 4.0 Alpha, my system is sadly German, and the MSI crashes...

  • EdwardJudenEdwardJuden USMember

    I gave up on Visual Studio integration and now just use my Mac with Xamarin Studio. When my business license expires I will switch to Indie since this is the ONLY reason I purchased the business license. I am tempted to just bite the bullet and learn objective-C and just use XCode.

  • PhilippeBourquePhilippeBourque CAUniversity ✭✭
    edited October 2015

    Same problem here, but only with an iOS on device (iPhone 5 with iOs 9)

    Working great with the iPhone simulator, Windows Phone simulator and on Nexus 7 device

    Visual Studio 2015
    Windows 10
    Everything update on MAC.

  • AmiSchreiberAmiSchreiber USMember

    Same issues here. I can debug using the build host emulator on my Mac but can't use my physical iPhone. VS just hangs and says "Launching Application for debugging..."

  • jakezjakez USMember
    edited October 2015

    I'm also experiencing this problem with problem. Unable to my device. VS hangs on "Launching Application for Debugging"

    Visual Studio 2013
    Windows 8.1
    Xamarin.iOS 9.0.1.29
    OS 10.10

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited April 2017

    Note that as Fredy mentioned, the Cycle 6 "Release Candidate" that is currently available on the Alpha updater channel includes a completely re-written build host (based on SSH rather than HTTPS). The new connection solves at least 2 specific timing-dependent problems that can arise when debugging on iOS simulators and devices on the current Stable version:

    1. The primary symptom on Bug 28027 where the VS debugger intermittently failed to connect to the device.
    2. A secondary problem where an immediate failure could happen if you attempted 2 deployments in rapid succession.

    It likely also fixes several other similar timing-dependent problems.

    Remaining hangs in the Cycle 6 Release Candidate

    If you still see hangs on the new Cycle 6 version, please do file a quick bug report using the Cycle 6 Release Candidate bug filing page. The XamarinVS team is quite interested to gather reports of symptoms in the Cycle 6 build host connection, even if the bug reports are "rough" (that is, even if they don't include all of the possible details or a specific way to reproduce the problem). Since the SSH-based connection code is still brand new, they are looking to get as much real-world usage data as possible to help make the eventual Stable version as robust as possible. Thanks in advance!

    Future reports of hangs after Cycle 6 is released to Stable

    I will now close this thread because reports of hangs in the IDE should almost always be directed to bug reports or emails to the support team via "Business & Enterprise Support." (Note that hangs in the IDE are always worthy of bug reports. Forum threads might occasionally be helpful for IDE hangs if other users have found some ways to work around the problem, but especially in cases like this thread where no workarounds have been found, bug reports are the best way forward. That said, I am happy to reopen this thread within the next month or two if a user does find a workaround they would like to share. Feel free to send a quick email to [email protected] to make that request.)

    If the problem resurfaces after Cycle 6 is released to Stable (or on any follow-up bugfix "Service Release" based on Cycle 6), please do file a bug using the specific bug-filing links that will be provided for those releases. Thanks again!

This discussion has been closed.