Issues

NinaVyedinNinaVyedin Nina VyedinUSXamarin Team, University, XamUProfessors Xamurai
edited January 2015 in Profiler

Something not working right? We can help!

Please include information about your environment, including the version of the profiler you're using. Include logs (see docs for more info on profiler logs: http://developer.xamarin.com/guides/cross-platform/deployment,_testing,_and_metrics/xamarin-profiler/#Logging_and_Diagnostics)

Answers

  • KaruneshVermaKaruneshVerma Karunesh Verma USMember

    I have Install all the component required.when i create Blank App(Xamarin.Form.Prtable) under Mobile App i got the error message as attachment.
    Please tell me what to do for this

  • KrystianKrystian Krystian USMember
    edited December 2014

    I had a similar issue using Visual Studio and I've found answer on SO that targeted frameworks should be slightly changed in popup window when you creating new App, the following combination in the PCL works:

    • .NET Framework 4.5
    • Windows Phone Silverlight 8
    • Xamarin.AndroidM
    • Xamarin.iOS

    BTW I think its wrong thread for this question

  • c0lbyc0lby Colby Williams USMember ✭✭✭

    Hi,

    When attempting to profile my iOS app, by selecting Run -> Start Profiling, the app builds, Xamarin Studio launches the Profiler, etc.

    However, a few seconds into launching the app (never getting past the launch screen) the app crashes.

    The Profiler does seem to be working initially, as I can see the allocations going up, but of course, when the app crashes, everything stops.

    I never get anything on the Application Output log, so I'm having a hard time figuring out what / where it's failing.

    (btw, the app doesn't crash when not profiling)

    Any advice on how to get past this?

    Thanks,

    c0lby

  • RobertDurfeeRobertDurfee Robert Durfee USMember ✭✭

    I'm having the same issues as Colby. As soon as Profiler starts and you begin using the app, either the Profiler crashes or the app crashes.

    Rob

  • RyanPalmer.0677RyanPalmer.0677 Ryan Palmer USMember ✭✭

    I'm having the same issue, app crashes moments after starting profiling (and it doesn't crash normally).

  • RyanPalmer.0677RyanPalmer.0677 Ryan Palmer USMember ✭✭
    edited December 2014

    The crash was happening on a 1st gen Nexus 7, i'm now running on a Galaxy S3 and it seems to be ok.

  • RyanPalmer.0677RyanPalmer.0677 Ryan Palmer USMember ✭✭

    Hmmm..crashed after about 5 mins

  • SebastianSeidel.9226SebastianSeidel.9226 Sebastian Seidel DEInsider, University ✭✭✭✭
    edited December 2014

    The filter input field to reduce the allocated types and such is not working.

  • NinaVyedinNinaVyedin Nina Vyedin USXamarin Team, University, XamUProfessors Xamurai

    For all - what version of the profiler are you using? Can you include a copy of the profiler logs?

  • PrasadCM.3389PrasadCM.3389 Prasad CM USMember

    I am unable to profile my app on iPhone 4S. It launches the profiler, the app is started. However the profiler is not logging allocations

  • shawshaw Stephen Shaw USXamarin Team, Insider Xamurai

    I believe I've seen the app crashing before. I'm not sure what exactly causes it. I believe it has gotten much much better in the next version coming out (very soon).

    Btw, knowing what version of mono, Xamarin.iOS, Xamarin.Android, and Xamarin Studio would be very helpful as well.

    Cheers,
    Stephen

  • RodrigoMoyaRodrigoMoya Rodrigo Moya ESXamarin Team Xamurai

    Could anyone experiencing the iOS apps crashes retrieve the device/emulator logs (as well as the profiler logs)? The best way to do so is to 1st add '-v -v -v -v' to the iOS app build options in XS (in Options dialog->iOS Build->General->Additional mtouch arguments), then start profiling the app and let it crash. Then, retrieve the logs from the device/emulator, which will include lots of Xamarin.iOS debug output which will help us finding the cause.

    Also, the profiler logs, which are in ~/Library/Logs/Xamarin.Profiler on Mac and %appdata%Local/Logs/Xamarin.Profiler on Windows.

    The best would be to file a bug to our Bugzilla, but it's ok if you just paste links here or send in private mail.

  • SebastianSeidel.9226SebastianSeidel.9226 Sebastian Seidel DEInsider, University ✭✭✭✭

    The link behind "More Information" in the message about using Boehm as GC is not working in the current downloadable profile package (XamarinProfiler.Mac v 010-720).

    The link-target is: http://developer.xamarin.com/guides/cross-platform/deployment,_testing,_and_metrics/xamarin-profiler/introduction_to_xamarin_profiler#profiling-ios-applications and it results in an 404.

  • NinaVyedinNinaVyedin Nina Vyedin USXamarin Team, University, XamUProfessors Xamurai
    edited January 2015

    This links works: http://developer.xamarin.com/guides/cross-platform/deployment,_testing,_and_metrics/xamarin-profiler

    The iOS profiling section is a little ways down.

    I'll let our devs know to update the link.

  • TomasVojtek.6570TomasVojtek.6570 Tomas Vojtek SKMember

    Hi,

    we are experiencing same problem as mentioned above. When running xamarin.iOS app without profiler, it works correctly (but it crashes later on while working with it (this crash we are trying to solve by using profiler)).

    Once we start app using profiler run > start profiling application crashes and profiler stops at exactly 21 seconds on splash screen (every time profiler stops at exactly 21 sec).

    we have:

    Xamarin Studio
    Version 5.9 (build 431)

    xamarin profiler Version 0.14-0 (1)
    Xamarin.iOS Version: 8.8.1.9 (Business Edition)

    We will try to get some logs for you. But I didn't see any movement for few months here, do you have some solution for this problem?

    Tomas

  • RodrigoMoyaRodrigoMoya Rodrigo Moya ESXamarin Team Xamurai

    @TomasVojtek.6570 this looks a lot like the timeout iOS uses to let apps start, killing them if they fail to respond in time. So, I guess the runtime profiler is adding some overhead that prevents the app to complete its startup in time (since you say it doesn't do this when not running the profiler). So, could you please provide us with the profiler logs and, if possible, the crash report for the iOS app (located in ~/Library/Logs/DiagnosticReports for simulators)?

    As for a solution, without logs, it is hard to know exactly what the problem is, so please either provide them here or, better, file a bug to bugzilla with all the information.

Sign In or Register to comment.