Forum General

Problems getting up and running on PC

Just some feedback so far of my experience trying to get Mono for Android running on my PC.

I thought I already had an account on this site so i tried to sign into this forum. The log in form dialog comes up, I enter my info and after a few seconds the dialog closes. Thought I was logged in so I was hunting around for the "Post Thread" button. After realizing that I had not been authenticated I attempted to log in a few more times with the same result. No indication my log in had failed, the dialog just goes away like everything was fine. Recommendation... have your developer take a few moments and fix the log in form so that it provides feedback to the user when their log in fails.

So I figured I would try and register, Almost aborted that because when I got down the to country drop down list I clicked on it and hit the "U" key on my key board because I live in the "United States" and did not want to scroll all the way down to the U's. When I got to the U's I noticed that there were a few countries in the list starting with the letter U but did not see the "United States" option. So I tried A for "America" but still no option for my country. This is where I nearly gave up but then noticed that the list options were not ordered alphabetically like 100% of the other web sites I have visited over the years. Luckily I scrolled down near the bottom of the entire list and found the option I needed. Recommendation... sort your list options alphabetically.

While I was trying to gain access to this site I had the Mono for Android installer running. I was not given the option to select where I wanted to install the software, I don't have a lot of space left on my C drive so i need to install this on another drive. With out being able to select a location to install this software I doubt I will be able to install it. The installer shows me some required components like the Android SDK for one, the installer does not detect that I already have the SDK on another drive due to the lack of space on my primary drive. The installer wants to download and install the SDK anyways rather than giving me an option to specify it's current location.

While the installer was doing it's business my chrome browser started crashing because some of my plugins became unstable and failed to load. After nearly 10 minutes of the installer indicating it had made 0% progress I figured I would cancel and restart it in order to give my PC an opportunity to become stable again. I clicked the cancel button and the installer dialog closes but I noticed that my PC resources are still under heavy load. Looking at the running processes I can still see the Mono for Android installer running as well as the Xamarin Setup.exe still running. After killing those two processes my system process became so hosed up I had to kill the power to my PC because it was unusable at that point. Not sure why the install went south but had I been able to tell the installer that I already had the SDK on my machine that would have been one less step it had to worry about.


  • brajkovicbrajkovic USXamarin Team, University Xamurai
    edited November 2012

    Hi Jesse,

    We've reported the issues with the forum login form to the upstream developer. Thanks for your recommendation.


    Edit: Also, the register page should have sorted countries--you may have received a cached version. I've kicked the caches so you should now see a properly sorted list.

  • JonathanPryorJonathanPryor USXamarin Team Xamurai

    Thank you for the feedback.

    the installer does not detect that I already have the SDK on another drive due to the lack of space on my primary drive

    The cause is that you (unfortunately) used the wrong Android SDK installer. Google provides two installers: a .exe installer and a .zip archive. The .exe installer, in addition to installing the Android SDK, also adds Windows Registry entries which allows us to detect that (1) the Android SDK has been installed, and (2) where it's located. Unfortunately, it appears that you used the .zip installer, which provides neither of these properties. (Tracking Bug)

    The inability to specify installation directory has been filed as Bug 8157.

  • Actually I did use the .exe, "Android SDK Tools Setup Wizard". Then after that I used the SDK Manager.exe to download all the various SDK files and tools.

Sign In or Register to comment.