Can't run app on Visual Studio 2015 emulator (DWP Handshake failed)

CorradoCavalliCorradoCavalli Corrado CavalliITInsider, University ✭✭

Installed everything and created a blank Android application, when I press F5 emulator starts, i see assemblies deployed but then debug crashes with this error

In mgmain JNI_OnLoad
Couldn't connect to logcat, GetProcessId returned: 0

I then get a dialog with following stacktrace


Error initializing the debugger: Mono.Debugging.Soft.ConnectionException: Could not connect to the debugger. ---> System.IO.IOException: DWP Handshake failed.

Server stack trace:

at Mono.Debugger.Soft.Connection.Connect()

at Mono.Debugger.Soft.VirtualMachine.connect()

at Mono.Debugger.Soft.VirtualMachineManager.Connect(Connection transport, StreamReader standardOutput, StreamReader standardError)

at Mono.Debugger.Soft.VirtualMachineManager.ConnectInternal(Socket dbg_sock, Socket con_sock, IPEndPoint dbg_ep, IPEndPoint con_ep)

at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs)

at System.Runtime.Remoting.Messaging.StackBuilderSink.AsyncProcessMessage(IMessage msg, IMessageSink replySink)

Exception rethrown at [0]:

at System.Runtime.Remoting.Proxies.RealProxy.EndInvokeHelper(Message reqMsg, Boolean bProxyCase)

at System.Runtime.Remoting.Proxies.RemotingProxy.Invoke(Object NotUsed, MessageData& msgData)

at Mono.Debugger.Soft.VirtualMachineManager.ConnectCallback.EndInvoke(IAsyncResult result)

at Mono.Debugger.Soft.VirtualMachineManager.EndConnect(IAsyncResult asyncResult)

at Mono.Debugging.Soft.SoftDebuggerSession.<>c__DisplayClass9.b__8(IAsyncResult ar)

--- End of inner exception stack trace ---

Posts

  • CorradoCavalliCorradoCavalli Corrado Cavalli ITInsider, University ✭✭

    Ok, got it... I haven't unchecked that Use Fast Deployment option.
    Everything is ok now. :)

  • MarkWildenbergMarkWildenberg Mark Wildenberg NLMember

    thnx for the tip! I forgot about the fast deploy :smile:

  • MudassirShahMudassirShah Mudassir Shah USMember

    From where I have to uncheck the fast deployment.... ??

  • anveshanvesh anvesh USMember

    In visual studio,
    Project=>Properties=>Android Options
    In Xamarin Studio,
    Project=>Project Options =>Android Build =>Fast deployment

  • DonPabloneDonPablone Pablo Cuadra CLMember

    Thanks guys for the tips.

  • HumaylHumayl salman mazhar AEMember ✭✭

    I did the same , still same error

  • MarcoAntonioFonatanaTellesMarcoAntonioFonatanaTelles Marco Antonio Fonatana Telles USMember

    I'm having the same problem .. and even taking the recommended actions the error persists, try also:
    Android Manifest -->Required Permission -->Enable ACCESS_COARSE_LOCATION and INTERNET(tick)
    Android Options --> Supported Architecture -->Enable armeabi and armeabi-v7a

    and even then the error persists

Sign In or Register to comment.