ibtool error The operation couldn’t be completed. -[NSTaggedPointerString getCharacters:range:]:

KeenOnAppsKeenOnApps ✭✭NLMember ✭✭

Hello,

I've been torturing myself to find a solution for this error the past couple of days and I can't get it to work. So I need your help!
I've updated Xamarin iOS/Studio/iOS SDK/Xcode to latest versions on wednesday and the whole project compiled perfectly.
On Friday I upgraded to Yosemite and also installed new Xamarin Studio / Xamarin iOS SDKs and since then the project does not want to compile.

I get the following error:
Applications/Xcode.app/Contents/Developer/usr/bin/ibtool --errors --warnings --notices --minimum-deployment-target 6.0 --output-format human-readable-text --compile "/--path-removed--/IntroView.xib" --sdk "/Applications/Xcode6.1.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator8.0.sdk"
2014-10-19 16:09:41.663 ibtoold[2615:75649] Exception raised while decoding document objects - -[NSTaggedPointerString getCharacters:range:]: Range {0, 10} out of bounds; string length 7
/* com.apple.ibtool.errors */

error: The document "IntroView.xib" could not be opened. The operation couldn’t be completed. -[NSTaggedPointerString getCharacters:range:]: Range {0, 10} out of bounds; string length 7.
Failure Reason: -[NSTaggedPointerString getCharacters:range:]: Range {0, 10} out of bounds; string length 7.
Recovery Suggestion: Check the console log for additional information.
ibtool exited with code 1
Build complete -- 1 error, 36 warnings

What I've done:
Downgraded Xamarin Studio, Xamarin iOS SDK and Xcode to previous versions and still got the same error. Also checked out an older revision from SVN and still had the same problem. This all makes me think that this is not an Xcode or Xamarin error because it worked before. But I also don't think the OS alone can cause this... I've seen some threads with a similar message about a storyboard but I can't map that problem to this one.
I hope someone can give me a hint on where to search or about a next step.

I started a new iPhone project master/detail and that one compiled (but it doesn't have .xib files).

Thanks!

Posts

  • rcaratchukrcaratchuk BRMember

    I'm having the same problem.
    After upgrading to Yosemite, I noticed that when mainstoryboard is changed, the application does not compile anymore.
    My application has stopped working.

  • DavidMarconnet.7018DavidMarconnet.7018 USMember
    edited October 2014

    Same problem here after upgrading to Yosemite. This is a show-stopper.

    UPDATE: I cleared out the Image property on a UIImageView I had on the storyboard and things started working again. If I set this in the storyboard, everything breaks again, so it's all in the code now.

  • KeenOnAppsKeenOnApps ✭✭ NLMember ✭✭

    In my case there ain't no storyboard. That's why I can't map the other solutions to my situation.
    Shoud we remove all image declaration in the XIB files and assign them by code?

  • rcaratchukrcaratchuk BRMember

    managed to solve.
    In mainstoryboard removed the image of the subdirectory to the same level of the Resource.
    is working ....

Sign In or Register to comment.