Is AnimationInterval ignored?

Hi everyone,

I try to set my FPS with AnimationInterval but it looks like it is ignored or at least I can't see a difference in frames. Sadly DisplayStats throws still an exception so I can't see the actual frames on screen.

Is there anything that I need to consider when using AnimationInterval, is this the wrong method for changing FPS or is it really ignored?

Best Answer

Answers

  • kjpou1kjpou1 LUMember, Xamarin Team Xamurai

    Maru

    What platform?

  • MaruMaru DEMember ✭✭

    @kjpou1‌ Ah, sorry! Its on Android, Genymotion emulator.

  • MaruMaru DEMember ✭✭

    @kjpou1‌ Thank you for adding these.

    Is there any news on the package update on Nuget now that Evolve is over? :)

  • kjpou1kjpou1 LUMember, Xamarin Team Xamurai

    Maru

    Here is a screen shot of the DisplayStats on Android simulator.

  • MaruMaru DEMember ✭✭

    @kjpou1‌ I can confirm after updating that DisplayStats is working.

    Sadly now I can see that the AnimationInterval is not changing. I tried AnimationInterval = 1.0 / 30.0 to get 30FPS but DisplayStats shows still 60FPS.

  • kjpou1kjpou1 LUMember, Xamarin Team Xamurai

    We have the issue open here on that one. We will be taking a look at.

  • MaruMaru DEMember ✭✭

    @kjpou1‌ Thank you for looking into that.

    Using your code is solving my problem, so I see in the stats 30FPS. The difference in your code is that you set AnimationInterval for CCApplication while I was setting it for CCWindow.

    Can you maybe explain what the difference between these two AnimationIntervals are?

  • kjpou1kjpou1 LUMember, Xamarin Team Xamurai
    edited October 2014

    @Maru‌

    Thank you for letting us know about theAnimationInterval for CCWindow not working. I have opened an Issue for this to be worked out.

  • MaruMaru DEMember ✭✭

    @kjpou1‌ Thank you for opening and resolving this issue! :)

Sign In or Register to comment.