Forum Visual Studio

Crashlytics configuration error

I have a problem today with crashlytics intergration in the last Xamarin studio version. At the end of the build, its says "Could not configure Crashlytics: undefined method `[]' for nil:NilClass.". I had no problems (crash reporting was working fine) before installing the last version of Xamarin Studio. I tried then to install the previous version of studio again, but the issues is the same.

Is it a know issues? Causing by Xamarin or Crashlytcis? Is it possible to fix it? Thanks for your answer!


  • NicolasDougoud.5371NicolasDougoud.5371 CHMember ✭✭
    edited March 2013

    I have tested the same thing on the Mac of a colleague who has not updated xamarin studio. The message is the same.... "Not possible to configure Crashlytics".

    I guess that the problem is not the update. I have probably broken something in the code but my project and my solution did not have change since the last time I successfully sent the build infos to crashlytics... The API key seems also to be alright.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Can you revert back to previous versions of your code to see if that still works? If so, then you can do a binary search in your commit history to find which commit broke it.

  • Thanks for the answer! I tried to revert my changes and build again the version that was working but still the same message. Weird... I was thinking it's maybe a server issue, but no requests seem to be sent according to my http traffic sniffer.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    That is strange because afaict, the only time that error is shown is if the server responds with an error.

  • Ok. I am contact with Crashlytics to see if there is a problem on their side. Thanks for your help!

  • m8rgem8rge RUMember
    edited March 2013

    I have same issue. I'm using Xamarin Studio 4.0.3

    DartfishDev, do you solve the problem?

  • The answer of crahlytics team:

    "Regarding Xamarin integration, unfortunately Xamarin released this very, very prematurely and it is currently unsupported."

  • IanVinkIanVink CAInsider, University ✭✭✭

    I am getting the same issues reported when I build with 4.0.1

  • m8rgem8rge RUMember
    edited March 2013

    I used dtruss utility, but can't see any strings related to crashlytics.
    Does anybody knows how xamarin integration with crashlythics works?

    Error "undefined method '[]' for nil:NilClass" definitely comes from crashlythics server, because it's ROR error.

  • RolfBjarneKvingeRolfBjarneKvinge USXamarin Team Xamurai

    I've been able to track this down to the app icon - if you use an icon that's bigger than 64x64 this error will show up (this typically happens with iPad Retina icons).

    I've contacted Crashlytics to see if they can fix it on their servers, if that's not possible I'll fix it for the next release of Xamarin Studio.

  • m8rgem8rge RUMember
    edited March 2013

    Much appreciated, rolf!

    I removed ipad retina icon and crash info uploaded successfully!

  • Great work!!!

Sign In or Register to comment.