Not getting proper output from Visual Studio but From mac Its working fine

I was trying the tableview example from the developers section, the exact code is just showing a empty screen if i run from visual studio and the same is working fine in xamarin studio in mac

Posts

  • JohnSIJohnSI USMember

    I was checking the Logs and I am getting following error

    Debug session started...
    Loaded assembly: /Users/Freddy/Library/Application Support/iPhone Simulator/7.1-64/Applications/CA6CAEA0-7DAD-447C-B9DA-45A3AAC9B7E4/App19.app/Xamarin.iOS.dll
    Loaded assembly: /Users/Freddy/Library/Application Support/iPhone Simulator/7.1-64/Applications/CA6CAEA0-7DAD-447C-B9DA-45A3AAC9B7E4/App19.app/System.dll
    Thread started: #2
    Loaded assembly: /Users/Freddy/Library/Application Support/iPhone Simulator/7.1-64/Applications/CA6CAEA0-7DAD-447C-B9DA-45A3AAC9B7E4/App19.app/App19.exe
    Loaded assembly: /Users/Freddy/Library/Application Support/iPhone Simulator/7.1-64/Applications/CA6CAEA0-7DAD-447C-B9DA-45A3AAC9B7E4/App19.app/System.Xml.dll
    Loaded assembly: /Users/Freddy/Library/Application Support/iPhone Simulator/7.1-64/Applications/CA6CAEA0-7DAD-447C-B9DA-45A3AAC9B7E4/App19.app/System.Core.dll
    Loaded assembly: /Users/Freddy/Library/Application Support/iPhone Simulator/7.1-64/Applications/CA6CAEA0-7DAD-447C-B9DA-45A3AAC9B7E4/App19.app/Mono.Dynamic.Interpreter.dll [External]
    2014-09-27 20:39:33.339 App19[1982:70b] Unknown class App19ViewController in Interface Builder file.
    2014-09-27 20:39:33.354 App19[1982:70b] Error loading /System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib: dlopen(/System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib, 262): Symbol not found: __dealloc
    Referenced from: /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    Expected in: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator7.1.sdk/usr/lib/libobjc.A.dylib
    in /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    2014-09-27 20:39:33.355 App19[1982:70b] Cannot find function pointer IOHIDLibFactory for factory 13AA9C44-6F1B-11D4-907C-0005028F18D5 in CFBundle/CFPlugIn 0x7c87efb0 </System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin> (bundle, not loaded)
    2014-09-27 20:39:33.357 App19[1982:70b] Error loading /System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.
    plugin/Contents/MacOS/IOHIDLib: dlopen(/System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib, 262): Symbol not found: __dealloc
    Referenced from: /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    Expected in: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator7.1.sdk/usr/lib/libobjc.A.dylib
    in /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    2014-09-27 20:39:33.357 App19[1982:70b] Cannot find function pointer IOHIDLibFactory for factory 13AA9C44-6F1B-11D4-907C-0005028F18D5 in CFBundle/CFPlugIn 0x7c87efb0 </System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin> (bundle, not loaded)
    2014-09-27 20:39:33.360 App19[1982:70b] Error loading /System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib: dlopen(/System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib, 262): Symbol not found: __dealloc
    Referenced from: /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    Expected in: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator7.1.sdk/usr/lib/libobjc.A.dylib
    in /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    2014-09-27 20:39:33.361 App19[1982:70b] Cannot find function pointer IOHIDLibFactory for factory 13AA9C44-6F1B-11D4-907C-000
    5028F18D5 in CFBundle/CFPlugIn 0x7c87efb0 </System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin> (bundle, not loaded)

  • MikeRogersMikeRogers USMember

    John, Have you gotten any resolution?

    All of a sudden I have getting this in our app console: 2014-09-29 15:35:29.772 MemberMobileInbox[77742:70b] Error loading /System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib: dlopen(/System/Library/Extensions/IOHIDFamily.kext/Contents/PlugIns/IOHIDLib.plugin/Contents/MacOS/IOHIDLib, 262): Symbol not found: __dealloc
    Referenced from: /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation
    Expected in: /Applications/Xcode 5.1.1.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator7.1.sdk/usr/lib/libobjc.A.dylib
    in /System/Library/Frameworks/CoreFoundation.framework/Versions/A/CoreFoundation

    Same error you are getting, it doesn't seem fatal though. But I am getting mystery crashes every once in a while from unknown monotype runtime errors.

  • JohnSIJohnSI USMember

    Nope, I think the new SDK update is causing this, Just waiting to hear back from the Xamarin Guys

  • reshmapopupreshmapopup USUniversity

    Hey guys,
    facing same problem. any updates on this.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited October 2014

    Thanks for the reports! The messages about missing symbols when loading IOHIDLib are caused by a bug in Apple's frameworks. Note that these messages only appears when running on the simulator (and the messages are harmless as well).

    The only known workaround for the moment is to enable the linker in the project's iOS Build Options (set "Linker behavior" to "Link SDK assemblies only"), but that might slow down the build speed significantly depending on the number of SDK assemblies used by the app.

    If you're having trouble building, deploying, or debugging, there's no need to worry about these messages. Instead, you can check the Verbose build output log, the Xamarin for Visual Studio logs, and the Build Host logs on the Mac to look for additional errors. (See: http://kb.xamarin.com/customer/portal/articles/1675684-how-to-collect-version-information-and-logs).

Sign In or Register to comment.