Forum Visual Studio
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

iPad missing in Device List ?

FlorianDahnFlorianDahn DEMember ✭✭
edited September 2014 in Visual Studio

hi everybody,

i updated my Windows and Mac components yesterday, and it seems that my iPad mini did not appear on the device list on visual Studio, did anyone noticed this too ?

And sometimes the Connection to the build Server gets interruped after failed build from build host, so i have to reconnect, a bit annoying.

Visual Studio 2012
Xamarin.iOS 8.0.62.0
Xamarin 3.6.249

Thanks

Posts

  • FlorianDahnFlorianDahn DEMember ✭✭
    edited September 2014

    for a short amount the iPad appears, really curious, but i got some error messages from the build server now

    [25-Sep-2014 16:40:15] Request handled in 0,551ms
    [25-Sep-2014 16:40:21] Error: Command [ListDevices: CommmandUrl=ListDevices] failed.
    [25-Sep-2014 16:40:21] Exception: Exception type: System.ArgumentNullException
    Argument cannot be null.
    Parameter name: version
      at System.Version..ctor (System.String version) [0x00000] in <filename unknown>:0 
      at Mtb.Server.DeviceListener.<GetDevices>m__1 (Xamarin.MacDev.IPhoneDevice d) [0x00000] in <filename unknown>:0 
      at System.Linq.Enumerable+<CreateSelectIterator>c__Iterator10`2[Xamarin.MacDev.IPhoneDevice,Mtb.Server.Device].MoveNext () [0x00000] in <filename unknown>:0 
      at System.Collections.Generic.List`1[Mtb.Server.Device].AddEnumerable (IEnumerable`1 enumerable) [0x00000] in <filename unknown>:0 
      at System.Collections.Generic.List`1[Mtb.Server.Device]..ctor (IEnumerable`1 collection) [0x00000] in <filename unknown>:0 
      at System.Linq.Enumerable.ToList[Device] (IEnumerable`1 source) [0x00000] in <filename unknown>:0 
      at Mtb.Server.DeviceListener.GetDevices () [0x00000] in <filename unknown>:0 
      at Mtb.Server.Commands.ListDevices.GetDevices () [0x00000] in <filename unknown>:0 
      at Mtb.Server.Commands.ListDevices.HandleRequest (ILoggingHelper logger, System.Object commandRequestState) [0x00000] in <filename unknown>:0 
      at Mtb.Server.BaseCommand.OnRequest (System.Net.HttpListenerContext context, System.Object commandRequestState) [0x00000] in <filename unknown>:0 
      at Mtb.Server.Listener.OnRequest (System.Object state) [0x00000] in <filename unknown>:0 
    [25-Sep-2014 16:40:21] Request handled in 0,633ms
    

    i got now more into it, after restarting the iPad, it appears in the list, before i unlock the device with the lock code, after unlocking it disappears...

    there runs the latest iOS 8 on the iPad, maybe the reason ? iPhone with iOS 8 works fine

  • ZachGreenZachGreen USUniversity

    I am getting the same error when trying to connect to my iPhone 6 on 8.0.2. My iPod works fine. You ever figure out the solution to this problem?

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Thanks for the reports! The new hotfix just released to the stable channel (Xamarin 3.6.262) should significantly improve or eliminate problems with missing or disappearing devices in the device list. It should also decrease the frequency of disconnects. The hotfix specifically addresses a situation where VS was keeping the build server connection busier than it should have.

  • FlorianDahnFlorianDahn DEMember ✭✭
    edited October 2014

    Hm, after the last update no device appeared anymore in the list. Just sometimes the iPhone 5 (8.0.2)

    Im running on Alpha channel, maybe the reason ?

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    There is unfortunately still one remaining issue with build server connectivity that can lead to missing devices. The Xamarin VS team is intently investigating that issue, and will hopefully have a fix quite soon.

    Possible workaround

    For one other user who was seeing an incomplete device list, the following steps to clear the log files and cache folders helped:

    1. Delete the following folders on the Mac build host:
      ~/Library/Logs/Xamarin/MonoTouchVS
      ~/Library/Caches/Xamarin/mtbs

    2. Delete the following folder on the Windows machine:
      %LOCALAPPDATA%\Xamarin\Log

    3. Click the "Unpair" button on the Xamarin.iOS Build Host app, and then repair again with Visual Studio.

    My guess is that the most important step is to delete ~/Library/Logs/Xamarin/MonoTouchVS/mtbserver.log.

  • FlorianDahnFlorianDahn DEMember ✭✭

    Ok thanks, i tried some stuff. Moving back to Stable Version was the fix for me, for the Moment.
    So Topic is closed.

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai

    Thanks for the updated results! I'll close this forum thread as a likely duplicate of the main thread on the "Argument cannot be null" error:

    http://forums.xamarin.com/discussion/25636/fixed-no-devices-attached-due-to-argumentnullexception-in-system-version-ctor/p1

This discussion has been closed.