No Devices Attached. trying to debug iOS app

After updating to the latest tools and SDKs, I get "No Devices Attached." and can't see any devices nor simulators. Build Host is running and is connected.

Xamarin 3.6.249.0
Xamarin.iOS 8.0.62.0

Microsoft Visual Studio Ultimate 2013
Version 12.0.30723.00 Update 3
Microsoft .NET Framework
Version 4.5.50938

On Mac side
=== Xamarin Studio ===
Version 5.4 (build 240)
Installation UUID: 154f502a-19fd-4977-a6c0-d1b53baffef1
Runtime:
Mono 3.8.0 ((no/45d0ba1)
GTK+ 2.24.23 (Raleigh theme)

Package version: 308000009

=== Apple Developer Tools ===

Xcode 6.0.1 (6528)
Build 6A317

=== Xamarin.Mac ===

Version:

=== Xamarin.iOS ===

Version: 8.0.0.62 (Business Edition)
Hash: 8bd8158
Branch:
Build date: 2014-09-18 09:12:55-0400

=== Xamarin.Android ===

Not Installed

=== Build Information ===

Release ID: 504000240
Git revision: 01786bc67c7024ec33d327ed27e4416d7a846f4e
Build date: 2014-09-17 10:58:48-04
Xamarin addins: 7cd7dfcd6b7b7b53281508954ec080f1cd153ad3

=== Operating System ===

Mac OS X 10.9.5

Posts

  • HodorHodor USMember
    edited September 2014

    Same issue here.

    I have tried to do everything from here but it looks like it's another issue.

    I'm also now getting the errors:
    Error: /Developer/MonoTouch/usr/share/doc/MonoTouch/MDocArchiveToMsxDocConverter.exe not found Error: /Developer/MonoTouch/usr/share/doc/MonoTouch/apple-doc-wizard not found

    .. but only after updating to the latest Xamarin.iOS for iOS 8.

    I've updated all of the developer tools in my Mac and the diagnostic tool on VS only works if I don't pair it first.
    Whenever I run the diagnostic tool with success, I need to re-pair my connection because I get the error "another instance of VS is in use".

    I'm able to compile and run from the Xamarin Studio at the Mac, but I cannot see any device from VS and I can't start any simulator.

  • I'm getting exactly the same problem since updating. It's blocking me from seeing any devices in Visual Studio.

  • Same issue here. After updating I cannot see any devices in Visual Studio 2013 Pro but I can compile and run from the Mac using Xamarin Studio.

    I had a very brief period where it was working (I deployed my app once to a new device), but then it seemed after syncing SDKs is when it broke (?). I tried re-installing Xamarin on my Windows PC and XCode on the Mac but no difference.

  • Same here, no devices attached. Also build on VS fails with this:

    1>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(419,3): error : Failed to load output manifest for actool for the file obj/iPhone/Debug/actool/asset-manifest.plist: Argument is out of range.
    1>C:\Program Files (x86)\MSBuild\Xamarin\iOS\Xamarin.iOS.Common.targets(419,3): error : Parameter name: index

  • After manually installing latest Xamarin installer from https://store.xamarin.com/account/my/subscription/downloads
    the issue is gone!

  • KarinKarin USMember

    That works KevinAshley. Same for me. After running the installer the issue was fixed.

    Note: I did run the installer previously but I recall other updates occurring such as the 3.6.245 to 3.6.249 update and some SDK synchronizations. Happily, after all was updated on both sides (Windows and Mac) and running the Windows installer again, it works. Thanks!

  • Similar problem:

    Warning 1 There is a minor mismatch between the installed Xamarin.iOS (version 8.0.0.63) on the Mac Build Host 192.168.1.101 and the local Xamarin.iOS 8.0.62.0. When applying updates, make sure to keep both the Mac and Windows in sync. 0 0

    I've tried all the ways to update without success!

  • BrendanZagaeskiBrendanZagaeski USForum Administrator, Xamarin Team Xamurai
    edited October 2014

    In case any users find this thread first when looking for the latest information about a "No Devices Attached" problem, you can first check the ~/Library/Logs/Xamarin/MonoTouchVS/mtbserver.log file on the Mac build host to look for an error message about an ArgumentNullException from System.Version..ctor. If you see that error, then the latest discussion can be found in the following thread:

    http://forums.xamarin.com/discussion/25636/no-devices-attached-due-to-argumentnullexception-in-system-version-ctor

    If you see a "No Devices Attached" problem where the mtbserver.log file does not contain an ArgumentNullException from System.Version..ctor, please start a new thread, or report the issue to contact@xamarin.com. Thanks!

    I'll close this thread for now to help consolidate any new reports of the problem.

This discussion has been closed.