Unable to deploy any app to IOS device since upgrading Xcode and Xamarin

2»

Posts

  • rmaciasrmacias USBeta, University ✭✭✭✭✭
    edited December 2014

    Okay, are you using an AdHoc provisioning profile, or a Developer Provisioning Profile? If you're using an AdHoc, the value must be "production". If you're using a Developer Provisioning Profile the value must be "development". Also, push notifications only work on actual devices. They don't work in the Simulator.

  • uwantfriesuwantfries GBBeta ✭✭

    I was using a dev profile with my dev entitlements. I also tried ad-hoc that used a production entitlements e.g the file was the same as above except development was production. I was using an iPod touch not the sim.
    http://forums.xamarin.com/discussion/comment/93715?#
    I am beginning to wonder if its failing due to firewalls but surely most peoples home routers block random ports? Also the documentation from apple suggests it uses 443 as a fallback over wifi.

  • uwantfriesuwantfries GBBeta ✭✭

    I spent last night testing and retesting. Eventually tried using the push sharp lib and it worked 1st time. Looks like a web service problem from the cloud push provider. Also works fine from Amazons APNS push system. So much time wasted :(

    Thank you for you perseverance @rmacias - I think my Entitlements problems did not help either but the main problem seems to be the push provider.

  • JR_VerberneJR_Verberne NLMember

    For everyone who is not being able to test (debug/release/ad-hoc) an IOS app on a physical device :

    The UDID tool you suppose to download from the Apple store retuns a wrong UDID. It does not match the UDID which shows up in XCode (6.1) under 'devices'. After entering this ID in my Provisionig Profile my app now runs perfect.

  • JohnSourcerJohnSourcer ZAMember ✭✭

    Clean & Rebuild.

  • I have been working on this problem for several days. It all started when I renewed my Apple credentials that were about to expire. I renewed them via Xcode 6 and verified operation with my iOS devices via Xcode. Now when I try to deploy a debug version of my Xamarin project to my iOS devices with the new certificates and provisioning profile I always get Unable to Deploy message. I am using Xamarin Studio (version 5.7) on my Mac. Xamarin had been working flawlessly prior to that with the same iOS devices.

    I get the following errors:
    Installing application bundle
    writeDictToFile:1249 open failed for /Users/gfelberbaum/Documents/iOSDevelopment/Smart Battery Reader/BatteryReader/BatteryReader.iOS/obj/iPhone/Debug/mtouch-cache/install-shadow-directory/9358f382cebf13302d000975e16dddf3/c71aedbdfdd3e9175d88575c4a2e6bb3cfa24cbb/ManifestCache.plist : No such file or directory

    **MDMCacheDirectoryManifest:1323 writeDictToFile failed to write to **/Users/gfelberbaum/Documents/iOSDevelopment/Smart Battery Reader/BatteryReader/BatteryReader.iOS/obj/iPhone/Debug/mtouch-cache/install-shadow-directory/9358f382cebf13302d000975e16dddf3/c71aedbdfdd3e9175d88575c4a2e6bb3cfa24cbb/ManifestCache.plist : No such file or directory

    **error MT1006: Could not install the application **'/Users/gfelberbaum/Documents/iOSDevelopment/Smart Battery Reader/BatteryReader/BatteryReader.iOS/bin/iPhone/Debug/BatteryReaderiOS.app' on the device Gary Felberbaum's iPad: Your application failed code-signing checks. Check your certificates, provisioning profiles, and bundle ids. Probably your device is not part of the selected provisioning profile (error: 0xe8008015).
    The application was terminated by a signal: SIGHUP

  • jack.lejack.le USUniversity

    You should remove all provisioning profiles and certificates. Then add them again, check if provisioning profiles match your certificate. It worked for me. I chose wrong provisioning profile

  • Pratik.0946Pratik.0946 USUniversity

    Did you try the following step:
    1. goto project options and select iOS bundle signing.
    2. remove all custom entitlements

    I hope this works

  • JeremyGinnJeremyGinn USUniversity

    I'm not sure if this will help anyone, but I've struggled with this issue for a few days now. All of my entitlements were lining up, I'd cleaned my solution, deleted my provisioning profiles and regenerated, cleared the profiles off my test iPhone. Then I looked back at my Entitlements.plist and instead of looking at it from the entitlements view, I changed it to the source view. Lo and behold, 'get-task-allow' had been set to 'no'. I did not change this setting, I assume it may have occurred during an update? Either way, I set it back to yes and I am back in business. I suppose this explained why even though I was receiving the "entitlement not supported" error, I could not find what entitlement was misaligned with my provisioning profile.

  • NathanTaylor.SBNathanTaylor.SB USMember
    edited July 2015

    I too have run into this wall and after trying everything in this thread, nothing has worked...

    writeDictToFile:1241 open failed for /Users/ntaylor/Development/Projects/xamarin/iTunesMediaDump/iTunesMediaDump/obj/iPhone/Debug/mtouch-cache/install-shadow-directory/0aeead4384aeb5c772922f3d200362d0/0de2388dec507a946b805a6ca40e1726e71ac9b4/ManifestCache.plist : No such file or directory
    MDMCacheDirectoryManifest:1315 writeDictToFile failed to write to /Users/ntaylor/Development/Projects/xamarin/iTunesMediaDump/iTunesMediaDump/obj/iPhone/Debug/mtouch-cache/install-shadow-directory/0aeead4384aeb5c772922f3d200362d0/0de2388dec507a946b805a6ca40e1726e71ac9b4/ManifestCache.plist : No such file or directory
    error MT1006: Could not install the application '/Users/ntaylor/Development/Projects/xamarin/iTunesMediaDump/iTunesMediaDump/bin/iPhone/Debug/iTunesMediaDump.app' on the device iPod touch: Your code signing/provisioning profiles are not correctly configured. Probably you have an entitlement not supported by your current provisioning profile, check the iOS Device Log for details (error: 0xe8008016).
    The application was terminated by a signal: SIGHUP

    I have tried manually deleting and re-adding my provisioning profiles, cleaning and rebuilding, completely deleting Entitlements.plist and the reference to it in the build config. Nothing works.

    This same iPod Touch works fine when I deploy to it from Xcode, but I haven't found a single Xamarin solution which does not produce the above error.


    Edit: I was able to successfully deploy the failing project to an iPhone, but my iPod Touch would not take. I'm not sure what else to try.

  • UmairEmUmairEm GBMember ✭✭

    I had the same issue when I added push notifications in my entitlements.

    What I missed is that for Ad-Hoc/Distribution builds the aps (notification) value must be set to production
    and for Debug/Development the aps (notification) value must be set to development

    I had the default value development while I was building under Ad-Hoc configuration.

    Hope this helps :)

Sign In or Register to comment.