iTunes App Rejection -Invalid Image path for AppIcons120x120

IanVinkIanVink CAInsider, University ✭✭✭
edited September 2014 in Xamarin.iOS

I'm getting an "Invalid Image path for AppIcons120x120" when I submit the app. Here's the json for the appIcons. Xamarin Studio shows all the images nicely.!

Ideas?

{ "images": [ { "filename": "Icon-Small.png", "size": "29x29", "scale": "1x", "idiom": "iphone" }, { "filename": "[email protected]", "size": "29x29", "scale": "2x", "idiom": "iphone" }, { "filename": "Icon-87.png", "size": "29x29", "scale": "3x", "idiom": "iphone" }, { "filename": "[email protected]", "size": "40x40", "scale": "2x", "idiom": "iphone" }, { "filename": "[email protected]", "size": "40x40", "scale": "3x", "idiom": "iphone" }, { "filename": "Icon.png", "size": "57x57", "scale": "1x", "idiom": "iphone" }, { "filename": "[email protected]", "size": "57x57", "scale": "2x", "idiom": "iphone" }, { "filename": "[email protected]", "size": "60x60", "scale": "2x", "idiom": "iphone" }, { "filename": "Icon-180.png", "size": "60x60", "scale": "3x", "idiom": "iphone" }, { "filename": "Icon-Small.png", "size": "29x29", "scale": "1x", "idiom": "ipad" }, { "filename": "[email protected]", "size": "29x29", "scale": "2x", "idiom": "ipad" }, { "filename": "Icon-Small-40.png", "size": "40x40", "scale": "1x", "idiom": "ipad" }, { "filename": "[email protected]", "size": "40x40", "scale": "2x", "idiom": "ipad" }, { "filename": "Icon-Small-50.png", "size": "50x50", "scale": "1x", "idiom": "ipad" }, { "filename": "[email protected]", "size": "50x50", "scale": "2x", "idiom": "ipad" }, { "filename": "Icon-72.png", "size": "72x72", "scale": "1x", "idiom": "ipad" }, { "filename": "[email protected]", "size": "72x72", "scale": "2x", "idiom": "ipad" }, { "filename": "Icon-76.png", "size": "76x76", "scale": "1x", "idiom": "ipad" }, { "filename": "[email protected]", "size": "76x76", "scale": "2x", "idiom": "ipad" }, { "filename": "Icon-120.png", "size": "120x120", "scale": "1x", "idiom": "car" } ], "info": { "version": 1, "author": "xcode" } }

Posts

  • An.NgoAn.Ngo VNMember

    I have the same problem as your. After digging into the info.plist in the final ipa file, I see the value AppIcons120x120, but the file is missing in the app bundle. It seem a bug of Xamarin.

  • SongtiveSongtive LVMember ✭✭

    Yeah, encountered with the same problem, which is delaying my publishing to Apple Store. Hope will be resolved soon.

  • BasileBasile USMember

    Same here !
    Can't validate without it ... any workaround for now or are we just stuck ?

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    This is really strange because we use Apple's tools to generate the AppIcons files in the app bundle along with adding the entries to the Info.plist.

    After a build, could you check in the obj/iPhone/AppStore/actool directory for 2 files: asset-manifest.plist and partial-info.plist?

    If you are missing files in your app bundle, make sure that the files exist in the actool directory as well as existing in the asset-manifest.plist file (the build system copies only the files listed in the asset-manifest.plist file, assuming all others are to be ignored).

    If you have entries missing in your app bundles Info.plist, does the Info.plist in your app bundle not match the values in the partial-info.plist file? (you can use plutil -convert xml1 Info.xml Info.plist to convert the binary plist in your app bundle into readable xml).

  • IanVinkIanVink CAInsider, University ✭✭✭
    edited September 2014

    Jeff. I'll update the bugzilla ticket with more information.

    https://bugzilla.xamarin.com/show_bug.cgi?id=23207

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Thanks Ian.

  • IanVinkIanVink CAInsider, University ✭✭✭

    --SOLUTION HERE---

    Following Jeff's thought that the App Uploader is the problem:

    I unset the CarPlay image in Xamarin Studio by right clicking it, changed the version number, cleaned the project and rebuilt fully everything.

    Note that ** keeping the version number caused the same error**, perhaps the App Uploader is caching.

  • SongtiveSongtive LVMember ✭✭

    Thanks @IanVink, worked for me too!

  • EmanEman USMember

    This worked for me too.. I open with the Contents.json thru Xcode and remove the CarPlay image. Though at first its not reflecting in Contents.json so I refresh the whole solution before changing the version number and rebuilt it.. Thanks @IanVink‌

  • DoubletouchDoubletouch AUMember

    I have just experienced this now, many months after the last post here - not sure why it still occurs. I was just starting to publish a new App so I didn't want to have to go through the process of incrementing the version number which would mean re-creating the version information on itunesconnect from scratch. So I found a solution that was slightly different to IanVink's solution:

    I unset the CarPlay image in Xamarin Studio by right clicking it in the asset catalog. I then added a new icon file to my Xamarin iOS project which matched the name of the missing file: AppIcons120x120.png. Right click on the image in Xamarin Studio and ensure the Build Action is set to BundleResource.

    I did the usual Clean All and Build All and proceeded with publishing.

  • MichaelKnappMichaelKnapp USMember

    I have the same problem - not sure how to proceed, almost all my icons are reported "missing" when publishing to the AppStore only

  • same problem here - using xamarin studio on mac version 5.10.3

  • StephenOLearyStephenOLeary USMember

    Using Xamarin Studio on Mac Version 5.10.3 - this also occurred for me for four icons. I'm also using a bundle resources just like the OP.

    This solution worked for me:

    In info.plist, go to the source tab and add a new property "Bundle icon files". Then add the array for the names of the missing files. Make sure those files are physically located in the resource folder. Then after all is done, do a build first. Then generate the archive.

    The xml that was generated for me from using the source tab in info.plist was this:

    <key>CFBundleIconFiles</key> <array> <string>appIcon120x120.png</string> <string>appIcon76x76.png</string> <string>appIcon152x152.png</string> <string>appIcon167x167.png</string> </array>
    Note that the icons i've listed were the ones that I was told were missing. Your filenames are obviously specific to your app.

Sign In or Register to comment.