Install Failed missing shared library.

Dear All.

I try an Xamarin sample ( field service), I compile it from Visual Studio 2010.
when i run and install on android 4.2.2 (SDK 17), I got an error Install Failed missing shared library.
I take acreenshoot and take on attachment, Please tell us what must we do.

regards

Posts

  • JonathanPryorJonathanPryor USXamarin Team Xamurai

    The Field Service project requires Google Maps, which in turn requires device target support. You are probably attempting to install to an Android emulator which lacks Google Maps support. You will need to create a new emulator target which supports Google Maps.

  • ChongLiKenChongLiKen MYMember ✭✭

    Thank You for fast respone.
    I try to to use google API, and it works.
    Thanks.

  • jonp: You will need to create a new emulator target which supports Google Maps.

    How do we do that?

  • JonathanPryorJonathanPryor USXamarin Team Xamurai

    How do we do that?

    From the MapsDemo README:

    Installing the Google APIs Android SDK add-on

    The Google APIs require the "Google APIs" add-on library, which is provided
    for each API level. You need to download it for the API level you wish to
    target.

    To install the Google APIs Android SDK add-on:

    1. Launch the Android SDK manager:
      $ANDROID_SDK_PATH/tools/android
    2. Within the Android SDK manager, click Available packages
      in the left-hand pane.
    3. In the right-hand pane, navigate to the tree view node Third party
      Add-ons /Google Inc. add-ons (dl-ssl.google.com)
    4. Select the check-box for e.g. "Google APIs by Google Inc., Android API
      8, revision 2".
    5. Click the Install Selected button in the lower right corner.
    6. In the "Choose Packages to Install" dialog, select the Accept
      radio button, then click the Install button.

    Creating a device with Google Maps support

    To verify that your target device has Google Maps support, you can use
    the following command to see if Google Maps support is present:

    $ $ANDROID_SDK_PATH/platform-tools/adb shell ls /system/framework/*map*
    /system/framework/com.google.android.maps.jar
    /system/framework/com.google.android.maps.odex
    

    The com.google.android.maps.jar library should be present on
    hardware devices, but may not be present within some emulators.

    If you need an emulator with Google Maps support:

    1. Launch the Android AVD manager:
      $ANDROID_SDK_PATH/tools/android avd
    2. Within the Android SDK and AVD manager, click Virtual devices
      in the left-hand pane.
    3. Click the New... button on the right-hande side.
    4. In the Create new Android Virtual Device (AVD) dialog, provide a
      name for the device (e.g. MAPS), and in the Target drop-down
      select the Google APIs (Google Inc.) - API Level 8 entry.
    5. Click the Create AVD button.

    You may now launch the emulator with:

    `$ANDROID_SDK_PATH/tools/emulator -partition-size 512 -avd MAPS`
    
  • zaraev.dzaraev.d USMember

    Hello. Hit with the same proplem. I just repeat all actions, described above, but
    error continues to appear later (not during deploy, but after start app in emulator).

    And for this check:

    $ $ANDROID_SDK_PATH/platform-tools/adb shell ls /system/framework/*map*

    I received only

    /system/framework/com.google.android.maps.jar

    but not .odex file.

    Sorry for my bad english.

  • JonathanPryorJonathanPryor USXamarin Team Xamurai

    Which emulator image are you using?

    When creating the AVD, you must set the Target to an "Google APIs (Google Inc.)" entry.

  • Hello Jonathan,

    Facing the same problem. Repeated all the steps told above , but still the problem exists. The emulator image I'am using is 'Google APIs (Google Inc.) - API Level 15'.

  • CaptainXamtasticCaptainXamtastic GBUniversity ✭✭✭

    Instead of:

    $ $ANDROID_SDK_PATH/platform-tools/adb shell ls /system/framework/*map*
    /system/framework/com.google.android.maps.jar
    /system/framework/com.google.android.maps.odex
    

    I get:

    $ $ANDROID_SDK_PATH/platform-tools/adb shell ls /system/framework/*map*
    /system/framework/com.google.android.maps.jar
    

    I've also added Android API 8, revision 2 as suggested above, followed the instructions on how to create an Emulator to the letter, and also tried it with an HTC ONE device connected.

    In all cases I get 11 errors that say that package com.google.android.maps does not exist

  • if you're using the xamarin android emulators... follow these steps https://university.xamarin.com/resources/how-to-install-google-play-on-android-emulator

  • RozymehtaRozymehta USMember

    Working fine with Google Api.

Sign In or Register to comment.