Forum Visual Studio

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Xamarin Update: Error retrieving update information ?

Any ideas why, seemingly no matter what, the 'Check for Updates' dialog will only ever show an error message?

Seemingly relevant Log message
ERROR [2013-03-14 22:36:01Z]:ERROR [2013-03-14 22:36:01Z]: Error checking for updates System.AggregateException: One or more errors occurred. ---> System.Net.WebException: The remote server returned an error: (500) Internal Server Error. at System.Net.HttpWebRequest.GetResponse() at Xamarin.Ide.Updater.UpdateService.<>c__DisplayClass2c.<QueryUpdateServer>b__28() at System.Threading.Tasks.Task1.InnerInvoke()
at System.Threading.Tasks.Task.Execute()
--- End of inner exception stack trace ---
at System.Threading.Tasks.Task.ThrowIfExceptional(Boolean includeTaskCanceledExceptions)
at System.Threading.Tasks.Task1.GetResultCore(Boolean waitCompletionNotification) at System.Threading.Tasks.Task1.get_Result()
at Xamarin.Ide.Updater.UpdateService.ReceivedResponse(IProgressMonitor monitor, Task1 t, UpdateLevel level, UpdateInfo[] updateInfos) ---> (Inner Exception #0) System.Net.WebException: The remote server returned an error: (500) Internal Server Error. at System.Net.HttpWebRequest.GetResponse() at Xamarin.Ide.Updater.UpdateService.<>c__DisplayClass2c.<QueryUpdateServer>b__28() at System.Threading.Tasks.Task1.InnerInvoke()
at System.Threading.Tasks.Task.Execute()<---
`

«1

Posts

  • mountainmountain NLMember

    Got the same problem since yesterday (2013-03-14). Alpha and beta channel give an error, Stable channel started download of MDK 2.10.11.

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    Which version of Xamarin Studio are you guys running?

    I think there was an updater fix as part of 4.0.1, but not sure if this was the one or not.

  • NathanBoukNathanBouk USMember

    I'm on 4.0.1

  • JoshuaRoseJoshuaRose USMember, Beta, University

    I am having the exact same issue with the same log message, also running 4.0.1 on OSX

  • JamesLaveryJamesLavery GBBeta, University ✭✭✭✭✭

    I think there was a general problem on the Xamarin server yesterday. Xamarin.com itself was returning a 500 error!

    I think it's fixed now - I managed to update my XS yesterday afternoon (on Windows).

  • NathanBoukNathanBouk USMember

    My issue isn't just yesterday. Same error is still happening, and has been happening since I got the Xamarin Studio update from MonoDevelop.

  • LluisSanchezLluisSanchez ESXamarin Team Xamurai

    Nathan, are you running Windows or Mac OSX?

  • NathanBoukNathanBouk USMember

    Windows

  • LluisSanchezLluisSanchez ESXamarin Team Xamurai

    Ok, try again, it should be fixed now.

  • lee.7753lee.7753 USMember

    I am facing the same problem from last 2-3 days..

    I did a install on my windows 7 laptop and was trying to update the xamarian..
    But any time I try the update in alpha channel it always says " Error retireving information:"

    I tried using a different user ID but somehow it picks information from the registry...

    I am not able to do any updates and my project is critically impacted...

    Its very annoying the problem isn't fixed even if I do a complete re-installtion of xamarian for atleast 7 times ( seems foolish though )

    I guess there are some registry settings, which are take everytime even when I do a fresh installation on the same machine

    I don't have a problem on my Desktop.. which is a different machine..

    I can't reimage my OS just to fix this issue ..

    Regards
    Lee

  • LluisSanchezLluisSanchez ESXamarin Team Xamurai

    Hi Lee, can you try updating again? it should work now. This is an issue in our updater server, you don't need to reinstall.

  • kirkuskirkus USMember, Beta

    Still getting errors on all channels on XS 4.0.1 on Mac (10.8.3)

  • lee.7753lee.7753 USMember

    Atleast I found stable channel working.

    Still have problems with Alpha and Beta channels

  • LluisSanchezLluisSanchez ESXamarin Team Xamurai

    @kirkus, @lee.7753, could you send me your public IP addresses? (use whatismyipaddress.com for example). You can send them to [email protected] I need to identify the failing requests in the access log. Thanks!

  • NathanBoukNathanBouk USMember
    edited March 2013

    Thank you Lluis, it was fixed for me.

    edit: And by fixed, I mean the update server is contacted, but the update won't install.

    Action start 22:07:40: RemoveExistingProducts.
    CustomAction returned actual error code 1612 (note this may not be 100% accurate if translation happened inside sandbox)
    MSI (s) (BC:40) [22:07:46:276]: Product: Xamarin Studio 4.0.2 -- Error 1714. The older version of Xamarin Studio 4.0.2 cannot be removed. Contact your technical support group. System Error 1612.

  • ImantzImantz LVMember

    Have been trying updating every day, but still no joy for me - there's an error every time.

  • LluisSanchezLluisSanchez ESXamarin Team Xamurai
    edited March 2013

    For everybody that still has problems getting updates, try deleting all the files you'll find in the following directories:

    On Mac:

    • ~/Library/Monotouch

    • ~/Library/MonoAndroid

    On Windows:

    • C:\ProgramData\Mono for Android\License

    • C:\ProgramData\MonoTouch\License

    This will trigger a reactivation of the products, and should fix the issue.

  • ImantzImantz LVMember

    OK, thanks, I'll try it once I get home.
    Think I already tried that though, but will do once again.

  • ImantzImantz LVMember

    Works like a charm, thanks a lot :)

  • dejwidhdejwidh USMember

    It doesn't help. I've got XS 4.0.

  • LluisSanchezLluisSanchez ESXamarin Team Xamurai

    @dejwidh: to help diagnosing the issue, could you please send the following information to [email protected]?

    • The detailed version information from the Xamarin Studio about box.

    • The Xamarin Studio log file. You can open the folder where it is located by clicking on the option Help -> Open Log Directory. Just grab the most recent log file named Ide.something.

    • The Updater.log file from the same directory, if you have it.

    • Your public IP address

    Anyone else having this problem, please send me that info. Thanks!

  • Hello lluis, i have the same problem.
    If i remember it correct: at the first start of xamarin today the updater has automaticly found the f# update. A later manual try to update resulted in the known error.Attached are my informations, no updater.log file.
    Thanks,
    Thomas

    87.193.233.103

    === Xamarin Studio ===

    Version 4.0.1 (build 9)

    Installation UUID: 52d3599d-fe8f-40e9-9937-ee3d014f4b72

    Runtime:

    Microsoft .NET 4.0.30319.18033
    
    GTK 2.24.13
    
    GTK# (2.12.0.0)
    

    === Xamarin.Android ===

    Version: 4.4.54

    Android SDK: C:\Program Files (x86)\Android\android-sdk

    Supported Android versions:
    
        2.1 (API level 7)
    
        2.2 (API level 8)
    
        2.3 (API level 10)
    
        3.1 (API level 12)
    
        4.0 (API level 14)
    
        4.1 (API level 16)
    
        4.2 (API level 17)
    

    Java SDK: C:\Program Files (x86)\Java\jdk1.6.0_31

    === Build Information ===

    Git revision: Release ID: 400010009

    4d204dd3370ed4de8ae6194b08208bcf11129eca

    Build date: 2013-03-05 12:49:29Z

    Xamarin addins: 181e75e43f263f1c0783b9f7e32234cac6850998

    === Operating System ===

    Windows 6.2.9200.0 (64-bit)

  • Problem:

    "Check for updates" returns "Error retrieving update information".

    Situation:

    It turns out it's because I had no internet connection when XS first started up which resulted in the error in every attempt to "Check for updates" even though my internet connection was ok.

    Solution:

    Just restart XS - problem solved :)

  • LeighBowersLeighBowers GBMember
    edited April 2013

    I'm still having the issue.

    OSX, XS 4.0.3 (build 13)

    I see the following in the log:

    "Failed license update: Invalid entitlements"

    Has my license not activated correctly?

  • LluisSanchezLluisSanchez ESXamarin Team Xamurai

    @MilkyJoe: try deleting all the files you'll find in those directories:

    ~/Library/Monotouch
    ~/Library/MonoAndroid

  • LeighBowersLeighBowers GBMember

    That did the trick. Thanks Iluis

  • TonyFonagerTonyFonager DKInsider ✭✭

    I removed the suggested folders, and that fixed my problem. Thanks ALOT!

  • MassimoGentiliMassimoGentili USMember

    :( I first delete the files, then then also the folder, but nothing change :( I still get the error

  • DanielNordmarkDanielNordmark SEMember ✭✭

    Same issue for me!
    I've deleted the folders / files but still no luck on any of the update channels.

    Xamarin, what to do? Is it possible to manually download the update?

  • DavidJeskeDavidJeske USMember ✭✭
    edited April 2013

    I'm seeing the error on Beta/Alpha channels. I'm trying to get 4.0.4 because of the XCode problem (4.0.3 is busted and won't build anything).

    Xamarin Studio 4.0.3 (build 13)

    XCode Version 4.6.2 (4H1003)

    There is no updater.log, see ide.log below..

    Current public IP is: 24.130.35.20 (comcast)

    ide.log follows....

    2013-04-22 13:53:23.078 XamarinStudio[2800:1007] *** WARNING: Method userSpaceScaleFactor in class NSView is deprecated on 10.7 and later. It should not be used in new applications. Use convertRectToBacking: instead.
    Starting Xamarin Studio

    ERROR [2013-04-22 13:53:23Z]: Error loading Xcode information for prefix '/Applications/Xcode.app/Contents/Developer'
    System.FormatException: Input string was not in the correct format
    at System.Int32.Parse (System.String s) [0x00014] in /private/tmp/source/bockbuild/profiles/mono-2-10/build-root/mono-2.10.12/_build/mono-2.10.12.git/mcs/class/corlib/System/Int32.cs:625
    at MonoDevelop.MacDev.AppleSdkSettings.Init () [0x001b0] in /Users/builder/data/lanes/monodevelop-lion-bs1/fae7c2bd/source/md-addins/MonoDevelop.MacDev/MonoDevelop.MacDev/AppleSdkSettings.cs:183

    ERROR [2013-04-22 13:53:24Z]: Failed to load MonoTouch entitlements: Invalid entitlements
    Loading Workbench
    Initializing Main Window

    ERROR [2013-04-22 13:53:24Z]: Failed to load MonoAndroid entitlements: Invalid entitlements

    WARNING [2013-04-22 13:53:25Z]: First run content index not found.

    MacDir exists

    Basedir=/Library/Frameworks/Mono.framework/Versions/2.10.12/lib/monodoc

    Error: did not find one of the files in sources//Library/Frameworks/Mono.framework/External/monodoc/MonoAndroid-man

    ERROR [2013-04-22 14:00:59Z]: Failed license update: Invalid entitlements

    ERROR [2013-04-22 14:00:59Z]: Failed license update: Invalid entitlements

  • ChrisHardyChrisHardy GBForum Administrator, Xamarin Team Xamurai

    @DavidJeske You will probably need to get Xcode 4.6.1 installed as the Xcode 4.6.2 will cause an issue with the updater too - http://forums.xamarin.com/discussion/comment/10620/#Comment_10620

  • patlaplantepatlaplante USMember

    I have 2 macs (1 macbook pro and 1 imac)... The macbook pro works fine... The imac won't update... always get the error updating and the log tells me Failed license update......

    Really frustrating!

  • patlaplantepatlaplante USMember

    Just installed xcode 4.6.1... Tried an update from xamarin, still no luck...

  • rfogrfog ESMember

    Same problem here.

    Xamarin Studio 4.0.3, xCode 4.6.1 or 4.6.2, deleted files in Library, no luck. In my Mid 2011 iMAC and Mid 2012 MacBook Pro Retina...

  • EmanueleSabettaEmanueleSabetta ITBeta ✭✭✭

    Same problem here. :(

  • LluisSanchezLluisSanchez ESXamarin Team Xamurai

    @rfog, @EmanueleSabetta, @DavidJeske: If you deleted the contents of ~/Library/MonoAndroid and it still fails, could you please send me the contents of that folder to [email protected]? (the contents are regenerated when XS is started)

  • rfogrfog ESMember

    Hi LLuis!

    I solved issue removing Xamarin and reinstalling it from a new download, that installs 4.0.4 version that does not have the fail (or at least works for me). I removed it with CleanMyMac in order to remove all installed files and configs.

    If you still want the contents of that folder, please ask.

  • PaulRivers.0341PaulRivers.0341 GBMember, Beta

    I too am currently having this issue if anyone has any pointers...

  • GaetanTestGaetanTest USMember
    edited July 2013

    I can't use my Xamarin account beacause the Xamarin server seems to have a problem : (I'm on Windows.)

    Mono.VisualStudio.Shell.ShellPackage Error: 0 : There was an error while contacting the activation server
    System.Net.WebException: The server returns an error : (500) Internal server error.
       à System.Net.HttpWebRequest.GetResponse()
       à Xamarin.Components.Ide.ApiClients.WebRequestUtils.<>c__DisplayClass1.<DoRequest>b__0()
       à System.Threading.Tasks.Task`1.InnerInvoke()
       à System.Threading.Tasks.Task.Execute()
    

    Moreover, I have the following message when I try to view my account on the Xamarin website : > Sorry, an error occurred while processing your request.

    Update Xamarin doesn't solve the problem.

    What can I do ?

  • MJJamesMJJames GBMember, Beta

    @GaetanTest I am also hitting that problem all work ground to a halt here :( just waiting on a status update from Xamarin, hopefully it won't be a long outage

Sign In or Register to comment.