Xamarin App does not run on Android emulator

ArnoHofmannArnoHofmann DEMember
edited August 2014 in Xamarin.Android

The Android emulator starts but the app does only appear briefly. I can see the app icon but when I touch it the app appears briefly again. Every Android app I've tested did't work. I use Xamarin Studio 5.2.

Best Answer

Answers

  • PhilRyanPhilRyan AUMember ✭✭

    What versions of the Android SDK are you using on the emulator? It may be that the Apps you are trying to run are aimed at higher SDK versions. SDK release 15 is Android 4.0.3, and currently has about 80%+ of the user base (or more).

    Try the "out of the box" Xamarin examples - you can download full working Xamarin Android apps - and if they won't work, then you probably need to play with the Android Virtual Device creation (AVD), possibly with your system settings (do you have enough RAM on your system? How recent is your PC or Mac that you are programming on?)

  • ArnoHofmannArnoHofmann DEMember
    • Android SDK: 19
    • I tried "out of the box" sample MobileCRM
    • I tried multiply AVD emulators
    • I have 16 GB RAM on my iMac
    • iMac 2014
    • It works on my real device!
    • My next step is, I'm going to test it with GenyMotion
  • SebastianSeidel.9226SebastianSeidel.9226 DEInsider, University ✭✭✭✭

    Are there any error messages appearing in the application output panel? I experience a similar behavior if I use a charting library that requires hardware acceleration.

  • Tobias_StuggTobias_Stugg DEMember

    Hello Arno,

    the emulator doesn't work above level 12. Connect a Android device (mobile or tablet) in debug-mode and test it with this.

    Tobi

  • CheesebaronCheesebaron DKInsider, University mod

    @TobiasRathgeber that is nonsense, it works just fine at any API level. Although it is slow when running the ARM images. So be sure to create an AVD with an X86 image and if you have an Intel CPU install HAXM.

  • Tobias_StuggTobias_Stugg DEMember

    Thanx! i'll try it..

  • ArnoHofmannArnoHofmann DEMember
    edited August 2014

    As I told in my post above an Android device works well :-).

    My emulator settings are:

    • Device: Galaxy Nexus (4.65", 720 x 1280: xhdpi)
    • Target: API Level 19
    • CPU/ABI: Intel Atom (x86)
    • RAM: 1024 MiB
    • Internal Storage: 1024 MiB
    • SD Card 1024 MiB

    Output:

    Build succeeded.
    0 Warning(s)
    0 Error(s)

    The GenyMotion emulator works fine as well! This solve my problem.

    Thank you very much to all for their help.

Sign In or Register to comment.