Step Over not working in debugger

Hi,

when I'm doing a step over anywhere in the code the app just stops and displays this in the output (5.2, build 366):

Step request failed: Exception of type 'Mono.Debugger.Soft.VMDisconnectedException' was thrown.

Any ideas on how to resolve this?

Thanks,

Rogier

Posts

  • JeffreyStedfastJeffreyStedfast USXamarin Team Xamurai

    This means that the app is crashing for some reason. Hard to know for sure why, but it's probably a bug in the Mono runtime.

    I'd recommend filing a bug report on https://bugzilla.xamarin.com

    If you could, it would be good to attach device logs.

  • rogiheerogihee NLMember ✭✭✭

    I think it is in the mono part too, in the debugger agent:
    https://bugzilla.xamarin.com/show_bug.cgi?id=21488

    Here is the important part:
    Jul 21 21:36:43 app [327] : * Assertion at ../../../../../mono/mono/mini/debugger-agent.c:3597, condition `klass' not met

  • DerekHagenDerekHagen USMember ✭✭

    I get the same error when trying to update my Markers on a map:

    The following line gets the error and kills the debug:
    dicMarkers["m1"].Position.Latitude = _Settings.Latitude;

    I also tried this with same issue:
    dicMarkers["m1"].Position.Latitude = (new Android.Gms.Maps.Model.LatLng(_Settings.Latitude, ._Settings.Longitude));

    The output shows this:

    08-14 12:42:54.950 F/ (19066): * Assertion at /Users/builder/data/lanes/monodroid-mlion-monodroid-4.14-series/a5d57087/source/mono/mono/mini/debugger-agent.c:3597, condition `klass' not met
    08-14 12:42:54.950 E/mono-rt (19066): Stacktrace:
    08-14 12:42:54.950 E/mono-rt (19066):
    08-14 12:42:54.950 E/mono-rt (19066):
    08-14 12:42:54.950 E/mono-rt (19066): =================================================================
    08-14 12:42:54.950 E/mono-rt (19066): Got a SIGSEGV while executing native code. This usually indicates
    08-14 12:42:54.950 E/mono-rt (19066): a fatal error in the mono runtime or one of the native libraries
    08-14 12:42:54.950 E/mono-rt (19066): used by your application.
    08-14 12:42:54.950 E/mono-rt (19066): =================================================================
    08-14 12:42:54.950 E/mono-rt (19066):
    08-14 12:42:57.169 I/dalvikvm(19066): threadid=4: reacting to signal 3
    08-14 12:42:57.177 I/dalvikvm(19066): Wrote stack traces to '/data/anr/traces.txt'

  • DerekHagenDerekHagen USMember ✭✭

    actually my line above should say:
    dicMarkers["m1"].Position = (new Android.Gms.Maps.Model.LatLng(_Settings.Latitude, ._Settings.Longitude));

    But I still get same error and result.

  • rogiheerogihee NLMember ✭✭✭

    My error has resolved itself somehow by a new update, can't pinpoint exactly when.

  • PeterDavisPeterDavis USMember ✭✭✭

    I'm getting this error as well. I can land on breakpoints, but if I try to step, it crashes my app.

  • Same problem here. New project in VS2013 and when step to an next line in debug modes, the following:

    • Assertion at /Users/builder/data/lanes/1131/62e09eb0/source/mono/mono/mini/debugger-agent.c:3652, condition `klass' not met
  • I started getting this bug too after installing the September releases. It happens almost every time, please fix it. I use Xamarin.Android 4.16.0.17 (2a7b68212b17c903160fbd8e0106babb299d1be3). I am downgrading for the time being.

  • Zoltan, this is great. When will this version be released?

Sign In or Register to comment.