Forum Visual Studio

TrialCheckChanges failure during build (iOS)

MakaniMakani USMember

After successfully pairing with my iOS build machine, I created a brand new Xamarin Forms project and attempted to run the Hello World app as-is in the iPhone Simulator. The build succeeds but deployment errors out with the following log:

1>Build started.
1>Server returned an error. The remote server returned an error: (500) Internal Server Error.
1>Server error code: 500
1>Internal Server Error
1>TrialCheckChanges failure during build
1>Exception thrown: Object reference not set to an instance of an object
1>
1>Remote build step failed.

I attempted to use an iPhone device (my device shows up in Visual Studio). But again, same error. When I try a different MacBook Pro it works fine. But with the MacBook I want as my build box I have this error.


More background as to exact reproduction steps:
1) I created a new xamarin trial account and installed xamarin on a Windows 7 machine.
2) I also installed xamarin on a MacBook Pro that I had with existing team accounts already in XCode.
3) I created a Xamarin Forms template project and the iOS deployment worked perfectly. So did Android. But Windows Phone did not. I tried closing and restarting Visual Studio, and then every time I would try to build my solution, it would crash visual studio. Eventually I discovered that I had to delete the Windows Phone project everytime I used the template to create a new solution, and then it would not crash.
4) SO I decided to upgrade my Windows 7 to Windows 8.1 Pro in an attempt to fix the Windows Phone issue.
5) I had to revoke the license to my windows 7 machine and re-assign it to the same machine with Windows 8.1 Pro (after installing Visual Studio 2013 and Xamarin again, still using the trial license).
6) Simultaneously, I also decided to use a different MacBook Pro for development, as the other one was not owned by me. I installed XCode and Xamarin on it, and again revoked the license on the other MacBook Pro and redirected the license to this MacBook Pro.
7) I created a new Apple developer account, created a provisioning profile, app id, including a wildcard one, etc..
8) I created a Xamarin Forms project on the new MacBook Pro successfully using Xamarin Studio and was able to deploy the project onto my iPhone 5 with no issues.
9) Now in Visual Studio I changed the build server to my new MacBook Pro (although the old one still shows up). I had unpaired the old MacBook and started a new pairing with the new one. After some issues like not being able to read the SDK status and restarting stuff, it eventually paired successfully.
10) I then tried to deploy to the device, and then got the error above. Same thing with simulator.
11) I tried installing the Alpha version on the MacBook Pro, but still the same issue.
12) I switched back to using the other MacBook pro build server, which worked perfectly, even though its license had been revoked. This showed me that the problem was not on the Windows side.
13) I again paired with my new MacBook Pro and unfortunately I had the same issue.

The exact error on the Visual Studio side was pasted above.
Here is the error on the Mac side in the mtbserver.log file:

...
Starting pdb2mdb "FormsTemplateiOS.exe"
Starting /Developer/MonoTouch/usr/bin/mtouch -sdkroot "/Applications/Xcode.app/Contents/Developer" --entitlements
stdout: some_guid MonoTouch TRIAL 2014-07-27T04:42:02.

Command [Build: CommandUrl=Build] finished (14)

I tried running the same thing again on the other MacBook Pro and it seems to have the same stdout result except a different guid.

Any ideas what is going on? I really need a resolution on this problem ASAP please.

Thanks

Best Answer

Answers

  • adrinadrin USMember

    Seems like I might have ran into the same issue, trying to run hello world app through VS2013 on my mac server fails with:
    1>Server returned an error. The remote server returned an error: (500) Internal Server Error. 1>Server error code: 500 1>Internal Server Error 1><?xml version="1.0" encoding="utf-8"?><mtbs xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"><payload type="generic" code="Error" exitCode="0" serverStatusCode="200"><messages><message>TrialCheckChanges failure during build 1>Exception thrown: Object reference not set to an instance of an object</message></messages><async>false</async></payload></mtbs>

    Server log:
    [02-Jul-2014 11:44:34] Running tool: DebugInformationConverter [02-Jul-2014 11:44:35] Running tool: ContentCopier [02-Jul-2014 11:44:35] Running tool: TrialCheckChanges [02-Jul-2014 11:44:35] Error: Tool MonoTouch.Tools.Tools.TrialCheckChanges failed to run [02-Jul-2014 11:44:35] Exception: Exception type: System.NullReferenceException Object reference not set to an instance of an object at MonoTouch.Tools.Tools.TrialCheckChanges.RunInner (MonoTouch.Tools.Tools.RunInfo ri) [0x00000] in <filename unknown>:0 at MonoTouch.Tools.Tools.ToolBase.Run () [0x00000] in <filename unknown>:0 at Mtb.Server.Commands.Build.RunTools (System.Collections.Generic.List1 tools, ILoggingHelper logger) [0x00000] in :0`

    This is blocking me at the moment, will try wiping out Xamarin on mac and reinstalling. Running the project directly on a Mac works fine.

  • adrinadrin USMember

    Reinstalling Xamarin on Mac did not help, still the same issue - anyone can help to fix it or debug it?
    What does TrialCheckChanges tool do?

  • RezaMousaviRezaMousavi GBMember
    edited July 2014

    Exactly the same error here. Tried:

    1) Reinstalling on both machines

    2) Re-entering the trial credentials

    Failed to install an older version as only older versions of Xamarin Studio are available for trial users, so can not downgrade Xamarin.iOS and Xamarin.Android!

  • Same error message here. Tried uninstall/reinstall approach for both machines as well, with no luck.
    I am also using a trial license.

  • KevinDonahueKevinDonahue USMember

    Looks like I have the same issue. Is it a problem with the latest build versions of Xamarin?

  • XinXin USMember

    I've got the same error. Does upgrading to Business Edition solve the problem?

  • PatITPROPatITPRO USMember
  • PatITPROPatITPRO USMember

    Still does not work
    Windows:

    • downgraded to previous stable version: SDK issues, unable to debug
    • updated the SDK manually: no more issues, still unable to debug
    • run updater to get vs to the current stable version: TrialCheckChanges...

    I guess the mac installation is at fault (my build host still shows version 7.2.5.4) - and yes i tried uninstall/reinstall too
    App runs without problems when started from xamarin studio on the mac

  • SebastianNSebastianN DEMember
    edited July 2014

    I've got the same problem.
    Are there any updates?

  • adrinadrin USMember

    Hey guys, I managed to get it working. Unfortunately i am not sure what are the repro steps for the fix.
    I've reinstalled everything again (including xcode), used 7.2.3.39 Xamain,iOS version on mac and 3.0.54.0 on Windows... and the problem went away.

    It is probably urelated, but I've also noticed that when ran from command line, mtouch binary on mac complained about missing sdk:

    Framework does not exist /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneSimulator.platform/Developer/SDKs/iPhoneSimulator.sdk

    Because it is named iPhoneSimulator7.1.sdk (note 7.1) with the current xcode installation.

  • PJBeamanXPJBeamanX USXamarin Team Xamurai

    Hi everyone,

    We've identified the source of the issue, and will be releasing a hotfix shortly. In the meantime, you can downgrade to the previous stable versions of Xamarin.iOS and Xamarin for Visual Studio to get back up and running again.

    Downgrading

    If you would like to downgrade for now, you can download and install the previous versions of Xamarin from https://store.xamarin.com/account/my/subscription/downloads.

    Direct links to the previous stable builds:
    Xamarin.iOS 7.2.4.4
    Xamarin 3.0.56

    We apologize for the inconvenience,

    PJ

  • JurajJanecekJurajJanecek SKMember ✭✭

    Hi
    Im running latest versions but still not able to deploy on MAC from VS2013
    ios there some way how to get more info about error?
    thanks

  • OmkarchoudhariOmkarchoudhari USMember, University

    I am facing the same problem and i am using all the latest version , Can anyone please tell which all version should i use to avoid this error.??

Sign In or Register to comment.