Forum Libraries, Components, and Plugins
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Need information on updating to Firebase latest SDK

Hi! We all know that we need to update to the latest Firebase Crashlytics SDK as Fabric is going to be discontinued by Nov 15th as per official announcement.

Has anybody done this? Can you give the package version details and Google ads package version for iOS?? I'm using xamarin.forms
I tried updating to latest SDK for both crashlytics SDK and Google Ads for iOS but got an error which I opened here - https://github.com/xamarin/GoogleApisForiOSComponents/issues/456

Any help is much appreciated. Thanks

Best Answer

  • mac121mac121 Member ✭✭✭
    Accepted Answer

    Thank you very much @jezh!

    By God's grace, I got it working in the same existing solution.. I had to upgrade all firebase, Ads and Analytics packages to the latest version that depend on Xamarin.Build.Download.

    Really appreciate the support :smile:

Answers

  • jezhjezh Member, Xamarin Team Xamurai

    I tried updating to latest SDK for both crashlytics SDK and Google Ads for iOS but got an error which I opened here

    Did your app have this problem before you upgraded your app?

    Besides, could you please post the full error log about this problem?

  • mac121mac121 Member ✭✭✭
    Thanks for your reply jezh!

    No, I didn't have this error before upgrade.

    I want to know the latest working version number of Firebase SDK for my xamarin.forms app - to address the old Fabric libraries
  • jezhjezh Member, Xamarin Team Xamurai

    Then you can try to delete bin and obj folders, then restart VS and try again .

    If the issue still exists, could you please post a basic demo to github or OneDrive so that we can try to reproduce this problem on our side?

  • mac121mac121 Member ✭✭✭
    edited November 18
    Sure, thanks a lot for your help. I'll check this
  • jezhjezh Member, Xamarin Team Xamurai

    Waiting for your good news. :)

  • mac121mac121 Member ✭✭✭
    Accepted Answer

    Thank you very much @jezh!

    By God's grace, I got it working in the same existing solution.. I had to upgrade all firebase, Ads and Analytics packages to the latest version that depend on Xamarin.Build.Download.

    Really appreciate the support :smile:

  • jezhjezh Member, Xamarin Team Xamurai

    Congrats, could you please mark the useful reply as answered so that it will help others who have similar problems?

    Thanks in advance. :)

Sign In or Register to comment.