Forum Xamarin.Forms
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Xamarin Forms: UWP app clicking is not working as expected

SreeeeSreeee INMember ✭✭✭✭✭

I have a weird issue with my UWP version of the xamarin forms project. The clicking is not working as expected. Sometimes no response when clicking items (button, image), and sometimes top items are opening when clicking an item.

Please watch this video for getting a clear idea. In this video, I am clicking the next button(Quiz page) several times, but no response. On the game page, the top item pages are opening when clicking an item. In android and ios, everything is working fine.

Version Details:

Xamarin Forms: 4.7.0.968
UWP target version: Windows 10, version 1903(10.0;Build 18362)
UWP Min version: Windows 10, Fall Creators Update(10.0; Build 16299)

Please help me to find the issue behind this. Thanks in advance.

Best Answer

  • SreeeeSreeee INMember ✭✭✭✭✭
    Accepted Answer

    @ColeX I have solved this issue by updating the xamarin forms version to 4.8.0.1269.

Answers

  • ColeXColeX Member, Xamarin Team Xamurai

    It might be some view overlapping the button , or you're setting very small size on that button , could you post the code in Quiz page ?

  • SreeeeSreeee INMember ✭✭✭✭✭

    @ColeX Here is the button code

    <Button 
        Text="NEXT"
        TextColor="White"
        HorizontalOptions="EndAndExpand"
        BackgroundColor="#f5c74c" 
        Clicked="NextButtonClicked"
        WidthRequest="150"
        HeightRequest="40"
        FontSize="18"
        BorderRadius="20"/>
    
    public void NextButtonClicked(object sender, EventArgs args)
    {
        //action
    }
    
  • ColeXColeX Member, Xamarin Team Xamurai

    Could you post the complete code which could reproduce the problem ?

  • SreeeeSreeee INMember ✭✭✭✭✭
    Accepted Answer

    @ColeX I have solved this issue by updating the xamarin forms version to 4.8.0.1269.

Sign In or Register to comment.