Forum Xamarin.Android
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

One Signal for Xamarin - how use with Android X?

ZenDroidZenDroid USMember ✭✭✭

I using OneSignal(3.10.1) in my Xamarin Forms app. I have problem with android. I use some package I use several packages that need Android X. This is:

-BarcodeScanner.XF
-Xam.Plugins.Android.ExoPlayer

But OneSignal using CompileSdkVersion - Android 9(Api Level 28). When I try install OneSignal in android project(for Android 10) than I get this error:

   BarcodeScanner.XF 4.8.0 -> Xamarin.Android.Support.Compat (>= 28.0.0.3) 
   Com.OneSignal 3.10.1 -> Xamarin.Android.Support.CustomTabs 26.0.2 -> Xamarin.Android.Support.Compat (= 26.0.2).  

So for the single packages I need Android X for the other ones - Android 9(CompileSdkVersion). How do I solve this problem and is it possible?

Sign In or Register to comment.