Forum Xamarin.Forms
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Issue with grouped list view

FXamainFXamain Member ✭✭
I am facing a wierd issue. I have a grouped list view it is working fine while loading the page, but when trying to load the same with same data on button click using a command, it's not showing up, anyone has any idea what is going on there

Best Answer

Answers

  • LandLuLandLu Member, Xamarin Team Xamurai

    Did you use binding or set the items source directly?
    If you are resetting the source with binding, it could be caused by the property changed interface.
    Have you implemented the INotifyPropertyChanged on the view model?
    Could you please share some code here to help reproduce the issue?

  • FXamainFXamain Member ✭✭

    We are setting the item source using the Bindings

    We were initializing the object only on button click. I have tried out a sample and you can find the sample application below which i have added to the github https://github.com/AlfinFelixA/SampleApp.git. Hope this helps

  • FXamainFXamain Member ✭✭

    Thanks. it Worked

  • LandLuLandLu Member, Xamarin Team Xamurai

    If it is helpful to you, could you please mark my reply as the answer?

Sign In or Register to comment.