Forum Xamarin.iOS
We are excited to announce that the Xamarin Forums are moving to the new Microsoft Q&A experience. Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

We encourage you to head over to Microsoft Q&A for .NET for posting new questions and get involved today.

Application could not be uploaded to the device (Push Notifications)

KvotheKingkillerKvotheKingkiller Member ✭✭
edited September 1 in Xamarin.iOS

I'm having difficulty trying to launch my app with Push Notifications after following all the directions. Here's what I've done so far.

Followed the tutorial in Microsoft Docs. https://docs.microsoft.com/en-us/azure/notification-hubs/xamarin-notification-hubs-ios-push-notification-apns-get-started




Sorry, can't show a lot of the content, but here are pictures of me verifying everything is set up to what I believe is correct. Apple provisioning profile confirms that Push Notifications are enabled. I've checked the Enable Push Notifications box inside of the entitlements.plist. I've tried both checking and unchecking Enable Background Modes and Remote notifications for the plist. I've added and verified the KeyID, BundleID, TeamID, and Token all match for certificate/profile and my azure account.

I've tried signing automatically with signing into my apple account through visual studio and I've tried manually signing, redownloading and installing the new provisioning profile. My phone device is registered in the provisioning profile.

Note that as soon as I uncheck Enable Push Notifications the app launches just fine. I've cleaned, restarted. No idea what what else I'm missing from the documentation.

As for the error...here it is.

ApplicationVerificationFailed: Failed to verify code signature of /private/var/installd/Library/Caches/com.apple.mobile.installd.staging/temp.U6eXTr/extracted/MYAPPNAME.iOS.app : 0xe8008016 (The executable was signed with invalid entitlements.)
error MT1006: Could not install the application '/Users/MYNAME/repos/MYAPPNAME.iOS/bin/iPhone/Debug/device-builds/iphone11.8-13.6.1/MYAPPNAME.iOS.app' on the device 'MYDEVICENAME': Your code signing/provisioning profiles are not correctly configured. Probably you have an entitlement not supported by your current provisioning profile, or your device is not part of the current provisioning profile. Please check the iOS Device Log for details (error: 0xe8008016).

Also note that this works fine in release mode, but not debug mode. So not sure what other settings need to be toggled for that.

Best Answer

Answers

  • Thank you, ColeX. That was it!

Sign In or Register to comment.