Forum Xamarin.iOS

Provisioning Profile not showing up on IOS Bundle Signing

BennyBooBennyBoo Member ✭✭
edited June 29 in Xamarin.iOS

Hey I've been stuck on this for a while.
I have made a bunch of different provisioning profiles on apple: https://developer.apple.com/account/resources/profiles/list
And for some reason they are not showing up on the IOS Bundle Signing. I have changed the Signing Identity's and still nothing is showing up.
Also my computer is connected to it and I've followed all the steps on all the forms posts, nothing seems to work, can you please help me out.
It would be greatly appreciated if you could help
-- Thank you very much!

I didn't setup XCode before hand

Best Answer

Answers

  • LandLuLandLu Member, Xamarin Team Xamurai

    Have you installed these provisioning profiles on the Mac?
    Make sure the corresponding certificate has been installed on the Mac too.
    Besides, the certificate should be found in the My Certificates:

  • BennyBooBennyBoo Member ✭✭

    I see the Certificates in Keychain access, but i can't find the provisioning profiles. Ive downloaded them off the apple websites and all it does is just open xcode and do nothing in Visual Studios

  • BennyBooBennyBoo Member ✭✭

    You can see the distribution Identity here, I am using the correct Bundle Identifier and everything triple checked.

    and in preferences you can see the provisioning profile and ive downloaded the profiles many times and its not showing up in the Bundle Signing. im also using the correct Distribution account.

    What could be the fix with this.

    -- Thank you
    Ben

  • LandLuLandLu Member, Xamarin Team Xamurai

    What kind of provisioning profile is it?
    I saw you chose a distribution certificate and the corresponding profiles should be distribution too. Or it won't be shown up there.
    The second thing you could check is your project's Bundle ID. Did it match this profile?
    You could also test this in XCode directly. Try to create a project with the same ID in XCode to see if you could choose the provisioning profile there.

  • BennyBooBennyBoo Member ✭✭

    Yeah the provisioning profile is for distribution, and I tried it in XCode and it says the signing certificate was the problem. I have all the signing certificates fine so i dont know why that would be the problem

  • BennyBooBennyBoo Member ✭✭

    Thank you, I had a problem with a second Distribution ID that was interfering with the profile i was trying to get to work. I confirmed with XCode and everything worked, Thank you!

  • LandLuLandLu Member, Xamarin Team Xamurai

    If the issue has been solved, please mark it to end our conversation.

Sign In or Register to comment.