Forum Xamarin.iOS

Announcement:

The Xamarin Forums have officially moved to the new Microsoft Q&A experience. Microsoft Q&A is the home for technical questions and answers at across all products at Microsoft now including Xamarin!

To create new threads and ask questions head over to Microsoft Q&A for .NET and get involved today.

Error In Run Simulator In Xamarin Forms

elahi1mahdielahi1mahdi Member ✭✭

i create new project xamarinforms (android and ios)
i use virtual box to run mac (catalina 10.15.3) and install xcode 10.15 and visual mac
and pair mac in visual connected successfully

but when run app in visual studio its show this error to me, whats problem ?

Answers

  • LandLuLandLu Member, Xamarin Team Xamurai

    Could the simulator open successfully on the VM without checking the remote simulator?

    Please notice that we should avoid installing Mac VM on a Windows machine. This violates Apple's policy.

  • elahi1mahdielahi1mahdi Member ✭✭

    uncheck remote Simulator to Windowns

    but in error list vs show this error

    Severity Code Description Project File Line Suppression State
    Error error HE0042: Could not launch the app 'com.companyname.Xamarin_App' on the device 'iOS 13.3 (17C45) - iPhone 11': The request to open "com.companyname.Xamarin_App" failed. 0

    befor i used mac high sierra and xcode 9 its worked correctly
    i have problem with xcode 10.13 and 10. & Catalina

  • LandLuLandLu Member, Xamarin Team Xamurai

    Did this occur on Xcode 11.13 or 11.15?
    May I ask why not update to the latest version of XCode and Mac OS.
    Is your visual studio 2019 compatible with the version of XCode?

  • elahi1mahdielahi1mahdi Member ✭✭
    edited June 2020

    @LandLu said:
    Did this occur on Xcode 11.13 or 11.15?
    May I ask why not update to the latest version of XCode and Mac OS.
    Is your visual studio 2019 compatible with the version of XCode?

    My Vs Is Latest Version 16.2.6
    XCode 10.15
    Mac : Catalina 15.3

  • LandLuLandLu Member, Xamarin Team Xamurai

    The latest version of Visual Studio 2019 is 16.6.2:
    https://docs.microsoft.com/en-us/visualstudio/releases/2019/release-notes
    And to make it compatible with the latest iOS version, it's better to update your XCode to 11.5.

  • elahi1mahdielahi1mahdi Member ✭✭

    sorry i'm typing incorrect : its 16.6.2 its true

  • elahi1mahdielahi1mahdi Member ✭✭
    edited June 2020

    @LandLu

    i uncheck the remote simulator on windows
    i now run it but in error list visual i have this error
    and can't lunch app

    error
    1 > App2->C:\Users\Admin\source\repos\App2\App2\App2\bin\Debug\netstandard2.0\App2.dll 2 > ------Build started: Project: App2.iOS, Configuration: Debug iPhoneSimulator ------ 2 > Executing SayHello Task to establish a connection to a Mac Server. 2 > Properties: SessionId = 9511606702053f44efd1e461893cb636, 2 > ServerPort = 55143, 2 > ServerAddress = 192.168.56.105, 2 > ServerUser = Mahdi, 2 > ServerPassword =, 2 > SSHKey =, 2 > SSHPassPhrase =, 2 > AppName = App2.iOS, 2 > ContinueOnDisconnected = False 2 > App2.iOS->C:\Users\Admin\source\repos\App2\App2\App2.iOS\bin\iPhoneSimulator\Debug\App2.iOS.exe 2 > Detected signing identity: 2 > Bundle Id: com.companyname.App2 2 > App Id: com.companyname.App2 2 > / Library / Frameworks / Xamarin.iOS.framework / Versions / Current / bin / mtouch @/ Users / mahdi / Library / Caches / Xamarin / mtbs / builds / App2.iOS / 9511606702053f44efd1e461893cb636 / obj / iPhoneSimulator / Debug / response - file.rsp ========== Build: 2 succeeded, 0 failed, 0 up-to-date, 0 skipped ========== ========== Deploy: 0 succeeded, 0 failed, 0 skipped ========== Launching 'App2.iOS' on 'iPhone 8 iOS 13.5'... Launching... Using Xcode 11.5 found in /Applications/Xcode.app/Contents/Developer Xamarin.Hosting: Xamarin.Hosting Xamarin.Hosting: Version: 27e82f1595 (d16-6) Xamarin.Hosting: Xcode: /Applications/Xcode.app Xamarin.Hosting: Xcode Version: 11.5 Xamarin.Hosting: Verbosity: 1 Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTFoundation.framework/Versions/A/DVTFoundation Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTiPhoneSimulatorRemoteClient.framework/DVTiPhoneSimulatorRemoteClient Xamarin.Hosting: Loaded /Library/Developer/PrivateFrameworks/CoreSimulator.framework/CoreSimulator Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DTDeviceKitBase.framework/DTDeviceKitBase Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTKit.framework/DVTKit Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DTDeviceKit.framework/DTDeviceKit Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DTXConnectionServices.framework/DTXConnectionServices Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTSourceControl.framework/DVTSourceControl Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTServices.framework/DVTServices Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTPortal.framework/DVTPortal Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTDocumentation.framework/DVTDocumentation Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTAnalyticsClient.framework/DVTAnalyticsClient Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/DVTAnalytics.framework/DVTAnalytics Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/SourceKit.framework/SourceKit Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/Frameworks/IDEFoundation.framework/IDEFoundation Xamarin.Hosting: Loaded /Applications/Xcode.app/Contents/SharedFrameworks/IDEProducts.framework/IDEProducts Xamarin.Hosting: Simulator watchdogs are not disabled for 'iOS 13.5 (17F61) - iPhone 8'. Xamarin.Hosting: Successfully disabled simulator watchdogs for 'iOS 13.5 (17F61) - iPhone 8'. Xamarin.Hosting: Launching simulator application 'com.apple.iphonesimulator' Xamarin.Hosting: Booting iPhone 8... Xamarin.Hosting: Booted iPhone 8 successfully. Copying in /Users/mahdi/Library/Caches/Xamarin/mtbs/builds/App2.iOS/9511606702053f44efd1e461893cb636/bin/iPhoneSimulator/Debug/App2.iOS.app/.monotouch-64 Xamarin.Hosting: No need to boot (already booted): iPhone 8 Xamarin.Hosting: Installing /Users/mahdi/Library/Caches/Xamarin/mtbs/builds/App2.iOS/9511606702053f44efd1e461893cb636/bin/iPhoneSimulator/Debug/App2.iOS.app with Bundle Identifier com.companyname.App2 on 'iOS 13.5 (17F61) - iPhone 8'... Xamarin.Hosting: Installed 'com.companyname.App2' from /Users/mahdi/Library/Caches/Xamarin/mtbs/builds/App2.iOS/9511606702053f44efd1e461893cb636/bin/iPhoneSimulator/Debug/App2.iOS.app Xamarin.Hosting: Could not find any potentially troublesome weak load commands. Xamarin.Hosting: The bundle id com.companyname.App2 was successfully installed. Xamarin.Hosting: Launching com.companyname.App2 on 'iOS 13.5 (17F61) - iPhone 8' Xamarin.Hosting: Could not launch the app 'com.companyname.App2' on the device 'iOS 13.5 (17F61) - iPhone 8': The request to open "com.companyname.App2" failed., will try to reinstall the app Xamarin.Hosting: Installing /Users/mahdi/Library/Caches/Xamarin/mtbs/builds/App2.iOS/9511606702053f44efd1e461893cb636/bin/iPhoneSimulator/Debug/App2.iOS.app with Bundle Identifier com.companyname.App2 on 'iOS 13.5 (17F61) - iPhone 8'... Xamarin.Hosting: Installed 'com.companyname.App2' from /Users/mahdi/Library/Caches/Xamarin/mtbs/builds/App2.iOS/9511606702053f44efd1e461893cb636/bin/iPhoneSimulator/Debug/App2.iOS.app Xamarin.Hosting: Could not find any potentially troublesome weak load commands.

    the app is terminated

  • LandLuLandLu Member, Xamarin Team Xamurai

    There could be some caches on your simulators.
    Try to open the simulator => Device => click on Erase All Content and Settings....
    It seems you have installed all the latest version tools. Try to delete the bin/obj folders, clean and rebuild again.

  • elahi1mahdielahi1mahdi Member ✭✭
    edited June 2020

    @LandLu said:
    There could be some caches on your simulators.
    Try to open the simulator => Device => click on Erase All Content and Settings....
    It seems you have installed all the latest version tools. Try to delete the bin/obj folders, clean and rebuild again.

    i remove bin/obj and clean , rebuild again but not worked

    but i can't Erase All Content and Settings In device because the device is not lunch at all

  • LandLuLandLu Member, Xamarin Team Xamurai

    I saw the log said your simulator has Booted iPhone 8 successfully.
    Could you please check it out on the Mac?

  • elahi1mahdielahi1mahdi Member ✭✭

    I don't understand what you mean
    you say open the simulator but the simulator dose not open and lunch at all.
    how to open it and go to settings to Erase All Content and Settings ? how to do it ?

  • elahi1mahdielahi1mahdi Member ✭✭

    i do it > @LandLu said:

    There could be some caches on your simulators.
    Try to open the simulator => Device => click on Erase All Content and Settings....
    It seems you have installed all the latest version tools. Try to delete the bin/obj folders, clean and rebuild again.

    i do it but in error list show this error
    **Could not launch the app 'com.companyname.App2' on the device 'iOS 13.5 (17F61) - iPhone 8': The request to open "com.companyname.App2" failed.
    **

  • elahi1mahdielahi1mahdi Member ✭✭
    edited June 2020

    This is the only place I can ask, but I'm disappointed

    There is no one to help , its very instantaneous

    by the way
    visual studio mac and visual studio windos , ios version is 13.18.2.1
    i lunch app with ios 13.5

    there is no have any problem ?

  • Hi elahi1mahdi, did you manage to solve the problem? if yes, how?

    @elahi1mahdi said:
    This is the only place I can ask, but I'm disappointed

    There is no one to help , its very instantaneous

    by the way
    visual studio mac and visual studio windos , ios version is 13.18.2.1
    i lunch app with ios 13.5

    there is no have any problem ?

  • elahi1mahdielahi1mahdi Member ✭✭

    @PierpaoloPirozzi said:
    Hi elahi1mahdi, did you manage to solve the problem? if yes, how?

    @elahi1mahdi said:
    This is the only place I can ask, but I'm disappointed

    There is no one to help , its very instantaneous

    by the way
    visual studio mac and visual studio windos , ios version is 13.18.2.1
    i lunch app with ios 13.5

    there is no have any problem ?

    just change xcode ios version to lower

Sign In or Register to comment.