Forum Xamarin.Android

debug error filelock_lock

YujinYujin Member ✭✭

In my environment, when "adb devices" command is executed, "emulator-5554" is displayed as "device" in "List of devices attached".

However, when "Debug" is executed in that state, "filelock_lock: error not already exists" is displayed and the application cannot be executed.

Is this missing adb settings?
Or are there any files that need to be put in the emulator?

please answer.

Best Answer


  • YujinYujin Member ✭✭

    Execute command:
    "C:\Program Files (x86)\Android\android-sdk\emulator\emulator.exe" -partition-size 512 -no-boot-anim -verbose -feature WindowsHypervisorPlatform -avd pixel_2_pie_9_0_-api_28 -prop monodroid.avdname=pixel_2_pie_9_0-_api_28


  • YujinYujin Member ✭✭


  • ColeXColeX Member, Xamarin Team Xamurai

    Have you tried to create emulator in Android Device Manager ?

    Does the problem persist when you run the emulator in visual studio ?

  • YujinYujin Member ✭✭


    I created a device on android device manager.

    But, The same error message is displayed on visualStudio.

  • YujinYujin Member ✭✭

    Thank you.

Sign In or Register to comment.